Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Regular Contributor
jlf175
Posts: 51
Registered: ‎08-13-2009
My Device: Not Specified

Emails not appearing on boss's new BB

Hi

I've registered my boss's Z10 into the Blackberry system and it appears to have taken the activation password. However, on the "work space" side of the phone the emails/contacts/calendar of his account in Exchange are not appearing or appear to be syncing. 

 

BB Services are on one box with an internal IP address. Database on SQL 2008 separate box.

Firewall settings are correct

Exchange server is Exchange 2010


Here's the steps I've done.

1. Created a user in the BES 10 Device Service and assigned activation password.

2. On the phone I went into System Settings --> Accounts -->  Add Account --> email, calendar, and contacts

3. entered boss's email address

4. Click Next

5. Provide activation password

6. Get blackberry balance welcome screen

7. Set workspace and device password to be same

** Activation complete ** message

 

Get put back to the Add Account page

Click Back

In System Settings

Exit that screen and get back to main screen

 

Message appears about blackberry balance and how to use it (drag finger down middle and tap personal or work).

 

I click Work

 

No email indicator

Nothing in contacts or calendar.

 

If it makes a differnece the screen background is purple.

 

AT&T is telling me that he has the BES plan

 

 

Enterprise SME
-BD-
Posts: 551
Registered: ‎05-15-2008
My Device: Z10

Re: Emails not appearing on boss's new BB

It doesn't sound like you've create an email profile and assigned it to the user. 

Regular Contributor
jlf175
Posts: 51
Registered: ‎08-13-2009
My Device: Not Specified

Re: Emails not appearing on boss's new BB

Where is this done?  I setup the user's Active Directory account into the BES 10 server and his name, email, and phone PIN apper in the BES 10 user listing. 

Enterprise SME
-BD-
Posts: 551
Registered: ‎05-15-2008
My Device: Z10

Re: Emails not appearing on boss's new BB

Expand profiles in BAS and create a new Email profile and add your Activesync settings in there.  Then manage the user and go to the email tab and apply the profile there.

 

You can also see page 30 of:

 

http://docs.blackberry.com/en/admin/deliverables/52736/BlackBerry_Enterprise_Service_10_version_10.1...

Regular Contributor
jlf175
Posts: 51
Registered: ‎08-13-2009
My Device: Not Specified

Re: Emails not appearing on boss's new BB

This is very possible. I was treating this like my old BES server and I don't recall setting up an Activesync connection for that. I simply typed in user's email address and activation password on their phone and it would sync up their work email to their phone.

Regular Contributor
jlf175
Posts: 51
Registered: ‎08-13-2009
My Device: Not Specified

Re: Emails not appearing on boss's new BB

ActiveSync is active on the Exchange 2010 server.  When I navigate the ActiveSync https:\\ URL page from the Blackberry 10 server I'm prompted for network credentials.  I enter those and get a 501/505 error. From what I have read this is normal.  I checked ActiveSync settings in Exchange and no rules or policies are set there.

 

All  BB services are on one server. This server does not have a public facing IP address or FQDN. It strictly runs internally. There is no firewall between the BB server and Exchange server.  They are on the same subnet


On my email profile settings in Blackberry Devices Services, I have this

type: Microsoft Activesync

server name: <<server name>>

Use SSL: YES

Push: yes

Days to sync: 30

Interval betee: 5 minutes

Require manual sync: no

Email/Calendar/Contact/Memo/Task synch: yes

 

SCEP profile: blank

 

S/mime messages: allowed

digitally signed s/mime: allowed

Encrypted S/mime: allowed

All ciphers unchecked.

 

So let's test an email then....

I then go to DEVICES--> Wireless Activations--> Device Activation settings

Edit Activation settings

 

"Allow activation information to be emailed: YES"

Error appears: An error was encounted when connecting to the SMTP server. Please verify the SMTP server settings are correct and that the Blackberry Service Service can connect to the SMTP server.

 

Notification settings --> SMTP Configuration

This appears to work as I sent a test message to my own inbox and received it.

 

 

Regular Contributor
jlf175
Posts: 51
Registered: ‎08-13-2009
My Device: Not Specified

Re: Emails not appearing on boss's new BB

We appear to be working now.  I tried setting up his phone again and this time it prompted him for his email account password (i.e. his network password).  After that everything started syncing up just fine. I made no changes to the system since my last post on Friday evening.

 

When speaking with  Blackberry support last week they stated that AT&T might not have setup his phone with the right Blackberry account type. This appears to have been the case. He was previously on the BES account but blackberry stated it should be the 'advanced' account type now.  Not sure of the difference, just that it works now.