Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Contributor
Posts: 10
Registered: ‎04-10-2012
My Device: mobile fusion
My Carrier: O2

Re: Fusion Installation / Problem with certificate

I´m sorry that I don`t explain this:

We have a lot of external IP Addresses and a lot of FQDN.

For testing the cert issue, I change the IP and the FQDN and reqest a new certificate from an external trust center names entrust.

 

We using the same FQDN in the ssl certificate. I have check this and this match exactly 

 

Thanks a lot for your assistance.

 

Lars

New Contributor
Posts: 2
Registered: ‎04-12-2012
My Device: Bold 9780
My Carrier: Vodafone

Re: Fusion Installation / Problem with certificate

Hi all,

 

I have the same problem.

I've tried to create again the certificate but always the same error.

The FQDN, the subject name, the certificate have been verified, all of them are correct.

Is there someone who got a solution ? :smileyhappy:

 

Many thanks :smileyhappy:

 

New Contributor
Posts: 9
Registered: ‎04-12-2012
My Device: BB 9700 + Playbook
My Carrier: T-Mobile

Re: Fusion Installation / Problem with certificate

[ Edited ]

Hello,

 

I have exactly the same Problem. Tried nearly any possible certificate (with and without SANs, Created with CSR or directly on Windows Ent CA, Globalsign, Self Signed, Windows Ent CA) it shows this error every time.

 

I have found the the same messages in the logfile:

 

<#03>[30000] (04/11 12:59:51.189):{0x970} CCertificateWrapper starting...
<#03>[30000] (04/11 12:59:51.189):{0x970} CCertificateWrapper:arseCertificate executing - [C:\Windows\SysWOW64\certutil.exe -p "XXXXXXXX" -v "C:\xxx.pfx"]
<#03>[30000] (04/11 12:59:51.267):{0x970} CProcessWrapper::RunCommand: The exit code of the process for C:\Windows\SysWOW64\certutil.exe -p******** -v "C:\xxxx.pfx" is [0].
<#03>[30000] (04/11 12:59:51.267):{0x970} CProcessWrapper::RunCommand: Successfully launched the process: C:\Windows\SysWOW64\certutil.exe -p******** -v "C:\xxx.pfx"
<#03>[30000] (04/11 12:59:51.267):{0x970} CCertificateWrapper:arseCertificate executed Return Code is [0]
<#01>[10000] (04/11 12:59:51.283):{0x970} CCertificateWrapper:arseCertificate - The certificate line []
<#03>[30000] (04/11 12:59:51.283):{0x970} CPasswordDataCon::Base64Encode succeeded
<#03>[30000] (04/11 12:59:51.283):{0x970} CCertificateWrapper:arseCertificate executed, result is [0]
<#01>[10000] (04/11 12:59:51.283):{0x970} CUbitexxCommunicationDataCon::Validate: The subject in SSL certificate is empty.
<#01>[10000] (04/11 12:59:51.283):{0x970} CDataContainer:smileysurprised:Validate: UbitexxCommunicationDataCon failed to validate. Result: 486007.
<#01>[10000] (04/11 12:59:51.283):{0xB48} CDataContainer:smileysurprised:Validate: UbitexxCommunicationDataCon failed to validate. Previous result: 486007.
<#01>[10000] (04/11 12:59:51.283):{0x970} [UbitexxCommunicationDataCon:smileysurprised:Validate]: PreviousValidationResult failed
<#03>[30000] (04/11 12:59:51.283):{0x970} Could not load a caption - defaulting to banner title.
<#04>[40000] (04/11 12:59:51.891):{0x970} UbitexxCommunicationDlg executes EnableControls.

 

I have tried the certutil command in commandline and can't find an error. As written in http://www.blackberry.com/btsc/KB29639 under resolution 2, the result [0] indicates, that the result [0] is ok for certutil.

 

C:\Users\administrator.Domain\AppData\Local\Temp\Certificate_Wrapper.txt shows the result of certutil

 

 

So the next step done by the UDS Installer must be the problem:

 

CUbitexxCommunicationDataCon::Validate: The subject in SSL certificate is empty.

 

I'am using an German OS, so maybe the Installer has an language problem (searching subject but there is only  Antragsteller) or something in the the subject field is a problem (too many aditional information like E=xxx@xxx.xx).

 

I will try to test this
 

New Contributor
Posts: 3
Registered: ‎04-11-2012
My Device: Bold
My Carrier: TIM

Re: Fusion Installation / Problem with certificate

Also for me, with certutil i have no errors and my OS is in Italian. Maybe it works only for English??
Contributor
Posts: 10
Registered: ‎04-10-2012
My Device: mobile fusion
My Carrier: O2

Re: Fusion Installation / Problem with certificate

I´m using a german OS, too.

All our systems like SQL, Server 2008R2 are in german.

 

Has enyone a solution to fix this problem?

Yesterday I have test all combinations with the cert. But nothing works for usw!

 

I heard yesterday, the Ubitexx Suite was a great application. But what makes rim with this? They create a not working application.

New Contributor
Posts: 2
Registered: ‎04-12-2012
My Device: Bold 9780
My Carrier: Vodafone

Re: Fusion Installation / Problem with certificate

I've tried changing the OS language in English and it works !

Contributor
Posts: 10
Registered: ‎04-10-2012
My Device: mobile fusion
My Carrier: O2

Re: Fusion Installation / Problem with certificate

That ist right!

I have setup a machine with english OS and it works!

Oh yes, that was a very hard problem. May thanks to Fr3Sh! You have faced the problem!

 

@RIM: Please note this in your installation sheet!!!!

Contributor
Posts: 10
Registered: ‎04-11-2012
My Device: 9900
My Carrier: Rogers

Re: Fusion Installation / Problem with certificate

Was searching for something in their kb's this morning and found this so it looks like they have noticed this issue:

 

http://www.blackberry.com/btsc/KB31259

Contributor
Posts: 10
Registered: ‎04-10-2012
My Device: mobile fusion
My Carrier: O2

Re: Fusion Installation / Problem with certificate

That is very cool. The KB article is from today. Nice

New Contributor
Posts: 3
Registered: ‎04-11-2012
My Device: Bold
My Carrier: TIM

Re: Fusion Installation / Problem with certificate

I hope for a fast fix!