If you are using Internet Explorer, please remove blackberry.com from your compatibility view settings.

Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black
My Carrier: Vodafone

Re: Installation Universal Device Service fails

sorry, meant the same drive, not the same directory

we`ve already changed the ports for all services.

 

Do we have to install all 3 Setups in the default folder?

 

 

Please use plain text.
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black
My Carrier: Vodafone

Re: Installation Universal Device Service fails

what i`ve done so far:

- uninstalled all RIM Software

- installed BDS to drive C --> OK

- installed Management Studio to drive C --> OK

 

install UDS to drive C --> not working

- tried default and individual installation

- reinstalled .net framework 4

- used a new CAL and SRP Identifier

 

UDS Error Screenshot

 

Setup Log

<#03>[30000] (01/29 08:08:38.580):{0x1130} CConfigToolComp::ResetTargetDir: Successfully reset the targetdir.
<#03>[30000] (01/29 08:08:40.638):{0x1130} CMSIWrapper::Install succeeds after 0 retries
<#03>[30000] (01/29 08:08:40.639):{0x1130} CMsiComponent::Install: Successfully installed ConfigTool.
<#03>[30000] (01/29 08:08:40.640):{0x1130} CShortcutWrapper::RemoveShortcut: Successfully removed the shortcut. [C:\ProgramData\Microsoft\Windows\Start Menu\Programs\BlackBerry Enterprise Service 10\Universal Device Service\Blackberry Universal Device Service Configuration.lnk].
<#03>[30000] (01/29 08:08:40.640):{0x1130} CConfigToolComp::RemoveConfigToolShortcut: Successfully removed the shortcut.
<#03>[30000] (01/29 08:08:40.640):{0x1130} CShortcutWrapper::RemoveShortcut: Successfully removed the shortcut. [C:\ProgramData\Microsoft\Windows\Start Menu\Programs\BlackBerry Mobile Fusion\Universal Device Service\Universal Device Service Configuration.lnk].
<#03>[30000] (01/29 08:08:40.640):{0x1130} CConfigToolComp::RemoveConfigToolShortcut: Successfully removed the old product shortcut.
<#03>[30000] (01/29 08:08:40.641):{0x1130} CShortcutWrapper::RemoveShortcut: Successfully removed the shortcut. [C:\ProgramData\Microsoft\Windows\Start Menu\Programs\BlackBerry Enterprise Service 10\Universal Device Service\Blackberry Universal Device Service Configuration.lnk].
<#03>[30000] (01/29 08:08:40.641):{0x1130} CShortcutWrapper::CreateShortcut: Parent directory [C:\ProgramData\Microsoft\Windows\Start Menu\Programs\BlackBerry Enterprise Service 10\Universal Device Service] already exists or created.
<#03>[30000] (01/29 08:08:40.828):{0x1130} CShortcutWrapper::CreateShortcut: Successfully saved the link. [C:\ProgramData\Microsoft\Windows\Start Menu\Programs\BlackBerry Enterprise Service 10\Universal Device Service\Blackberry Universal Device Service Configuration.lnk].
<#03>[30000] (01/29 08:08:40.828):{0x1130} CConfigToolComp::CreateConfigToolShortcut: Successfully created the shortcut.
<#03>[30000] (01/29 08:08:40.828):{0x1130} CConfigToolComp::Install: Successfully updated the config tool path in registry.
<#03>[30000] (01/29 08:08:40.828):{0x1130} CComponent::smileyvery-happy:oInstall - finishing install/uninstall for ConfigTool
<#03>[30000] (01/29 08:08:40.828):{0x1130} Successfully installed ConfigTool.
<#03>[30000] (01/29 08:08:40.828):{0x1130} Installing RIM BUDS Communication...
<#03>[30000] (01/29 08:08:41.777):{0x1130} CMSIWrapper::Install succeeds after 0 retries
<#03>[30000] (01/29 08:08:41.778):{0x1130} CMsiComponent::Install: Successfully installed RIM BUDS Communication.
<#03>[30000] (01/29 08:08:41.778):{0x1130} CComponent::smileyvery-happy:oInstall - finishing install/uninstall for RIM BUDS Communication
<#03>[30000] (01/29 08:08:41.778):{0x1130} Successfully installed RIM BUDS Communication.
<#03>[30000] (01/29 08:08:41.778):{0x1130} Not installing component [Logging], as it is already installed.
<#03>[30000] (01/29 08:08:41.778):{0x1130} Not installing component [Logging], as it is already installed.
<#03>[30000] (01/29 08:08:41.778):{0x1130} Not installing component [Microsoft .Net Framework 4.0], as it is already installed.
<#03>[30000] (01/29 08:08:41.779):{0x1130} Installing RIM BUDS Scheduler...
<#03>[30000] (01/29 08:08:42.946):{0x1130} CMSIWrapper::Install succeeds after 0 retries
<#03>[30000] (01/29 08:08:42.946):{0x1130} CMsiComponent::Install: Successfully installed RIM BUDS Scheduler.
<#01>[10000] (01/29 08:08:42.947):{0x1130} CUbitexxSchedulerComp::CopyConfigFile: Failed to backup Scheduler Service Config
<#03>[30000] (01/29 08:08:42.947):{0x1ECC} Could not load a caption - defaulting to banner title.
<#03>[30000] (01/29 08:08:42.950):{0x1130} Step RunInstall failed
<#01>[10000] (01/29 08:08:42.950):{0x1130} [CUbitexxSchedulerComp::CopyConfigFile]: Failed ot backup scheduler service config

 

 

CE Install Log

MSI (s) (4C:88) [08:08:37:068]: Note: 1: 1728
MSI (s) (4C:88) [08:08:37:068]: Note: 1: 2205 2:  3: Error
MSI (s) (4C:88) [08:08:37:068]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1728
MSI (s) (4C:88) [08:08:37:068]: Note: 1: 2205 2:  3: Error
MSI (s) (4C:88) [08:08:37:068]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709
MSI (s) (4C:88) [08:08:37:068]: Product: CE -- Configuration completed successfully.

MSI (s) (4C:88) [08:08:37:069]: Windows Installer reconfigured the product. Product Name: CE. Product Version: 2.0.0.10. Product Language: 1033. Manufacturer: Research In Motion Ltd.. Reconfiguration success or error status: 0.

MSI (s) (4C:88) [08:08:37:070]: Deferring clean up of packages/files, if any exist
MSI (s) (4C:88) [08:08:37:070]: MainEngineThread is returning 0
MSI (s) (4C:FC) [08:08:37:073]: RESTART MANAGER: Session closed.
MSI (s) (4C:FC) [08:08:37:073]: No System Restore sequence number for this installation.
=== Logging stopped: 29/01/2013  08:08:37 ===
MSI (s) (4C:FC) [08:08:37:075]: User policy value 'DisableRollback' is 0
MSI (s) (4C:FC) [08:08:37:075]: Machine policy value 'DisableRollback' is 0
MSI (s) (4C:FC) [08:08:37:075]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (4C:FC) [08:08:37:075]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (4C:FC) [08:08:37:075]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (4C:FC) [08:08:37:075]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (s) (4C:FC) [08:08:37:076]: Restoring environment variables
MSI (c) (F4:A0) [08:08:37:078]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (F4:A0) [08:08:37:079]: MainEngineThread is returning 0
=== Verbose logging stopped: 29/01/2013  08:08:37 ===

 

Any other Ideas what we could try to install and use the software?

 

 

Please use plain text.
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black
My Carrier: Vodafone

Re: Installation Universal Device Service fails

so now back to the beginning:

 

- deleted all registry entries

--> now i can nearly install the software but stills fails during the last task

 

 

<#03>[30000] (01/29 11:22:37.779):{0x2234} CIISWrapper::GrantLogFolderPermissions Setting up the path with permissions. [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\].
<#03>[30000] (01/29 11:22:37.779):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [Users] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#01>[10000] (01/29 11:22:37.808):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions result for SetEntriesInAcl was [1332]
<#01>[10000] (01/29 11:22:37.808):{0x2234}  CIISWrapper::GrantLogFolderPermissionsfailed to set write permissions for Users group.
<#03>[30000] (01/29 11:22:37.808):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [IUSR] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#03>[30000] (01/29 11:22:37.845):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions Successfully applied write permission for User [IUSR] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#03>[30000] (01/29 11:22:37.845):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [IIS APPPOOL\ASP.NET v4.0] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#03>[30000] (01/29 11:22:37.990):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions Successfully applied write permission for User [IIS APPPOOL\ASP.NET v4.0] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#03>[30000] (01/29 11:22:37.990):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [IIS APPPOOL\UDS.CoreModule] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#03>[30000] (01/29 11:22:38.015):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions Successfully applied write permission for User [IIS APPPOOL\UDS.CoreModule] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#03>[30000] (01/29 11:22:38.015):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [IIS APPPOOL\UDS.CommunicationModule] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#01>[10000] (01/29 11:22:38.020):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions result for SetEntriesInAcl was [1332]
<#01>[10000] (01/29 11:22:38.020):{0x2234}  CIISWrapper::GrantLogFolderPermissions failed to set write permissions for 'IIS APPPOOL\UDS.COMMUNICATIONMODULE' user.
<#03>[30000] (01/29 11:22:38.020):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [DG\administrator] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#03>[30000] (01/29 11:22:38.049):{0x2234} CFileWrapper::smileyfrustrated:etPathWritePermissions Successfully applied write permission for User [DG\administrator] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#03>[30000] (01/29 11:22:38.049):{0x2234} CIISWrapper::GrantWindowsTempFolderPermissions Attempting to set write permission for User [Authenticated Users] on folder [C:\Windows\Temp]
<#01>[10000] (01/29 11:22:38.051):{0x2234} CIISWrapper::GrantWindowsTempFolderPermissions result for SetEntriesInAcl was [1332]

 

 

 

 

Please use plain text.
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black
My Carrier: Vodafone

Re: Installation Universal Device Service fails

Anyone an idea?

we´ve alread set the permission for the users and authenticated users group

 

<#03>[30000] (01/30 10:37:07.982):{0x1F6C} CIISWrapper::GrantLogFolderPermissions Setting up the path with permissions. [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\].

<#03>[30000] (01/30 10:37:07.982):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [Users] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#01>[10000] (01/30 10:37:07.990):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions result for SetEntriesInAcl was [1332]

<#01>[10000] (01/30 10:37:07.990):{0x1F6C}  CIISWrapper::GrantLogFolderPermissionsfailed to set write permissions for Users group.

<#03>[30000] (01/30 10:37:07.990):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [IUSR] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#03>[30000] (01/30 10:37:08.007):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Successfully applied write permission for User [IUSR] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#03>[30000] (01/30 10:37:08.007):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [IIS APPPOOL\ASP.NET v4.0] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#03>[30000] (01/30 10:37:08.101):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Successfully applied write permission for User [IIS APPPOOL\ASP.NET v4.0] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#03>[30000] (01/30 10:37:08.101):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [IIS APPPOOL\UDS.CoreModule] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#03>[30000] (01/30 10:37:08.109):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Successfully applied write permission for User [IIS APPPOOL\UDS.CoreModule] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#03>[30000] (01/30 10:37:08.109):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [IIS APPPOOL\UDS.CommunicationModule] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#03>[30000] (01/30 10:37:08.114):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Successfully applied write permission for User [IIS APPPOOL\UDS.CommunicationModule] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#03>[30000] (01/30 10:37:08.114):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [DG\BESadmin] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#03>[30000] (01/30 10:37:08.121):{0x1F6C} CFileWrapper::smileyfrustrated:etPathWritePermissions Successfully applied write permission for User [DG\BESadmin] on folder [C:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]

<#03>[30000] (01/30 10:37:08.121):{0x1F6C} CIISWrapper::GrantWindowsTempFolderPermissions Attempting to set write permission for User [Authenticated Users] on folder [C:\Windows\Temp]

<#01>[10000] (01/30 10:37:08.122):{0x1F6C} CIISWrapper::GrantWindowsTempFolderPermissions result for SetEntriesInAcl was [1332]

Please use plain text.
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black
My Carrier: Vodafone

Re: Installation Universal Device Service fails

well, we´ve managed the installation by creating both users/groups in English as a German server installation with the Englisch language pack is still using the German group and user names

 

Benutzer instead of users

Authentizierte Benutzer instead of  Authenticated Users

 

The only problem is that the Blackberry Web Service won´t start

 

Any idea fixing this?

Please use plain text.
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black
My Carrier: Vodafone

Re: Installation Universal Device Service fails -- Solution

[ Edited ]

okay, finally we finished the installation -- Solution

 

Complete Solution for BDS/UDS/Management Studio on a localized Server:

 

System:
Windows Server 2008 R2 German

all 3 apps on the same server

BES5 on a different one

 

1. installation BDS

2. UDS Installation fails (see other posts)

  • installation MS server English language pack
  • creating english local user groups (users & Authenticated User) with the same security credentials and permissions as the German ones (Benutzer und Authentifizierte User)
  • we had to reinstall the UDS because the Blackberry Web Service won`t start after the first time

3. Installation Management studio

4. Provide all websites to the management studio and provide the BES Admin User to the UDS

 

If you have any questions please feel free to contact me.

 

We`ve already connected a Playbook and a few ipads, still waiting for the BB10 device coming to Germany.

 

Regards

Simon

 

Please use plain text.
Forums Advisor I
oliwer
Posts: 581
Registered: ‎05-23-2008
My Device: BB10 and WiFi PB
My Carrier: .

Re: Installation Universal Device Service fails -- Solution

Thanks for the solution!
Please use plain text.
New Member
nitzerebb
Posts: 1
Registered: ‎04-14-2013
My Device: Z-10
My Carrier: Telekom

Re: Installation Universal Device Service fails -- Solution

[ Edited ]

@Simon2013

 

Hello Simon,

 

I don't have a local "Authentifizierte Benutzer" group on my Server.

I only have "Benutzer"

 

any ideas ?

 

Best regards Jan

Please use plain text.
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black
My Carrier: Vodafone

Re: Installation Universal Device Service fails -- Solution

Hallo Jan,

 

die Gruppe Authentifizierte Benutzer beginnt in der AD mit NT-AUTORITÄT = NT-AUTORITÄT\Authentifizierte Benutzer.

Sollte dann so aussehen:

 

Unbenannt-1.jpg

Please use plain text.