Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black

Installation Universal Device Service fails

Hello,


We would like to install the new BES 10 including the Universal Device Service but the setup fails everytime at the end.

 

<#03>[30000] (01/28 10:53:50.956):{0xFBC} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [IIS APPPOOL\UDS.CommunicationModule] on folder [D:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#01>[10000] (01/28 10:53:50.956):{0xFBC} CFileWrapper::smileyfrustrated:etPathWritePermissions result for SetEntriesInAcl was [1332]
<#01>[10000] (01/28 10:53:50.956):{0xFBC}  CIISWrapper::GrantLogFolderPermissions failed to set write permissions for 'IIS APPPOOL\UDS.COMMUNICATIONMODULE' user.
<#03>[30000] (01/28 10:53:50.956):{0xFBC} CFileWrapper::smileyfrustrated:etPathWritePermissions Attempting to set write permission for User [DG\BESadmin] on folder [D:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#03>[30000] (01/28 10:53:50.971):{0xFBC} CFileWrapper::smileyfrustrated:etPathWritePermissions Successfully applied write permission for User [DG\BESadmin] on folder [D:\Program Files (x86)\Research In Motion\Universal Device Service\Logs\]
<#03>[30000] (01/28 10:53:50.971):{0xFBC} CIISWrapper::GrantWindowsTempFolderPermissions Attempting to set write permission for User [Authenticated Users] on folder [C:\Windows\Temp]
<#01>[10000] (01/28 10:53:50.971):{0xFBC} CIISWrapper::GrantWindowsTempFolderPermissions result for SetEntriesInAcl was [1332]

 

We`ve already changed the language of the windows server for the installation user to english and set the write permission for the Authenticated Users on folder C:\Windows\Temp but doesn´t help to finish the installation

 

My questions:

Do we have to use a complete englisch windows server installation or is the problem installing UDS on drive d?

Or any other idea how to solve the problem and finish the installation?

 

Thanks
Simon

Forums Advisor I
oliwer
Posts: 581
Registered: ‎05-23-2008
My Device: BB10 and WiFi PB

Re: Installation Universal Device Service fails

Is the service account for UDS local Admin?
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black

Re: Installation Universal Device Service fails

the user has local admin rights

Forums Advisor I
oliwer
Posts: 581
Registered: ‎05-23-2008
My Device: BB10 and WiFi PB

Re: Installation Universal Device Service fails

Which error message do you get when it aborts the installation?
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black

Re: Installation Universal Device Service fails

[ Edited ]

BES Error Screenshot

 

Problem signature:
  Problem Event Name:    BEX
  Application Name:    Setup.exe_Universal Device Service
  Application Version:    6.2.1.10
  Application Timestamp:    50e9d133
  Fault Module Name:    Setup.exe
  Fault Module Version:    6.2.1.10
  Fault Module Timestamp:    50e9d133
  Exception Offset:    0026f71c
  Exception Code:    c0000417
  Exception Data&colon;    00000000
  OS Version:    6.1.7601.2.1.0.272.7
  Locale ID:    2057
  Additional Information 1:    ce72
  Additional Information 2:    ce722724bcf95bce2f86222821ffeb34
  Additional Information 3:    1411
  Additional Information 4:    1411a5ba457a7963ef9ec4613a0f1d9f

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

Forums Advisor I
oliwer
Posts: 581
Registered: ‎05-23-2008
My Device: BB10 and WiFi PB

Re: Installation Universal Device Service fails

Did you check http://www.blackberry.com/btsc/KB30251 and http://www.blackberry.com/btsc/KB32215 (last one says you should choose default directory and you said you are using custom directory - you should give it a try).
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black

Re: Installation Universal Device Service fails

[ Edited ]

thats the error when i choose the default install directory

 

 

7:59.392):{0x25C} CConfigToolComp::ResetTargetDir: Successfully reset the targetdir.
<#03>[30000] (01/28 13:48:01.148):{0x25C} CMSIWrapper::Install succeeds after 0 retries
<#03>[30000] (01/28 13:48:01.149):{0x25C} CMsiComponent::Install: Successfully installed ConfigTool.
<#03>[30000] (01/28 13:48:01.150):{0x25C} CShortcutWrapper::RemoveShortcut: Successfully removed the shortcut. [C:\ProgramData\Microsoft\Windows\Start Menu\Programs\BlackBerry Enterprise Service 10\Universal Device Service\Blackberry Universal Device Service Configuration.lnk].
<#03>[30000] (01/28 13:48:01.150):{0x25C} CConfigToolComp::RemoveConfigToolShortcut: Successfully removed the shortcut.
<#03>[30000] (01/28 13:48:01.150):{0x25C} CShortcutWrapper::RemoveShortcut: Successfully removed the shortcut. [C:\ProgramData\Microsoft\Windows\Start Menu\Programs\BlackBerry Mobile Fusion\Universal Device Service\Universal Device Service Configuration.lnk].
<#03>[30000] (01/28 13:48:01.150):{0x25C} CConfigToolComp::RemoveConfigToolShortcut: Successfully removed the old product shortcut.
<#03>[30000] (01/28 13:48:01.151):{0x25C} CShortcutWrapper::RemoveShortcut: Successfully removed the shortcut. [C:\ProgramData\Microsoft\Windows\Start Menu\Programs\BlackBerry Enterprise Service 10\Universal Device Service\Blackberry Universal Device Service Configuration.lnk].
<#03>[30000] (01/28 13:48:01.171):{0x25C} CShortcutWrapper::CreateShortcut: Parent directory [C:\ProgramData\Microsoft\Windows\Start Menu\Programs\BlackBerry Enterprise Service 10\Universal Device Service] already exists or created.
<#03>[30000] (01/28 13:48:02.358):{0x25C} CShortcutWrapper::CreateShortcut: Successfully saved the link. [C:\ProgramData\Microsoft\Windows\Start Menu\Programs\BlackBerry Enterprise Service 10\Universal Device Service\Blackberry Universal Device Service Configuration.lnk].
<#03>[30000] (01/28 13:48:02.358):{0x25C} CConfigToolComp::CreateConfigToolShortcut: Successfully created the shortcut.
<#03>[30000] (01/28 13:48:02.358):{0x25C} CConfigToolComp::Install: Successfully updated the config tool path in registry.
<#03>[30000] (01/28 13:48:02.358):{0x25C} CComponent::smileyvery-happy:oInstall - finishing install/uninstall for ConfigTool
<#03>[30000] (01/28 13:48:02.358):{0x25C} Successfully installed ConfigTool.
<#03>[30000] (01/28 13:48:02.359):{0x25C} Installing RIM BUDS Communication...
<#03>[30000] (01/28 13:48:04.408):{0x25C} CMSIWrapper::Install succeeds after 0 retries
<#03>[30000] (01/28 13:48:04.408):{0x25C} CMsiComponent::Install: Successfully installed RIM BUDS Communication.
<#03>[30000] (01/28 13:48:04.418):{0x25C} CComponent::smileyvery-happy:oInstall - finishing install/uninstall for RIM BUDS Communication
<#03>[30000] (01/28 13:48:04.418):{0x25C} Successfully installed RIM BUDS Communication.
<#03>[30000] (01/28 13:48:04.418):{0x25C} Not installing component [Logging], as it is already installed.
<#03>[30000] (01/28 13:48:04.418):{0x25C} Not installing component [Logging], as it is already installed.
<#03>[30000] (01/28 13:48:04.418):{0x25C} Not installing component [Microsoft .Net Framework 4.0], as it is already installed.
<#03>[30000] (01/28 13:48:04.419):{0x25C} Installing RIM BUDS Scheduler...
<#03>[30000] (01/28 13:48:05.971):{0x25C} CMSIWrapper::Install succeeds after 0 retries
<#03>[30000] (01/28 13:48:05.971):{0x25C} CMsiComponent::Install: Successfully installed RIM BUDS Scheduler.
<#01>[10000] (01/28 13:48:05.971):{0x25C} CUbitexxSchedulerComp::CopyConfigFile: Failed to backup Scheduler Service Config
<#03>[30000] (01/28 13:48:05.972):{0x1FAC} Could not load a caption - defaulting to banner title.
<#03>[30000] (01/28 13:48:05.974):{0x25C} Step RunInstall failed
<#01>[10000] (01/28 13:48:05.974):{0x25C} [CUbitexxSchedulerComp::CopyConfigFile]: Failed ot backup scheduler service config

 

 

BES Error Screenshot

 

Forums Advisor I
oliwer
Posts: 581
Registered: ‎05-23-2008
My Device: BB10 and WiFi PB

Re: Installation Universal Device Service fails

Try an uninstall first before you try to install it to the default location.
Contributor
simon2013
Posts: 19
Registered: ‎01-28-2013
My Device: Q10 black

Re: Installation Universal Device Service fails

already uninstalled and restarted the system. Do i have to install the BDS in the same directory?

Forums Advisor I
oliwer
Posts: 581
Registered: ‎05-23-2008
My Device: BB10 and WiFi PB

Re: Installation Universal Device Service fails

No, don't install it in the same directory. You also have to change ports if you want to install it on the same machine: http://www.blackberry.com/btsc/KB32547