Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
thejollyboys
Posts: 5
Registered: ‎07-05-2013
My Device: z10

Notifications not working in secure work space on IOS.

Hi Guy's,

 

I have an issue with the Secure Work Space and not getting notification of new email.

 

So when the app is open new email arrives but when the app is locked no notification is received.  So the number of unread does not increase.

 

I have followed the guide which is not great but still its not working.

 

1. Replaced the self signed certs on all the sites.

2. exported the root uds cert and installed on exchange cas array servers.

3. configure the web services in the settings tab of admin console.

4. restarted the notification service.

5. all ports are open to the relevant sites from the server.

 

In the asg.log i get tis error.

 

[2013-07-05 13:26:19,603] [http-apr-8088-exec-4] ERROR: NMUserDetailsService:185 - ADAM auth failed
[2013-07-05 13:26:19,614] [http-apr-8088-exec-4] ERROR: NMUserDetailsService:186 - ERROR - X509 key decoding failed.
com.openpeak.common.service.BusinessLogicException: X509 key decoding failed.

 

Also i get in the same log.

 

[2013-07-05 13:34:00,002] [schedulerFactory_Worker-8] INFO : EwsScheduleServiceImpl:141 - staring running polling email registrations from Adam server...
[2013-07-05 13:34:00,003] [schedulerFactory_Worker-8] ERROR: EwsScheduleServiceImpl:59 - ASG pulling is not running. You need to set adamBaseUrl with right value first....

Please use plain text.
Super Contributor
swotam
Posts: 323
Registered: ‎05-10-2011
My Device: Z10

Re: Notifications not working in secure work space on IOS.

The first set of errors sound like something to do with authentication. The second sounds like something didn't get configured correctly during installation.

If you look at the C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Service 10\RIM.BUDS.BWCN\conf\asg.xml file, what is the value for adamBaseUrl?
----------
BESX 5.0.4, SQL 2008, Exchange 2010 SP2 RU4a
Please use plain text.
New Contributor
thejollyboys
Posts: 5
Registered: ‎07-05-2013
My Device: z10

Re: Notifications not working in secure work space on IOS.

Thanks sotam,

 

In the xml the setting for adambaseurl is http://localhost:7070/adam/portal/opeak/admin#

 

Thanks

Please use plain text.
Super Contributor
swotam
Posts: 323
Registered: ‎05-10-2011
My Device: Z10

Re: Notifications not working in secure work space on IOS.

Hmm, in mine it's https://ca.swsmanager.bbsecure.com/adam/portal/asg/admin which is quite different from yours.

I'd suggest calling RIM on this one, sounds like something didn't get setup correctly.
----------
BESX 5.0.4, SQL 2008, Exchange 2010 SP2 RU4a
Please use plain text.
Contributor
rol801
Posts: 21
Registered: ‎07-20-2011
My Device: Torch 9810 Z10 Q10 Q5 A10

Re: Notifications not working in secure work space on IOS.

[ Edited ]

my test server build up since 6.0 release and upgrade / relocate alot of time till 10.1.1 .

 

The content in asg.xml file is correct but notification cant work properly and cause account lock up often.

as per i tried last night by modify db directly and crash acive sync gateway.. and i cant add or delete any server for EWS... and i have to reinstall everything again. (DB crash...)

 

however, upon clean installation complete. the content in asg.xml using localhost only..

and error message shows in UDS console / work space .. it shows The system could not enable Secure Work Space.

 

and i gest ADAM serverulr change upon APNs cert become valid..

 

1 more problem is.. upon UDS reinstalled, it requires me to apply APNs cert again and not allows me to import old cert.... but i had this cert already.. its so stupid while compare with other MDM software.....

Please use plain text.
Contributor
misquote
Posts: 23
Registered: ‎07-31-2009
My Device: Z10

Re: Notifications not working in secure work space on IOS.

Did anyone find a fix for this?

Please use plain text.
Contributor
mvannessjr
Posts: 16
Registered: ‎07-17-2013
My Device: BlackBerry Z10 STL100-3

Re: Notifications not working in secure work space on IOS.

Greetings again misquote,

 

Which issue are you referring to?  The first issue from the opening post is usually due to a punctuation character such as '&' or not UTF-8 character in the Certificate Subject/Common Name.

 

The second I've already responded to you.

 

Hope it helps!

Mark
Systems Analyst
---
BlackBerry Enterprise Server 5.0.4 (Bundle 100)
BlackBerry Enterprise Service 10.1.1
Microsoft Exchange 2013

Please use plain text.
Contributor
rol801
Posts: 21
Registered: ‎07-20-2011
My Device: Torch 9810 Z10 Q10 Q5 A10

Re: Notifications not working in secure work space on IOS.

after escalating the ticket to higher level and a long long call phone call . server function resume past tuesday...23/07 , since SRP reuse and action requires to perform in infrastructure....

 

whole case takes 9 days from case report to resolve..

 

however, notification for secure work space stop working after at 25/07 17:18 suddenly without any reason..

server reboot few times but cant help.. then request case reopen again..

however... it resume again after 26/07/ 21:23 . there's no action taken in time between except server reboot and logs download...and expect related to latest BES10 client...

 


below are some of the suggestion for notification setup...

Exchange EWS virtual directory - windows authentication require

services account password - try using 4 characters with lower character only..

 

latest problem found... when ipad become landscape , double notification might appears sometimes...


this happen since server resume at 23/07..

 

 

strange....

Please use plain text.
Contributor
rol801
Posts: 21
Registered: ‎07-20-2011
My Device: Torch 9810 Z10 Q10 Q5 A10

Re: Notifications not working in secure work space on IOS.

More updates..

 

since it works suddenly last night.. but function stop again around 12:00 (noon) since last notification in device at 11:48 a.m

and no notification comes out again.... OMG..... what happen up there.....

Please use plain text.
Contributor
squishmike
Posts: 17
Registered: ‎03-14-2012
My Device: Curve 9300

Re: Notifications not working in secure work space on IOS.

Anyone have a fix for that AdamBaseURL issue? We get the same errors in our asg.log. The value in our xml file is also localhost. That doesn't seem to be the right value. We are on Exch 2003 Sp2. No push notifications on Android phone unless the work space is unlocked and open.

Please use plain text.