Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Highlighted
Contributor
Posts: 19
Registered: ‎05-15-2013
My Device: Z10
My Carrier: Vodafone

SOCKS Proxy setting in UDS / Secure Connection not working? BES 10.1.1

Hi there,

 

once again, I tried to get UDS working but again, the proxy is the show stopper.

 

I installed UDS/BDS on a server on the internal network. BDS is connecting through Blackberry Router in the DMZ, but UDS cannot use this Router. So what I learned from different posts here is that UDS needs a connection to (in my case) de.bbsecure.com on 3101, and IF it is not possible to allow direct communication from internal to external network, a "non-transparent proxy" aka "TCPIP Proxy" aka SOCKS Proxy shall be configured.

So I configured our SOCKS4 Proxy in UDS Management ("Settings" -> "Secure Connect Service" ->  "Enable TCP Proxy" checked, correct IP and Port entered). Service restarted.

Looking at the BSC log I find this:

 

2013-08-28 08:45:30,166 WARN [pool-12-thread-1] [,] TcpClientConnector - SSL Handshake failed to complete in 15 secs
2013-08-28 08:45:30,167 WARN [pool-12-thread-1] [,] ApplicationEndpoint - Unable to connect to EndpointInfo[host=172.26.xxx.yyy,port=zzzz,tls=false,mode=<null>], failureStreak is 11.
2013-08-28 08:46:00,163 WARN [pool-12-thread-1] [,] TcpClientConnector - SSL Handshake failed to complete in 15 secs
2013-08-28 08:46:00,164 WARN [pool-12-thread-1] [,] ApplicationEndpoint - Unable to connect to EndpointInfo[host=172.26.xxx.yyy,port=zzzz,tls=false,mode=<null>], failureStreak is 12.
2013-08-28 08:46:30,167 WARN [pool-12-thread-1] [,] TcpClientConnector - SSL Handshake failed to complete in 15 secs
2013-08-28 08:46:30,168 WARN [pool-12-thread-1] [,] ApplicationEndpoint - Unable to connect to EndpointInfo[host=172.26.xxx.yyy,port=zzzz,tls=false,mode=<null>], failureStreak is 13.
2013-08-28 08:47:00,165 WARN [pool-12-thread-1] [,] TcpClientConnector - SSL Handshake failed to complete in 15 secs
2013-08-28 08:47:00,166 WARN [pool-12-thread-1] [,] ApplicationEndpoint - Unable to connect to EndpointInfo[host=172.26.xxx.yyy,port=zzzz,tls=false,mode=<null>], failureStreak is 14.

 

(IP and port replaced).

 

It seems as UDS does not recognize the Proxy Settings but wants to connect to my proxy directly. If I use Proxifier to send the network packets to the proxy everythings works fine. So I fear this is a bug in UDS.

 

Any ideas / comments?

 

 

cheers

 

eKKi