Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
BooMeringue
Posts: 9
Registered: ‎09-03-2012
My Device: 9860

Sync problems for a single user, CDO/MAPI errors

[ Edited ]

We run BES 5.0.3 MR7 on Exchange 2007 with around 400 users.

 

One of our users keeps getting issues with Mail and calendar not synchronising properly.

 

Looking at the CDO/MAPI logs I see the following errors repeatedly for this user alone:

 

[30147] (08/31 15:42:12.261):{0x1F40} {user@domain.com} MAPIMailbox::RefIDtoEntryID - FindRow (0x8004010f) failed

 

[30002] (09/03 11:04:20.579):{0x16E0} Server = servername, Mailbox = /o=EXCHANGE/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=username Description = [Collaboration Data Objects - [MAPI_E_LOGON_FAILED(80040111)]]

 

[30147] (09/03 08:54:33.442):{0x1940} {user@domain.com} MAPIMailbox::UpdateRIMMessageState - SetProps (0x8004010f) failed

 

I've had a search around and seen various issues to do with CDO and MAPI with different fixes suggested, but I thought my issues was slightly unusual in that it was only affecting a single user.

 

I've checked the permissions on his mailbox and our BES service account has admin permissions. Any help on follow up steps gratefully received.

New Contributor
BooMeringue
Posts: 9
Registered: ‎09-03-2012
My Device: 9860

Re: Sync problems for a single user, CDO/MAPI errors

I should mention that the handset has been wiped and reactivated a couple of times, and the user has been completely removed from the BES and re-added.

Guru III
knottyrope
Posts: 30,921
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Sync problems for a single user, CDO/MAPI errors

when you removed from BES, did you wait 30 minutes? users are not deleted right away but queued for removal.

 

 


run this test on the affected user

http://docs.blackberry.com/en/admin/deliverables/25747/Verify_Win_account_access_to_Exchange_usrs_61...


Double check permission according to this

 

KB02276 - Assigning permissions for a BlackBerry Enterprise Server service account

 

 



KB15582 - BlackBerry Enterprise Server might not work correctly in Microsoft Exchange environments w...

 

 



What is the BESAdmin service account?
http://supportforums.blackberry.com/t5/BlackBerry-Enterprise-Solution/What-is-the-BESAdmin-service-a...

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


New Contributor
BooMeringue
Posts: 9
Registered: ‎09-03-2012
My Device: 9860

Re: Sync problems for a single user, CDO/MAPI errors

Thanks, knotty.

 

I did run IEMSTest for the user, everything succeeded except for EWS. I've noticed a CDO.dll version mismatch between the BES and exchange and decided that we'll try switching over to using EWS rather than CDO.

 

The user has an issue with email sync, as well as calendar - could this be caused by the CDO version mismatch?

Guru III
knottyrope
Posts: 30,921
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Sync problems for a single user, CDO/MAPI errors

CDO mismatch can cause it. BES must be equal or higher than Exchange.

 

 

 

 

CDO 1.2.1 from here
http://www.microsoft.com/downloads/details.aspx?FamilyID=94274318-27c4-4d8d-9bc5-3e6484286b1f&Displa...

 

 

 

KB15779 How to install or upgrade CDO 1.2.1



 

KB20676 March 2010 Daylight Savings Time Update

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


New Contributor
BooMeringue
Posts: 9
Registered: ‎09-03-2012
My Device: 9860

Re: Sync problems for a single user, CDO/MAPI errors

Hmm, the version of CDO.dll on the BES is higher than on the Exchange server - perhaps a red herring.

 

Well, using EWS seems like a good idea generally. I have to get it through our change control process then I'll report back to say if it fixed the problem.

New Contributor
BooMeringue
Posts: 9
Registered: ‎09-03-2012
My Device: 9860

Re: Sync problems for a single user, CDO/MAPI errors

[ Edited ]

Well we've implemented the change but when I try to run traittool -list on a user or messaging agent that I've configured for EWS it returns nothing.

 

When I run IEMSTest for a user that I've configured for EWS it returns everything successful as below:

 

BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Version 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - BES Administrator (bes_server)

User: Opening message store using /o=exchange/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients/cn=user/o=EXCHANGE/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=servername/cn=Microsoft Private MDB
User: Mailbox opened successfully
User: Root Folder opened successfully
User: Folder created successfully
User: Test folder deleted successfully
User: MAPI test completed successfully
User: CDO Server Name: servername
User: CDO Mailbox DN: /o=exchange/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients/cn=user
User: CDO logon successful
User: Get default calendar folder successful
User: Get calendar folder name successful: 'Calendar'
User: CDO test completed successfully
User: Active Directory permissions test completed successfully
User: Initializing EWS Proxy... successful
User: Configuring User... successful
User: EWS calendar find request... successful

 

How can I get traittool -list to work so I can confirm that EWS has successfully enabled? Am I being stupid here?

 

Just to add some extra info, here is the command that I used to enable EWS on the test messaging agient (201):

traittool -server servername -agent 201 -trait EWSEnable -set true where servername is the hostname of our BES

 

This returns:
EWSEnable: Added 'true' Server:servername(1),Agent:201(201) again servername is the hostname of the BES, not sure what the (1) means.

 

The command I run to try and verify EWS enabled is:

traittool -agent 201 -list

 

...which returns nothing.

New Contributor
BooMeringue
Posts: 9
Registered: ‎09-03-2012
My Device: 9860

Re: Sync problems for a single user, CDO/MAPI errors

Ok I am being stupid. I just needed to include the -server parameter e.g.

traittool -server servername -agent 201 -list

 


It returns:

EWSEnable: true

 

:-)

New Contributor
BooMeringue
Posts: 9
Registered: ‎09-03-2012
My Device: 9860

Re: Sync problems for a single user, CDO/MAPI errors

And we run into the next problem.

 

IEMSTest returns everything successful when I run it for our pilot user (me), as above. However, if I run IEMSTest for other users the EWS calendar find request still comes up as failed. I've only been able to find one other user that it succeeds for, who happens to be another BES admin. If I run it for one of our full exchange admins though, it fails. Guess I need to start ;looking at permissions...

Guru III
knottyrope
Posts: 30,921
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Sync problems for a single user, CDO/MAPI errors