Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Member
trevorj
Posts: 1
Registered: ‎02-11-2013
My Device: BlackBerry Z10
My Carrier: Telus

UDS Fails to Install on Server with BDS and BMS Already Installed.

Hi all,

 

Hope someone can assist with this issue. UDS install is failing with the following error:

 


<#01>[10000] (02/11 18:57:00.851):{0x1C50} CXMLImplement::setNamedAttributeValue: Failed to set the value for named attribute [/configuration/appSettings/add[@key="DataProviderEncryptionKey"]/@value]
<#01>[10000] (02/11 18:57:00.851):{0x1C50} GenerateRijndaelKeyAndVector: Failed to update DataProviderEncryptionKey value in Core's web.config to [----------------------------------------------------].
<#01>[10000] (02/11 18:57:00.851):{0x1C50} CDataContainer::smileyvery-happy:oApply: UbitexxCoreDataCon failed to apply. Result: 486055.
<#03>[30000] (02/11 18:57:00.851):{0x1C50} Step ApplyProduct failed
<#01>[10000] (02/11 18:57:00.851):{0x1C50} [CInstallStepSeq::ApplyProduct]: Product application failed.

 

I followed the following installation KB article: Article ID: KB32547

 

I also read this forum article indicating issues with the LogOn Service account:

http://supportforums.blackberry.com/t5/BlackBerry-Mobile-Fusion/Universal-Device-Service-Installatio...

 

I noticed the services were set to start with the "Network Service" account rather than the admin account I used to install the software which was also selected during the installation. Once changing the service LogOn to this admin account the UDS services started. I still need to install the UDS Communication Module in my DMZ but has anyone else run into this? I suspect once I install the Communication module I'm going to see other errors.

 

Kind regards

 

Please use plain text.
New Contributor
chancy
Posts: 3
Registered: ‎04-14-2011
My Device: Bold 9700
My Carrier: AT&T

Re: UDS Fails to Install on Server with BDS and BMS Already Installed.

Did you ever get a solution to this. I'm stuck with the exact same error code when installing UDS at the finalization part.
Please use plain text.
Contributor
smoothrunnings
Posts: 19
Registered: ‎02-08-2010
My Device: BOLD 9000
My Carrier: MoviStar

Re: UDS Fails to Install on Server with BDS and BMS Already Installed.

You need to rip everything out and start over.. This time follow this KB instead.

 

http://btsc.webapps.blackberry.com/btsc/viewdocument.do;jsessionid=A630A121281E78BED1D2C03B86E608E9?...

 

Please use plain text.