Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
SOR-IT
Posts: 6
Registered: ‎05-05-2013
My Device: Z10
My Carrier: Telstra
Accepted Solution

UDS Install fails at Finalizing step

[ Edited ]

Hi Guys,

 

Need someone to point me in the right direction.

 

UDS is been installed on a server with BDS already installed. Port changes have been made as appropriate.

 

the setup log file has this entry:

 

"

<#03>[30000] (05/01 13:13:51.324):{0x1768}  CUbitexxCoreDataCon::Apply executing - ["C:\Program Files (x86)\IIS\Microsoft Web Deploy V2\msdeploy.exe" -source: package="C:\Program Files (x86)\Research In Motion\Universal Device Service\setup\core\RIM.BUDS.CoreServer.zip" -dest:auto,includeAcls="False" -verb:sync -disableLink:AppPoolExtension -disableLink:ContentExtension -disableLink:CertificateExtension -setParam:name="IIS Web Application Name",value="UDS.CoreModule"]


<#01>[10000] (05/01 13:13:51.325):{0x1768}  CUbitexxCoreDataCon::Apply failed to extract list Could not create process for command ["C:\Program Files (x86)\IIS\Microsoft Web Deploy V2\msdeploy.exe" -source: package="C:\Program Files (x86)\Research In Motion\Universal Device Service\setup\core\RIM.BUDS.CoreServer.zip" -dest:auto,includeAcls="False" -verb:sync -disableLink:AppPoolExtension -disableLink:ContentExtension -disableLink:CertificateExtension -setParam:name="IIS Web Application Name",value="UDS.CoreModule"] with error 2


<#01>[10000] (05/01 13:13:51.325):{0x1768} CDataContainer:: DoApply: UbitexxCoreDataCon failed to apply. Result: 486031.


<#03>[30000] (05/01 13:13:51.325):{0x1768} Step ApplyProduct failed


<#01>[10000] (05/01 13:13:51.325):{0x1768} [CInstallStepSeq::ApplyProduct]: Product application failed.

"

 

Any help will be much apreciated

thanks

Dan

Please use plain text.
New Contributor
SOR-IT
Posts: 6
Registered: ‎05-05-2013
My Device: Z10
My Carrier: Telstra

Re: UDS Install fails at Finalizing step

If you do come across this problem like I did, here is how to fix;

 

1. Locate the Web Deploy entry in Programs and Features

2. Repair the install. For some reason the application installed within the Program Files folder only, UDS install looks for it in Program Files (x86), a repair install the webdeploy app to Program Files (X86)

 

Technically you you can just copy the folder to Program Files (x86), I have not tried this.

 

Note: this problem will only affect x64 systems.

 

Please use plain text.