Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
TeploukhovAA
Posts: 9
Registered: ‎07-28-2010
My Device: Not Specified
Accepted Solution

Unable to logon to BlackBerry Administration Service

Hello!
I have 2 BES 5.0 SP2 servers (primary and stanfby) and configured High Availability Administration Service.

On one server (primary) now I unable to logon to BlackBerry Administration Service.

When I logon on the second server and I want to viwe properties of Administration Service I see error:

"The application has encountered a system error. Please report this error to the System Administrator. (EXCEPTION-com.rim.bes.bas.servicemanager.ServiceNotFoundException) "

In BBAS logs there is error:
(12/30 18:02:05:853):{Thread-5} [com.arjuna.ats.jta.logging.loggerI18N] [WARN] [com.arjuna.ats.internal.jta.recovery.xarecovery1] Local XARecoveryModule.xaRecovery  got XA exception javax.transaction.xa.XAException: Error trying to connect to provider java:/DefaultJMSProvider, XAException.XAER_RMERR
(12/30 18:02:05:853):{Thread-5} [org.jboss.jms.server.recovery.MessagingXAResourceWrapper] [ERROR] ********************************Failed to connect to server
javax.naming.NameNotFoundException: XAConnectionFactory
 at org.jboss.ha.jndi.TreeHead.lookup(TreeHead.java:242)


(12/30 18:01:14:897):{Timer-11} [com.rim.bes.bas.singletondeploymentbarrier.SingletonDeploymentBarrierManagerBean] [INFO] [BBAS-1011] {u=SystemUser, t=1631} isCurrentNodeTheSingletonInNewTransactionLocal CLUSTER:   heartbeat from another server (BES02) is still active, this server (BES01) cannot take over as singleton


The version java is dentical on servers. I find:
http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB14697
but it is don't help for me.

Because don't work BAS and don't work utility from BES Resource Kit.

I check 

KB18267 The username, password, or domain is not correct logging to BAS

 
On accaunt Besadmin section Do not require Kerberos preauthentication
 is clear.

KB18186 Unable to log on to BAS when running a mixed domain environment

 
Level of domain and forest is Windows 2008.

KB17950 The username, password, or domain is not correct

There are ptr-record in DNS and in C:\Windows\System32\drivers\etc\hosts didn't changed.

Please help me.

Contributor
bharvley
Posts: 21
Registered: ‎12-30-2010
My Device: Storm 9530

Re: Unable to logon to BlackBerry Administration Service

Hi,

 

Here is a KB for basic BAS troubleshooting.

 

http://www.blackberry.com/btsc/KB24220

 

I find that restarting BAS-NCC.exe resolves a lot of BAS issues. Attempt this and wait about 2 minutes after you have restarted the service before attempting to access the BAS again. Hope this helps!

New Contributor
TeploukhovAA
Posts: 9
Registered: ‎07-28-2010
My Device: Not Specified

Re: Unable to logon to BlackBerry Administration Service

Hi,

Thank you for answer.

 

I restartes BAS-NCC.exe. and BAS-AS.exe. After that in Event Log Application theer are message:

:
1. The description for Event ID 4100 from source BAS-NCC cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

BAS-NCC

 

2. 
The description for Event ID 4 from source BAS-NCC cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

BAS-NCC

 

3.
The description for Event ID 4 from source BAS-AS cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

BAS-AS

 

After 5 minutes I try to logon in BAS, but unable logon: There is error, after several minutes:

The username, password, or domain is not correct. Please correct the entry.

This error was befor restart BAS-NCC.exe. and BAS-AS.exe.

 

In BAS log there is error:

(01/03 00:05:46:857):{Thread-5} [com.arjuna.ats.jta.logging.loggerI18N] [WARN] [com.arjuna.ats.internal.jta.recovery.xarecovery1] Local XARecoveryModule.xaRecovery  got XA exception javax.transaction.xa.XAException: Error trying to connect to provider java:/DefaultJMSProvider, XAException.XAER_RMERR
(01/03 00:05:46:858):{Thread-5} [org.jboss.jms.server.recovery.MessagingXAResourceWrapper] [ERROR] ********************************Failed to connect to server
javax.naming.NameNotFoundException: XAConnectionFactory

On primary and stanby servers runninig BlackBerry Administration Service - Application Server and BlackBerry Administration Service - Native Code Contai

I configured HA BAS

 

On standby server I can to logon to BAS

 

 

 

 

New Contributor
TeploukhovAA
Posts: 9
Registered: ‎07-28-2010
My Device: Not Specified

Re: Unable to logon to BlackBerry Administration Service

I updated Java. Then  I check http://www.blackberry.com/btsc/KB14697 and upgrade 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic​es\BAS-AS\Parameters\JVM Option Number 3

-Xmx1024m
by
-Xmx768m

 

After that I restarted Application Server and BlackBerry Administration Service - Native Code Contai
At first time I can logon to BlackBerry Administration Service, but after several minutes I coudn't logon to BAS.

I think this problem with Java and BlackBerry Administration Service, but I coudn\t resolve this problem

New Contributor
TeploukhovAA
Posts: 9
Registered: ‎07-28-2010
My Device: Not Specified

Re: Unable to logon to BlackBerry Administration Service

Hello!
I resolve my problem.
Reason problem: on primary and stanby server were started BlackBerry Administration Service and BlackBerry Administration Service - Native Code Container.

 

Decision: Stop BlackBerry Administration Service and BlackBerry Administration Service - Native Code Container on one server (standby).

Contributor
voyager9355
Posts: 20
Registered: ‎04-23-2011
My Device: Bold 9930

Re: Unable to logon to BlackBerry Administration Service

Same exact problem here, all was fine till sometime last week.  

 

Only thing I noticed was on my primary BES, Windows Update had installed something.  I removed it & rebooted (and told Windows not to install again), hoping that would fix it, since that was really the only thing that changed...no luck.

 

I had identical symptoms as the original poster -  same version of BES, same error about username/password incorrect (when it's correct).  Same BBAS log entry/error.

 

Same (workaround) resolution.  I stopped the admin service on my primary BES, and can now log in to the console.  Anyone have a clue?  

Visitor
extremist
Posts: 1
Registered: ‎08-29-2013
My Device: 9780

Re: Unable to logon to BlackBerry Administration Service

I had this issue, restarted the 'BlackBerry Administration Service - Native Code Container' service which also restarted 'BlackBerry Administration Service - Application Server' because its a dependency, wait 5 minutes, re-connect to web interface, then it'll work.

If it doesn't work and you have a Secondary (Standby Server), stop the 'BlackBerry Administration Service' and 'BlackBerry Administration Service - Native Code Container' on the Secondary server and try the solution that I mentioned above.

Don't forget to change the service status to manual for the Secondary server so that it doesn't start automatically next time you boot/reboot the server.

You can have the web service running on both servers but it seems that it might have issues running them together (I think there is a solution for this but who cares, as long as it works, right?) and you'll most likely get the Primary servers services to stop.