Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Contributor
basher
Posts: 18
Registered: ‎04-13-2012
My Device: 9790
My Carrier: vodafone

Universal Device Service Setup crash during finalize installation

[ Edited ]

i'm installing on windows 2008 R2 in english.

Local administrator, local DB.

Using BMF 6.0.1 setup and wanted to install only UDS on a single machine (all modules installed on a single server)

The error occurs at the last stage of installation "finalize installation" either using "basic" or "advanced" installation.

 

The setup crashes due to a fault in module name msxml6.dll:

++++

Description:

Faulting application name: Setup.exe_Universal Device Service, version: 6.0.0.56, time stamp: 0x4f6b6e10

Faulting module name: msxml6.dll, version: 6.30.7600.16723, time stamp: 0x4d103aad

Exception code: 0xc0000005

Fault offset: 0x000b7f81

Faulting process id: 0xacc

Faulting application start time: 0x01cd19674da28f7c

Faulting application path: C:\Software\BlackBerry Mobile Fusion Studio 6.0.1\bundle0026\Modules\UDS\Setup.exe

Faulting module path: C:\Windows\System32\msxml6.dll

++++

 

This is the XML parser call causing the fault.

Then I analyzed the setup log and found that the last line report the following:

++++
<#01>[10000] (04/13 14:35:17.328):{0xB9C} Failed to load the XML file[C:\Program Files (x86)\Research In Motion\Universal Device Service\Communication\Web.config]

++++

 

I then wondered if this web.config file could be an XML file.. that's right! Might this file the cause of the crash of the XML parser call? Yep!

 

I analyzed the web.config file and found that there is an error on the XML format.

At the end of the file, on the last line, there's a trailing "n>" that does not close the XML file correctly.

This is confirmed by every XML validator I used to verify the XML syntax of this file.

See how it ends:

++++
      </container>
    </containers>
  </unity>
</configuration>
n>

++++

 

What to do then to solve the problem? I don't know because this web.config file is written from scratch by the setup itself every time it runs. Neither it's possible to stop the setup and manually modify the file a second before the setup calls the XML parser.

 

I reinstalled everything from scratch 4 times reverting to snapshot on my virtual machine. Every time the same error.

Mumbling further about this problem I think it can be related to some wrong interaction of the setup with the Windows 2008 R2 server configuration. But what could be causing the setup to add this "n>" at the end of the file? I sincerely didn't find a possible cause. The windows server 2008 R2 is in english version and the format and language region is set to "English (US)". I googled the problem, I searched in the RIm's KB but found nothing.

It seems so far I'm the only one in the whole world to have encountered this problem.

 

Any help?

Please use plain text.
New Contributor
DNA_Systembeheer
Posts: 4
Registered: ‎05-14-2012
My Device: none
My Carrier: none

Re: Universal Device Service Setup crash during finalize installation

I experience the same error: Faulting application name: Setup.exe_Universal Device Service, version: 6.0.0.56, time stamp: 0x4f6b6e10 Faulting module name: Setup.exe, version: 6.0.0.56, time stamp: 0x4f6b6e10 Exception code: 0xc0000005 Fault offset: 0x0023bad8 Faulting process id: 0x6b4 Faulting application start time: 0x01cd31b5cbe32cc6 Faulting application path: C:\Temp\Research In Motion\BlackBerry Mobile Fusion Studio 6.0.1\bundle0026\Modules\UDS\Setup.exe Faulting module path: C:\Temp\Research In Motion\BlackBerry Mobile Fusion Studio 6.0.1\bundle0026\Modules\UDS\Setup.exe Report Id: fcf6ca9e-9da9-11e1-a096-005056840034 Is there already a solution for this problem?
Please use plain text.
Contributor
basher
Posts: 18
Registered: ‎04-13-2012
My Device: 9790
My Carrier: vodafone

Re: Universal Device Service Setup crash during finalize installation

what is the "Faulting module path"? if it doesn't show "C:\Windows\System32\msxml6.dll" then my error is different than yours.

In any case, my problem was caused by the hostname I chose.

There's a terribile bug in this version 6.0.1. I found it after 3 weeks of investigation.

Never name the server "BUDS" because it leads to the above error I described. Weird but true.

 

Please use plain text.
New Contributor
DNA_Systembeheer
Posts: 4
Registered: ‎05-14-2012
My Device: none
My Carrier: none

Re: Universal Device Service Setup crash during finalize installation

Problem signature: Problem Event Name: APPCRASH Application Name: Setup.exe_Universal Device Service Application Version: 6.0.0.56 Application Timestamp: 4f6b6e10 Fault Module Name: Setup.exe Fault Module Version: 6.0.0.56 Fault Module Timestamp: 4f6b6e10 Exception Code: c0000005 Exception Offset: 0023bad8 OS Version: 6.1.7601.2.1.0.272.7 Locale ID: 1043 Additional Information 1: 0a9e Additional Information 2: 0a9e372d3b4ad19135b953a78882e789 Additional Information 3: 0a9e Additional Information 4: 0a9e372d3b4ad19135b953a78882e789 Read our privacy statement online: http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409 If the online privacy statement is not available, please read our privacy statement offline: C:\Windows\system32\en-US\erofflps.txt
Please use plain text.
New Contributor
DNA_Systembeheer
Posts: 4
Registered: ‎05-14-2012
My Device: none
My Carrier: none

Re: Universal Device Service Setup crash during finalize installation

It doesnt mention anything about a dll-file. But I will try to rename the server... It's strange that only during this BUDS setup the error appears and not during the Fusion Studio and BB device service setup.
Please use plain text.
BlackBerry Technical Advisor
-BD-
Posts: 483
Registered: ‎05-15-2008
My Device: Z10
My Carrier: Rogers

Re: Universal Device Service Setup crash during finalize installation

Did you specify a SSL certificate during the Communication Module portion of the install?  There is a known issue where the installation will crash on the finalize stage if this is left blank.

Please use plain text.
Contributor
basher
Posts: 18
Registered: ‎04-13-2012
My Device: 9790
My Carrier: vodafone

Re: Universal Device Service Setup crash during finalize installation

[ Edited ]

@DNA_Systembeheer,

 for sure my problem has a different cause than yours. You'd better follow the suggestions of -BD-

Please use plain text.
New Contributor
DNA_Systembeheer
Posts: 4
Registered: ‎05-14-2012
My Device: none
My Carrier: none

Re: Universal Device Service Setup crash during finalize installation

@DB, I left it blank. But what is the solution for this problem? I dont have any SSL certificates available.....
Please use plain text.
BlackBerry Technical Advisor
-BD-
Posts: 483
Registered: ‎05-15-2008
My Device: Z10
My Carrier: Rogers

Re: Universal Device Service Setup crash during finalize installation

You need to have a SSL certficiate.  It's a requirement for the server to function properly.  Without it your devices will be unable to communicate with the server.

 

Either setup an enterprise CA in your environment and issue your own cert or get one from a third-party vendor.

Please use plain text.