Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
joetheboss
Posts: 5
Registered: ‎07-18-2014
My Device: Q10
My Carrier: Telekom

Work Connect for BES10 app not working on IOS 7.1.2

Anyone else notice that Work Connect APP for IOS doesent work on IOS 7.1.2 when doing a new enrollment.

BES version is 10.2.3.

 

Anyone else having this issue?

 

 

Please use plain text.
PB_
New Contributor
PB_
Posts: 7
Registered: ‎07-16-2014
My Device: BBerry Z10, Apple iPhone 5S
My Carrier: Vodafone

Re: Work Connect for BES10 app not working on IOS 7.1.2

I enrolled it yesterday and it worked fine for me.
We use the same BES and iOS version.

Do you get an error or something?
Please use plain text.
New Contributor
joetheboss
Posts: 5
Registered: ‎07-18-2014
My Device: Q10
My Carrier: Telekom

Re: Work Connect for BES10 app not working on IOS 7.1.2

I get the error that my administrator has to create a workspace for me first, which doesn't make much sense because the device has pulled the workspace policy

Please use plain text.
PB_
New Contributor
PB_
Posts: 7
Registered: ‎07-16-2014
My Device: BBerry Z10, Apple iPhone 5S
My Carrier: Vodafone

Re: Work Connect for BES10 app not working on IOS 7.1.2

I had the same error, but I cannot really remember how I fixed it.

 

Try to reset the iPhone to system defaults (backup user data before doing this).

I think that solved the problem for me.

 

Let me know if it helped, if not, I'll try to reproduce the problem in our environment.

Please use plain text.
New Contributor
joetheboss
Posts: 5
Registered: ‎07-18-2014
My Device: Q10
My Carrier: Telekom

Re: Work Connect for BES10 app not working on IOS 7.1.2

I actually just tried it on a new device with a new account...but same problem.

Can you pls try to reproduce it.. Thanks

Please use plain text.
PB_
New Contributor
PB_
Posts: 7
Registered: ‎07-16-2014
My Device: BBerry Z10, Apple iPhone 5S
My Carrier: Vodafone

Re: Work Connect for BES10 app not working on IOS 7.1.2

Ensure the following:

- You have an Activation Profile for iOS (e.g. "Work and Personal - Full Control" instead of "MDM Controls") and it's assigned to the user

- The certificate (xx.bbsecure.com/sxxxxxxxx/ca) is installed on the iPhone

 

I think I forgot to assign the activation profile when I got the error.

Please use plain text.
New Contributor
joetheboss
Posts: 5
Registered: ‎07-18-2014
My Device: Q10
My Carrier: Telekom

Re: Work Connect for BES10 app not working on IOS 7.1.2

Yes the user has "Work and Personal - Full Control" profile

 

And yes the certificate is installed on the iphone.

 

 

Please use plain text.
PB_
New Contributor
PB_
Posts: 7
Registered: ‎07-16-2014
My Device: BBerry Z10, Apple iPhone 5S
My Carrier: Vodafone

Re: Work Connect for BES10 app not working on IOS 7.1.2

Hm.. For how long do you have the gold license activated?

When I installed it, it took about some hours for everything to work correctly.

I'm still trying to reproduce the problem... I will tell you if I found something..
Please use plain text.
New Contributor
joetheboss
Posts: 5
Registered: ‎07-18-2014
My Device: Q10
My Carrier: Telekom

Re: Work Connect for BES10 app not working on IOS 7.1.2

I just installed the bes server about 2 days ago, so i should still have about 58 days left on the test license.

Please use plain text.
PB_
New Contributor
PB_
Posts: 7
Registered: ‎07-16-2014
My Device: BBerry Z10, Apple iPhone 5S
My Carrier: Vodafone

Re: Work Connect for BES10 app not working on IOS 7.1.2

[ Edited ]

I could reproduce the error:

 

When I activated the iPhone before I added the user to the "Activation Type"-Profile and the "Work-Space IT-Policy" I get the same error.

 

Ensure that the user is added to the profiles before you activate the users iPhone.

 

Tell me if it worked for you.

Please use plain text.