Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Developer
Posts: 135
Registered: ‎09-25-2012
My Device: Dev Alpha
My Carrier: Rogers

"Acknowledgement for send was not received from Server" - MS Exchange with Z10

I have a bug which is preventing me from being able to send "some" messages through Exchange. I would get a red warning sign with a "Acknowledgement for send was not received from Server" error. It would only work if I have a plain text email with no hyperlinks (HTML). 

 

I have all but given up on it while my iPhone/Android co-workers have no issues. 

 

It seems like due to the way BlackBerry sends their network packet, it doesn't play friendly with the network loadbalancer. Our exchange server is load balanced for redudancy so information coming from the Z10 get sent to one of the exchange servers. What BlackBerry does with their send packet is to maintain connection to the server, if it doesn't hear from the original request (due to loadbalancing), it will just timeout. What iOS does is, it will retry with a new request which will work.

 

What BlackBerry want our company to do is to force BlackBerry traffic to a single server which will defeat the loadbalancing/redudancy design. 

 

Ideally, I would like them to have an option to "resend" package or format their network package to work with loadbalacing situations better.

 

I am not a network guy, so perhaps the terms aren't 100% correct, but this is what I was told from our network manager regarding the issue I am having with my Z10 timing out when sending emails through Outlook Webmail. Is there anything else I can do?