Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Contributor
mazbana
Posts: 28
Registered: ‎03-22-2013
My Device: Z10
My Carrier: Rogers
Accepted Solution

secure work space not working on corporate wireless

HI guys,

 

So i have a couple of questions.  I can activate and get secure work space working fine on my home internet or even tethered through my Z10, but as soon as I connect it to our corporate wireless i get nothing.  I get the following messages. I can't activate on my corporate wifi either.. so something is defintally being blocked, but before i talk to the network admins would like to dig a bit further.

 

"Unable to Connect work space can't connect at this time"

 

this is on an ipad.  Any idea what i should be looking at?

Please use plain text.
BlackBerry Development Advisor (Retired)
MAD-VIKING
Posts: 91
Registered: ‎05-17-2013
My Device: BlackBerry Z-10
My Carrier: Rogers

Re: secure work space not working on corporate wireless

Hello mazbana;

 

Welcome to the forums and thank you for your question.

 

Based on the information you have provided we can decipher the following;

Connect to ActiveSync with Secure Work-Space

Wireless Provider\tethered\WIFI Network        (PASS)

ISP Provider\Home WIFI                                 (PASS)

ISP Provider\Corp WIFI                                   (FAIL)

 

Can you activate to ActiveSync utilizing your Corp WIFI without the BlackBerry Enterprise Server in the picture?

 

Are you utilizing an Internal or External ActiveSync profile? (I am guessing external, since you are able to access it form outside of work, unless you are tunneling through a VPN)

 

You have stated that you are utilizing a BlackBerry Z-10 and that you are also unable to activate while on Corp WIFI. Does this hold true for the Z-10 as well? Meaning you are unable to activate your Z-10 to ActiveSync, through Corp WIFI, while the Z-10 is on a BlackBerry Enterprise Service 10.

 

 

Let us know if you have any further questions regarding this specific request.

 

 

MAD-VIKING
Please use plain text.
Contributor
mazbana
Posts: 28
Registered: ‎03-22-2013
My Device: Z10
My Carrier: Rogers

Re: secure work space not working on corporate wireless

when i  setup secure work space for Android or IOS i cannot activate or get email when i'm on the corporate wifi (same network as the BES)

 

when on a mobile network (cellular) or on another wifi (eg home or outside of work) i can activate and receive email.

 

setting up activesync direct bypassing BES10 works on both work wifi and any network outside of work.

 

i've talked to our network admins and they don't seem to think anything is blocked on our work wifi.. not sure there must be something though with how BES10 works..

Please use plain text.
New Member
erichuynh
Posts: 2
Registered: ‎07-18-2013
My Device: Z10
My Carrier: Telus

Re: secure work space not working on corporate wireless

We had this exact same issue on our corporate wireless. I'm the network admin, so I checked our firewall logs to see what was being blocked. It turns out that the Android (we don't have IOS) devices were using a HTTP proxy on port 80 to 216.9.242.240. We have a UTM firewall that blocks proxying, so once I setup a rule to allow proxying to that specific IP address, the issue went away. Hope this helps you out!

 

Eric  :-)

Please use plain text.
Contributor
mazbana
Posts: 28
Registered: ‎03-22-2013
My Device: Z10
My Carrier: Rogers

Re: secure work space not working on corporate wireless

looking into it, but problem still exists.

get work space "authentication failed"

not sure why it works everywhere else.
Please use plain text.
Guru III
knottyrope
Posts: 30,117
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: secure work space not working on corporate wireless

if corproate Wifi in on the LAN then you must have split DNS in place or it might be trying to go out of your network to access you WAN IP which wont work on most firewalls.

 

We have wifi here that uses a different WAN IP so it just as if you were in a random hotspot and works everytime.

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 5.0.4 and BES 10.2.2 with Exchange 2010 and SQL 2008


Please use plain text.
Contributor
mazbana
Posts: 28
Registered: ‎03-22-2013
My Device: Z10
My Carrier: Rogers

Re: secure work space not working on corporate wireless

found this in  a log file from my phone under a folder called mobile fusion.

 

[2013-08-06 13:34:24 -0400 DEBUG] "HttpClientFactory": Using existing Http client
[2013-08-06 13:34:45 -0400 ERROR] java.net.UnknownHostException: Unable to resolve host "ca.bbsecure.com": No address associated with hostname
java.net.InetAddress.lookupHostByName(InetAddress.java:434)
java.net.InetAddress.getAllByNameImpl(InetAddress.java:239)
java.net.InetAddress.getAllByName(InetAddress.java:214)
org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:137)
org.apache.http.impl.conn.AbstractPoolEntry.open(AbstractPoolEntry.java:164)
org.apache.http.impl.conn.AbstractPooledConnAdapter.open(AbstractPooledConnAdapter.java:119)
org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:367)
org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:593)
org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:510)
org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:488)
com.rim.mobilefusion.client.utils.connections.Connection.processRequest(Connection.java:410)
com.rim.mobilefusion.client.utils.connections.Connection.sendRequest(Connection.java:205)
com.rim.mobilefusion.client.utils.connections.Connection.sendRequest(Connection.java:136)
com.rim.mobilefusion.client.actions.ClientCommand.sendRequest(ClientCommand.java:110)
com.rim.mobilefusion.client.actions.commands.senddeviceinfo.DeviceInfoCommand.sendDeviceInfoData(DeviceInfoCommand.java:108)
com.rim.mobilefusion.client.service.ServiceWorkerDeviceInfo$DeviceInfoServiceThread.sendDeviceInfoPayloads(ServiceWorkerDeviceInfo.java:70)
com.rim.mobilefusion.client.service.ServiceWorkerDeviceInfo$DeviceInfoServiceThread.execute(ServiceWorkerDeviceInfo.java:35)
com.rim.mobilefusion.client.service.ServiceServerThreadBase.run(ServiceServerThreadBase.java:38)

Please use plain text.
Contributor
mazbana
Posts: 28
Registered: ‎03-22-2013
My Device: Z10
My Carrier: Rogers

Re: secure work space not working on corporate wireless

here is another error.  i think.  not sure if its relatd or just a cause of when i disconnect between cellular connection and wifi.

 

[2013-08-06 12:46:41 -0400 DEBUG] "Connection": Server responses: HTTP/1.1 204 No Content
[2013-08-06 12:46:41 -0400 DEBUG] "ExecuteConfigs": <<< Server Version:1.0.1 Client Version:1.0.1 >>>
[2013-08-06 12:46:41 -0400 DEBUG] "ExecuteConfigs": <<< Configs have not changed >>>
[2013-08-06 12:46:41 -0400 DEBUG] "ServiceServerThreadBase$CommandProccessor": CommandExecutor requesting command[0]...
[2013-08-06 12:46:41 -0400 DEBUG] "HttpClientFactory": Using existing Http client
[2013-08-06 12:46:41 -0400 DEBUG] "Connection": Client sends: GET to https://ca.bbsecure.com:80/s49729454/mdm/33521afe-1455-451a-aacd-29d6f6c8065a/commands
[2013-08-06 12:46:41 -0400 DEBUG] "Connection": Server responses: HTTP/1.1 200 OK
[2013-08-06 12:46:41 -0400 DEBUG] "Executer": No items in command list
[2013-08-06 12:46:41 -0400 DEBUG] "ServiceWorkerDeviceInfo": onStartCommand called...
[2013-08-06 12:47:03 -0400 DEBUG] "HttpClientFactory": Using existing Http client
[2013-08-06 12:47:03 -0400 DEBUG] "ClientCommand": request sent - status code return: 200
[2013-08-06 12:47:04 -0400 DEBUG] "HttpClientFactory": Using existing Http client
[2013-08-06 12:47:05 -0400 DEBUG] "ClientCommand": request sent - status code return: 200
[2013-08-06 12:47:05 -0400 DEBUG] "ServiceWorkerDeviceInfoCommand": onStartCommand called...
[2013-08-06 12:47:05 -0400 DEBUG] "ServiceServerThreadBase$CommandProccessor": CommandExecutor requesting command[0]...
[2013-08-06 12:47:05 -0400 DEBUG] "HttpClientFactory": Using existing Http client
[2013-08-06 12:47:05 -0400 DEBUG] "Connection": Client sends: GET to https://ca.bbsecure.com:80/s49729454/mdm/33521afe-1455-451a-aacd-29d6f6c8065a/commands
[2013-08-06 12:47:06 -0400 DEBUG] "Connection": Server responses: HTTP/1.1 200 OK
[2013-08-06 12:47:06 -0400 DEBUG] "Executer": No items in command list
[2013-08-06 13:01:41 -0400 DEBUG] "ServiceWorker": onStartCommand called...
[2013-08-06 13:01:41 -0400 DEBUG] "HttpClientFactory": Using existing Http client
[2013-08-06 13:01:41 -0400 DEBUG] "Connection": Client sends: HEAD to https://ca.bbsecure.com:80/s49729454/mdm/33521afe-1455-451a-aacd-29d6f6c8065a/config
[2013-08-06 13:01:41 -0400 ERROR] javax.net.ssl.SSLException: Read error: ssl=0x6daa1d30: I/O error during system call, Connection reset by peer
org.apache.harmony.xnet.provider.jsse.NativeCrypto.SSL_read(Native Method)
org.apache.harmony.xnet.provider.jsse.OpenSSLSocketImpl$SSLInputStream.read(OpenSSLSocketImpl.java:651)
org.apache.http.impl.io.AbstractSessionInputBuffer.fillBuffer(AbstractSessionInputBuffer.java:103)
org.apache.http.impl.io.AbstractSessionInputBuffer.readLine(AbstractSessionInputBuffer.java:191)
org.apache.http.impl.conn.DefaultResponseParser.parseHead(DefaultResponseParser.java:82)
org.apache.http.impl.io.AbstractMessageParser.parse(AbstractMessageParser.java:174)
org.apache.http.impl.AbstractHttpClientConnection.receiveResponseHeader(AbstractHttpClientConnection.java:180)
org.apache.http.impl.conn.DefaultClientConnection.receiveResponseHeader(DefaultClientConnection.java:235)
org.apache.http.impl.conn.AbstractClientConnAdapter.receiveResponseHeader(AbstractClientConnAdapter.java:259)
org.apache.http.protocol.HttpRequestExecutor.doReceiveResponse(HttpRequestExecutor.java:279)
org.apache.http.protocol.HttpRequestExecutor.execute(HttpRequestExecutor.java:121)
org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:435)
org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:593)
org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:510)
org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:488)
com.rim.mobilefusion.client.utils.connections.Connection.processRequest(Connection.java:410)
com.rim.mobilefusion.client.utils.connections.Connection.sendRequest(Connection.java:205)
com.rim.mobilefusion.client.utils.connections.Connection.sendRequest(Connection.java:241)
com.rim.mobilefusion.client.utils.connections.Connection.sendRequest(Connection.java:147)
com.rim.mobilefusion.client.actions.ExecuteConfigs.executeItem(ExecuteConfigs.java:101)
com.rim.mobilefusion.client.actions.Executer.execute(Executer.java:22)
com.rim.mobilefusion.client.service.ServiceWorker$CommandServiceThread.execute(ServiceWorker.java:34)
com.rim.mobilefusion.client.service.ServiceServerThreadBase.run(ServiceServerThreadBase.java:38)

Please use plain text.
Contributor
mazbana
Posts: 28
Registered: ‎03-22-2013
My Device: Z10
My Carrier: Rogers

Re: secure work space not working on corporate wireless

could this be an issue because i can see the servers directly?  the device and bes 10 server have direct access

Please use plain text.
Guru III
knottyrope
Posts: 30,117
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: secure work space not working on corporate wireless


mazbana wrote:

could this be an issue because i can see the servers directly?  the device and bes 10 server have direct access


yes

 

 

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 5.0.4 and BES 10.2.2 with Exchange 2010 and SQL 2008


Please use plain text.