Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
Smeider
Posts: 2
Registered: ‎10-11-2013
My Device: Z10
My Carrier: T-Mobil
Accepted Solution

upgrade form 10.1.2 to BlackBerry Enterprise Service 10 version 10.1.3 upgrade fails at the "Finalize Installation" stage

Hello Community,

 

Winodws 2008 R2 Server English OS

 

BlackBerry Enterprise Service 10 version 10.1.3 upgrade fails at the "Finalize Installation" stage.

 

At the end of the installation:

The installation Status windows shows following message:

 

"The setup application is completing the installation process and starting services. The process might takes serveral minutes"

 

and then the installation stop with a pop up:

 

"An error coccurred during the installation process .... Blackberry Enterprise Service 10 software installation did not complete ...... Logs\installer\."

 

 

I found even the following error messages:

=======================================================================================

<#03>[30000] (10/11 16:42:37.246):{0xF90} CBASEncryption::smileytongue:repareDecode - About to run batch file command: ["C:\Program Files (x86)\Java\jre1.7.0_25\bin\java.exe" -cp "C:\Research In Motion\BlackBerry Enterprise Service 10.1.3\bundle0021\tools\basServerSystem.jar" com.rim.bes.bas.system.Encoder decodeAES_HEX "XXXXXXXX" "XXXXXXXX"]
<#01>[10000] (10/11 16:42:37.262):{0xF90} CBASEncryption::LaunchProcess - Error attempting to LaunchProcess batch command, error [2]
<#01>[10000] (10/11 16:42:37.262):{0xF90} CBASEncryption::smileyvery-happy:ecode - Failed to decode digest, return code [4]
<#01>[10000] (10/11 16:42:37.262):{0xF90} CBASUtilitiesCon::smileyvery-happy:ecode: Failed to decode the digest.
<#03>[30000] (10/11 16:42:37.262):{0xF90} CBASUtilitiesCon::QueryBASKeystoreDefaultPassword failed to decode password, code [4], setting it to empty
<#01>[10000] (10/11 16:42:37.262):{0xF90} CBASKeystoreCon::Init could not decode default SSL password yet
<#03>[30000] (10/11 16:42:37.262):{0xF90} CBASKeystoreCon::Init result is [0] - [BASPwd[<NIL>], PwdEditC/N/CN[<NIL>/<NIL>/<NIL>], Auto[1], Mod[0], CES[00], IVA[0/0/0] LD[1]WD[0] RO[0]]
<#03>[30000] (10/11 16:42:37.262):{0xF90} CBASKeystoreCon::Validate begins - BASPwd[<NIL>], PwdEditC/N/CN[<NIL>/<NIL>/<NIL>], Auto[1], Mod[0], CES[00], IVA[0/0/0] LD[1]WD[0] RO[0]
<#03>[30000] (10/11 16:42:37.262):{0xF90} CBASKeystoreCon::Validate validation result is [10] - [BASPwd[<NIL>], PwdEditC/N/CN[<NIL>/<NIL>/<NIL>], Auto[1], Mod[0], CES[00], IVA[0/0/0] LD[1]WD[0] RO[0]]
<#01>[10000] (10/11 16:42:37.262):{0xF90} CDataContainer::smileyvery-happy:oValidate: BASKeystoreDC failed to validate. Result: 10.
================================================================================

 

 

<#03>[30000] (10/11 16:42:35.200):{0xF90} CRestApiWrapper::GetCertificateAttributes get data, result is [0]
<#03>[30000] (10/11 16:42:35.200):{0xF90} CUbitexxCACertDataCon::Retrieve 'generic.x.file.blob' = [74eb689d-abab-4aec-ba5d-b9d6ce8f0ec7] parameter from JSON response from core server failed.
<#04>[40000] (10/11 16:42:35.200):{0xF90} CWebRequestWrapper::RetrieveData&colon; Starting request to [SERV2SC.SWGROUP.LOCAL:9081]...
<#04>[40000] (10/11 16:42:35.200):{0xF90} CWebRequestWrapper::RetrieveData&colon; Starting retrieve from page [/util/tenant/1/repo/74eb689d-abab-4aec-ba5d-b9d6ce8f0ec7]...
<#04>[40000] (10/11 16:42:35.200):{0xF90} CWebRequestWrapper::RetrieveData&colon; WinHttpOpenRequest succeeded. SecureConnection: [1].
<#04>[40000] (10/11 16:42:35.200):{0xF90} CWebRequestWrapper::RetrieveData&colon; WinHttpSetOption succeeded. Flags: 12544.
<#04>[40000] (10/11 16:42:35.278):{0xF90} CWebRequestWrapper::RetrieveData&colon; WinHttpSendRequest succeeded.
<#04>[40000] (10/11 16:42:35.278):{0xF90} CWebRequestWrapper::RetrieveData&colon; WinHttpReceiveResponse succeeded.
=========================================================================================

 

 

 

 

 

The lofile showes following error at the endo of the logfile

========================================================

<#03>[30000] (10/11 16:47:17.494):{0xF90} CFileSecurityAttributes::GrantAccessRightsToFolder: Successfully called SetNamedSecurityInfo. Returned code: 0.
<#03>[30000] (10/11 16:47:17.494):{0xF90} CCertificateWrapper::GrantCertificatePermissions: Successfully granted access rights to [C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys\47027757b58772ce9527380b3d235660_82c039ea-c87d-45e1-bb14-ec6dad22c936].
<#03>[30000] (10/11 16:47:17.494):{0xF90} CCertificateWrapper::GrantCertificatePermissions executed, result is [0]
<#03>[30000] (10/11 16:47:17.494):{0xF90} CUbitexxCACertDataCon::Apply: Successfully granted the permissions for CA certificate.
<#03>[30000] (10/11 16:47:17.494):{0xF90} CDataContainer::smileyvery-happy:oApplyImpl: Successfully ran UbitexxCACertDataCon::Apply()
<#01>[10000] (10/11 16:47:17.494):{0xF90} CDataContainer::smileyvery-happy:oValidate: UbitexxCoreDataCon failed to validate. Previous result: 486052.
<#01>[10000] (10/11 16:47:17.494):{0xF90} CDataContainer::smileyvery-happy:oApplyImpl: UbitexxCoreDataCon failed to validate. Result: 486052.
<#03>[30000] (10/11 16:47:17.494):{0xF90} Step ApplyProduct failed
<#01>[10000] (10/11 16:47:17.494):{0xF90} [CInstallStepSeq::ApplyProduct]: Product application failed.
====== END OF LOG ==================================

 

 

 

================================================================================

 

<#03>[30000] (10/11 16:42:40.510):{0xF90} CPasswordDataCon::Base64Encode succeeded
<#03>[30000] (10/11 16:42:40.510):{0xF90} CCertificateWrapper::smileytongue:arseCertificate executed, result is [0]
<#03>[30000] (10/11 16:42:40.510):{0xF90} CBES10CertDataCon::ConvertStringToDate: The cert expire date: 8/15/2038.
<#03>[30000] (10/11 16:42:40.510):{0xF90} CBES10CertDataCon::CertificateHasExpired: Result is 0.  Curtime: 2013 10 11 16:42:40, Certtime: 2038 08 15 00:00:00.
<#01>[10000] (10/11 16:42:40.510):{0xF90} CBES10CertDataCon::Validate: Default password not generated yet.
<#01>[10000] (10/11 16:42:40.510):{0xF90} CDataContainer::smileyvery-happy:oValidate: BES10CertDataCon failed to validate. Result: 10003.
<#03>[30000] (10/11 16:42:40.526):{0xF90} CADSettingsCon::Init begins - U/D/P[BES10Admin/SWGroup.local/<NIL>] GC[] CES[21], IVA[0/0/0] LD[1]WD[0] RO[0]
<#03>[30000] (10/11 16:42:40.526):{0xF90} ADSettings found user name [BES10Admin] in the database, using that
<#03>[30000] (10/11 16:42:40.526):{0xF90} ADSettings found user domain [SWGroup.local] in the database, using that
<#03>[30000] (10/11 16:42:40.526):{0xF90} CBASEncryption::smileytongue:repareDecode - About to run batch file command: ["C:\Program Files (x86)\Java\jre1.7.0_25\bin\java.exe" -cp "C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Service 10\BAS\lib\basServerSystem.jar" com.rim.bes.bas.system.Encoder decodeAES_HEX "XXXXXXXX" "XXXXXXXX"]
<#01>[10000] (10/11 16:42:40.526):{0xF90} CBASEncryption::LaunchProcess - Error attempting to LaunchProcess batch command, error [2]
<#01>[10000] (10/11 16:42:40.526):{0xF90} CBASEncryption::smileyvery-happy:ecode - Failed to decode digest, return code [4]
<#01>[10000] (10/11 16:42:40.526):{0xF90} CBASUtilitiesCon::smileyvery-happy:ecode: Failed to decode the digest.
<#03>[30000] (10/11 16:42:40.526):{0xF90} ADSettings found invalid user password in the database, not using it
<#03>[30000] (10/11 16:42:40.526):{0xF90} ADSettings::Init result is [0] - U/D/P[BES10Admin/SWGroup.local/<NIL>] GC[] CES[21], IVA[0/0/0] LD[1]WD[0] RO[0]
<#03>[30000] (10/11 16:42:40.526):{0xF90} CADSettingsCon::Validate begins - U/D/P[BES10Admin/SWGroup.local/<NIL>] GC[] CES[21], IVA[0/0/0] LD[1]WD[0] RO[0]
<#01>[10000] (10/11 16:42:40.526):{0xF90} ADSettings could not validate user creds with a blank password - user[BES10Admin] domain[SWGroup.local]
<#01>[10000] (10/11 16:42:40.526):{0xF90} CDataContainer::smileyvery-happy:oValidate: ADSettingsDC failed to validate. Result: 7.
<#03>[30000] (10/11 16:42:40.526):{0xF90} CBASKeystoreCon::Init sets auto-generation to [1]
<#03>[30000] (10/11 16:42:40.526):{0xF90} CBASKeystoreCon::Init did not find valid SSL password, generating
<#03>[30000] (10/11 16:42:40.526):{0xF90} QueryBASKeystoreDefaultPassword located a default password

Please use plain text.
New Contributor
Matoe
Posts: 5
Registered: ‎07-11-2013
My Device: nvt
My Carrier: KPN

Re: upgrade form 10.1.2 to BlackBerry Enterprise Service 10 version 10.1.3 upgrade fails at the "Finalize Installation" stage

Same problems here, but from a 10.1.1 installation to 10.1.3

Please use plain text.
New Contributor
Matoe
Posts: 5
Registered: ‎07-11-2013
My Device: nvt
My Carrier: KPN

Re: upgrade form 10.1.2 to BlackBerry Enterprise Service 10 version 10.1.3 upgrade fails at the "Finalize Installation" stage

My issue is resolved, problem occured (i think) because the first update attempt was using an other administrator account instead of the BES account. After that all attepts (even with the right account) failed.

So i reverted back to the pre-update snapshot i created and the update using the BES10 account suceeded 

Please use plain text.
Guru III
knottyrope
Posts: 30,159
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: upgrade form 10.1.2 to BlackBerry Enterprise Service 10 version 10.1.3 upgrade fails at the "Finalize Installation" stage

[ Edited ]

BES always needs to be updated with the Service account you intalled it with and using a different account can really muck things up

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 5.0.4 and BES 10.2.2 with Exchange 2010 and SQL 2008


Please use plain text.
New Contributor
Smeider
Posts: 2
Registered: ‎10-11-2013
My Device: Z10
My Carrier: T-Mobil

Re: upgrade form 10.1.2 to BlackBerry Enterprise Service 10 version 10.1.3 upgrade fails at the "Finalize Installation" stage

Thanks,

 

I restore my Bes10.1.2 installation an install with the Insallation User (Bes10Amdin) and it works great

 

:smileyvery-happy:

Please use plain text.
Guru III
knottyrope
Posts: 30,159
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook, BlackBerry Wireless Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: upgrade form 10.1.2 to BlackBerry Enterprise Service 10 version 10.1.3 upgrade fails at the "Finalize Installation" stage

glad to hear your doing better

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 5.0.4 and BES 10.2.2 with Exchange 2010 and SQL 2008


Please use plain text.
Contributor
delcid05
Posts: 10
Registered: ‎08-22-2013
My Device: Z10
My Carrier: BELL

Re: upgrade form 10.1.2 to BlackBerry Enterprise Service 10 version 10.1.3 upgrade fails at the "Finalize Installation" stage

[ Edited ]

Did the same thing and everything works fine now. Only difference is that i stopped two services mentionned on the upgrade guide:

Upgrade BlackBerry Enterprise Service 10
If BlackBerry Enterprise Service 10 components are installed on separate computers, perform this task on the computer that hosts the core components first, and then upgrade the components on other computers (for example, standby instances of the core components or remote administration consoles).Before you begin: •
Verify that the BlackBerry Enterprise Service 10 service account has local administrator permissions on each computer.•
Before you upgrade the computer that hosts the core components, stop the following services on each computer that hosts the administration consoles:•
BES10 - BlackBerry Administration Service - Application Server•
BES10 - BlackBerry Administration Service - Native Code Container
You do not need to stop all BlackBerry Administration Service services in the domain when you repeat the upgrade steps on other computers.1.
Log in to the computer using the service account that runs the BlackBerry Enterprise Service 10 services.2.
In the BlackBerry Enterprise Service 10 installation files, double-click setup.exe.
If a Windows message appears and requests permission for setup.exe to make changes to the computer, click Yes.3.
Click Next to start the upgrade process.4.
When the upgrade process completes, click Finish.

Please use plain text.