Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Link

New Contributor
Posts: 3
Registered: ‎10-21-2013
My Device: Q 10 SQN100-3
My Carrier: Excellular

Re: Back up did not complete :-(

Thank you, I'll try that too. John McDermott333
New Contributor
Posts: 6
Registered: ‎05-14-2013
My Device: q10
My Carrier: o2

Re: Back up did not complete :-(

same problem with my q10 when trying full backup


a little workaround appears to be the custom backup option, a partial backup of application data and settings, leaving media stuff out

New Member
Posts: 1
Registered: ‎02-18-2014
My Device: Q10
My Carrier: Vodafone

Re: Back up did not complete :-( Z10 or Q10 Backup Does Not Complete With the Link Program

Thank you so much Jerry G.  Your advice worked!!!

Posts: 741
Registered: ‎10-06-2013
My Device: Q5
My Carrier: Cosmote

Re: Back up did not complete :-(

Ahh!!! I had the same problem and it worked thank you very much my friends! Smiley Happy
New Member
Posts: 1
Registered: ‎10-05-2014
My Device: Z10
My Carrier: T-Mobile

Re: Back up did not complete :-(

I just registered to share what worked for me: reinstalled the main components of the OS using Sachesi (https://github.com/xsacha/Sachesi/releases/) -- following the "upgrade" procedure, not debrick.


I tried everything I could find on the internet and nothing worked for me. I didn't have any apps that are in the list of known problematic apps installed, tried to reset the phone, switched to airplane mode, even tried on different computers with different OSes.


After hours of trial and errors, I found out that in my case app is probably not an issue as I couldn't even backup just the calendars and contacts. At first I thought my work email is giving me this problem, so I removed all email accounts. Sadly, it didn't change anything.


Just before giving up, I noticed that BB Link actually didn't even show the storage usage of my device correctly... which made me suspect that something must be wrong with BB Link or my BB10 OS. As reinstalling BB Link and trying it out in different computers didn't work, I believed that it must be my BB10 OS.


I remembered that I did several battery pulls several weeks ago, which might corrupted some important OS files. As I don't have any recent backups (last one was from last month) and I don't want to lose my data, doing factory reset wasn't really an option for me.


Luckily, as a BB developer, I used this useful program called Sachesi (https://github.com/xsacha/Sachesi/releases/) quite often to install .bar packages and update my Z10's OS. I opened up Sachesi and downloaded the same version of OS that is installed on my phone ( -- I had to select the version manually with no device connected as my phone is already at the latest version, then (re-)installed it on my phone. After the installation completed and the phone rebooted, I opened up my BB Link and it showed the correct storage usage and I can now back my phone up again!


Hope this might help any future frustrated BB users that stumbled across this page looking for solutions...