Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Link

Reply
Developer
Posts: 419
Registered: ‎04-10-2011
My Device: Z10 LE & PlayBook
Accepted Solution

BlackBerry-Link-Helper-Agent running 100% on OS X

I just installed BlackBerry Link on my MacBook and since the restart the BlackBerry-Link-Helper-Agent consumes 100% CPU time all the time. I can't quit or force quit it, because it automatically restarts :smileysad:

I have the latest verison of OS X Mountain Lion installed.

Also, no device is connected (I currently have a DevAlpha B).

-----------------------------------------------------------------------------
Check out my apps in the BlackBerry World
Visit my developer blogs /dev/alopix and /home/alopix
BBM Channel: C0047B612
Contributor
Posts: 11
Registered: ‎02-05-2013
My Device: Z10

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

Hello

 

i have the same issue.

 

Have you found a fix for that?

 

If not, i have to delete it from Macbook, because 100% is eating battery as well.

 

Alex

Developer
Posts: 419
Registered: ‎04-10-2011
My Device: Z10 LE & PlayBook

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

I restarted my Mac and after that it was not an issue any more :smileyhappy:
Also connected the Dev Alpha device and it was successfully backed up. I disabled the auto start of the BlackBerry Link of course.
-----------------------------------------------------------------------------
Check out my apps in the BlackBerry World
Visit my developer blogs /dev/alopix and /home/alopix
BBM Channel: C0047B612
Contributor
Posts: 45
Registered: ‎05-24-2013
My Device: Z10

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

I have uninstalled the BB Link and restarted twice and the process keeps coming back up. I released almost 1GB of RAM by uninstalling BB Link. Yes, RAM. MBP 10.8.5. The process reports using 26MB still.
Contributor
Posts: 45
Registered: ‎05-24-2013
My Device: Z10

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

Ok, I need to give some more information. I noted a process named BlackBerry-Link-Helper-Agent currently wasting 35MB of RAM. I thought it strange since I thought I uninstalled the crappy Link application from my computer. So I followed the KB18771 and downloaded the installer then uninstalled Blackberry Link. Or so I thought. After being told I was successful in installing the application and the software rebooting the computer, I looked and the process was still running. And the application was still in the application folder! I drug it to the trash, emptied, restarted. Application now gone, process still there. Stopped the process--it restarts instantly. Inspected the process and it lead me to ~/library/Application Support/Blackberry Link. Tried to delete the folder but can't because DesktopFilesModel.sql and DesktopPIMSyncModel.sql are still in use. So I stop the BlackBerry-Link-Helper-Agent and I can delete the files. However the process starts back up and the first thing it does is recreate the ~/library/Application Support/Blackberry Link folder and file structure. Help!

I saw a warning label on a generator this weekend that said: Caution using this generator inside can kill you in minutes. I think that Blackberry Link should have the following warning: Caution this software will slow down your Mac in seconds.

BTW does anyone else see the irony in the words "powered by lithium" at the bottom of the forum screen? I wonder how many miligrams they take?
New Contributor
Posts: 3
Registered: ‎03-07-2012
My Device: Playbook

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

[ Edited ]

The 100% CPU is still an issue with the latest version of the blackberry link on OS X

 

I've not connected the BB and this is a fresh reboot and it's just sitting there at 100% CPU all the time chewing through one of my cores on my laptop.

 

Killing the process (kill -9) does little as it restarts itself and resumes 100% CPU Load.

 

PLEASE SORT THIS OUT!  Stick a sleep() somewhere wherever this is going nuts at the very least!

New Contributor
Posts: 2
Registered: ‎10-16-2013
My Device: Z10

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

Please, someone with knowledge provides any insight here.  I recently installed BB Link, and now the blackberrylink.helper.exe runs in the background with around 100 K of RAM usage.  It is normally my 1st or 2nd application in terms of memory usage.  My computer now runs slower.  Do I freaking need this blackberrylink.helper.exe to be running all the time?  I am about to uninstall this thing.

 

And why BB Link takes 'hours' to load?

 

Been a long time BB user but sometimes I wonder...

 

Thanks for reading

Contributor
Posts: 45
Registered: ‎05-24-2013
My Device: Z10

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

I tweeted about the problem and @blackberryhelp said to contact Verizon and ask them to escalate the issue to them for resolution. Maybe you can try that too.
New Contributor
Posts: 3
Registered: ‎03-07-2012
My Device: Playbook

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

Um, so what's the point in these forums if we're asked to raise issues through carriers back to BB?

New Contributor
Posts: 2
Registered: ‎10-16-2013
My Device: Z10

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

I restarted the PC, and if you don't connect the BB again nor open the BB Link software, this "helper" application does not load.  Once is loaded because one opens the BB Link or connects the Z10, then you are stuck with it until the next restart.... Well, at least that has been my recent experience.