Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Link

Reply
New Member
Posts: 1
Registered: ‎04-16-2013
My Device: Z10
My Carrier: Optus

Blackberry Link Stops Working

Hello everyone,

 

When i connect my new Z10 Device to Blackberry Link, it keeps saying that it has Stopped Working.

This means that I am unable to back my phone up, which is a big concern to me.

I uninstalled the Software, and reinstalled it on my desktop...........still no good.

Can someone please help me?

 

Thanks,

New Member
Posts: 1
Registered: ‎04-16-2013
My Device: Z10
My Carrier: TMN

Re: Blackberry Link Stops Working

I'm in the same situation here. Install, reinstall, uninstall and install again, same result. Even tried deepper uninstall with proper software, no good. Any ideas??? Need to import my contacts :smileysad: (Windows 7 pro x86, dell laptop, 2gb)

New Contributor
Posts: 2
Registered: ‎04-22-2011
My Device: Playbook, Torch
My Carrier: Rogers

Re: Blackberry Link Stops Working

[ Edited ]

i have been having the same problem with Link opening slowly and shutting down before it finishes a backup.  I deleted and reloaded it twice but now although i was albe to get it to back up, it takes on average 5 minutes to open and then it is slow.

 

When i go to sign in it tells me my BBid is invalid but won't respond so that i can re-enter it. it will also say that i am not connected tot he internet when i am.

 

windows 7, 64 bit

 

 

New Contributor
Posts: 3
Registered: ‎04-23-2013
My Device: Z10
My Carrier: O2

Re: Blackberry Link Stops Working

I'm having similar problems.  When trying to link my new Z10 to my computer Blackberry Link stops working.  I can't sync, backup or transfer data from my old Blackberry Device.  I was told it would be simple.  Can someone please help?

New Contributor
Posts: 3
Registered: ‎04-23-2013
My Device: Z10
My Carrier: O2

Re: Blackberry Link Stops Working

I've been experimenting with this.  I managed to install Blackberry Link on Windows XP and get it to function corrrectly.  I was able to copy the data from my previous device to my new Z10, and backup my Z10.

 

However I still can't get Blackberry Link to work on my Laptop which runs Windows Vista.  Even just closing the  software (by clicking the x in the top right hand corner) causes a window to appear stating that Blackberry Link has stopped working.  I created a log file to see if I could find out what was going on.  In the folder that it created I found the file Rim.Desktop.Exception in which I can see the followiing:

 

12:15:25.869|FATAL|1|Exception|0|Fatal Error - Inner Exception
System.IO.FileNotFoundException: Could not load file or assembly 'System.EnterpriseServices.Wrapper.dll' or one of its dependencies. The specified module could not be found.
File name: 'System.EnterpriseServices.Wrapper.dll' ---> System.IO.FileNotFoundException: Could not load file or assembly 'System.EnterpriseServices.Wrapper.dll' or one of its dependencies. The specified module could not be found.
File name: 'System.EnterpriseServices.Wrapper.dll'

 

I assumed therefore that something had gone wrong with the installation, so uninstalled the software and reinstalled it.  However, I'm still getting the same problem.  Anyone got any suggestions about what I can try next?

New Contributor
Posts: 3
Registered: ‎04-23-2013
My Device: Z10
My Carrier: O2

Re: Blackberry Link Stops Working

Noticed there was a new version of Blackberry Link, so downloaded it in the hope it would resolve my problem.  Unfortunately it has made it worse.  I can't even run it now.  Really unhappy.  The joy of getting a new phone has turned very sour.  Could use some real customer support here.