Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Link

Reply
Trusted Contributor
turdusturdus
Posts: 241
Registered: ‎03-13-2012
My Device: playbook

Blackberry Link states the Z10 is not associated with a Blackberry ID

This is after the latest upgrade.
So, on the Z10, when I open Settings, Blackberry ID, up comes a blank page. Tell me how I fix this?!

rua
New Contributor
rua
Posts: 4
Registered: ‎05-18-2013
My Device: z10

Re: Blackberry Link states the Z10 is not associated with a Blackberry ID

I am having exactly the same problems - this was after loading the latest Link software and there is no way back.

 

And there is no other support on Blackberry site this is why they are losing customers around the world.

 

New Contributor
JRuppenthal
Posts: 5
Registered: ‎05-18-2013
My Device: Z10

Re: Blackberry Link states the Z10 is not associated with a Blackberry ID

I've had this problem even before 10.1. I haven't been able to do any backup of my Z10 and it's really irking me. Both Link and my Z10 say I'm logged into my Blackberry ID, same account, but when I try and backup, I get the error message telling me the Z10 is not associated with a Blackberrry ID even though, as I said, it is. Any help? Ughhh....

Trusted Contributor
turdusturdus
Posts: 241
Registered: ‎03-13-2012
My Device: playbook

Re: Blackberry Link states the Z10 is not associated with a Blackberry ID

Trying another way, by opening Link and signing in at the top right does not work.

Even then, signed in, and associating a device with this, one's Blackberry ID, fails.

 

This has occurred since the update to Blackberry Link, and especially after the Z10 update. Given that one believes the updates fix things, or improves on them, then this is the opposite. Sad!

Trusted Contributor
turdusturdus
Posts: 241
Registered: ‎03-13-2012
My Device: playbook

Re: Blackberry Link states the Z10 is not associated with a Blackberry ID

Here is a jpg of the error message that appears every time I open Link, with the Z10 attached to the machine, and recognised.

BlackberryLink_error.jpg

New Contributor
JRuppenthal
Posts: 5
Registered: ‎05-18-2013
My Device: Z10

Re: Blackberry Link states the Z10 is not associated with a Blackberry ID

That's exactly the same error message I see when I run Link. Unfortunately, unlike you, I've never been able to run a backup, even before the 10.1 update.

Forums Advisor III
jerryg50
Posts: 1,204
Registered: ‎02-28-2009
My Device: Torch, Bold, Play Book, and Bluetooth HS-700

Re: Blackberry Link states the Z10 is not associated with a Blackberry ID

I would try this:

 

On the net, log in to your Blackberry ID account. This will verify it.  If it is not allowing you to log in, then there is a problem. If the login is successful you can log out. This login must be the same that is used in the Link program and in the phone.

 

In the phone's Settings, go to Blackberry ID. Make sure the phone is properly logged in to its account. This login must be the same used in the Link software.

 

Open Link. Log in to the same account in the Link program. Connect the phone and see if the Link program will allow you to back up the phone.

 

If all of this does not work, I would call Blackberry support for assistance.

 

 

 

Jerry G.
Trusted Contributor
turdusturdus
Posts: 241
Registered: ‎03-13-2012
My Device: playbook

Re: Blackberry Link states the Z10 is not associated with a Blackberry ID

Tried to do this, signed in with Blackberry ID on the Link. Except that it gives the same error message when connecting the Z10, with a yellow triangle appearing.

 

Plus, the Blackberry ID is found on the Z10 in settings under About, but going to the Blackberry ID in Settings always, but always, comes up totally blank! 

rua
New Contributor
rua
Posts: 4
Registered: ‎05-18-2013
My Device: z10

Re: Blackberry Link states the Z10 is not associated with a Blackberry ID

i have tried every options you describe and still nothing, it was working fine just before I did the link update, I had even done a backup and al that stuff seconds before.
Then did the Link update and nothing since, so it must be obvious that its the Link Software "update" they just released.
I am tying to get hold of Blackberry support but there is no where on Blackberry site to contact anyone at all - this was the only option.
This is one of the reason Blackberry are getting such a bad name.
New Contributor
JRuppenthal
Posts: 5
Registered: ‎05-18-2013
My Device: Z10

Re: Blackberry Link states the Z10 is not associated with a Blackberry ID

Agreed. Can someone provide a number for Tech Support so I can wait hours to have this fixed? They hide it pretty well. Really pissed off at Blackberry right now, sorry. Thanks.