Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Link

Reply
New Contributor
Posts: 2
Registered: ‎09-10-2013
My Device: Z10
My Carrier: Rogers

Blackberry link and windows 8

i have a q10 and a z10. when i plug the q10 into my computer, it syncs like a charm. But when i plug the z10 nto my computer, i get a "BSOD" with "dpc_watchdog_violation". after that my computer reboots itself. i ddi some research and found out that this is an unsolved problem, but i could still sync wirelessly.

I tried syncing wirelessy, but everytime i try dragging something into the device tab, it stucks at "preparing to sync" for a long time. Sometimes it will say connection is lost, sometimes the tabs just disappear. either way the music was not synced.

 

Please hlep

Regular Contributor
Posts: 54
Registered: ‎09-11-2013
My Device: BlackBerry Z10, BlackBerry Pearl 3G 9105, BlackBerry Curve 9220

Re: Blackberry link and windows 8

Thank you for sharing this issue with us. The error message "dpc_watchdog_violation" is generally caused by inappropriate or outdated wireless NIC drivers that are installed on the computer. However, since the issue can also be generated due to some hard disk errors, users (or administrators) should first scan the hard disk drive for any issues that it may have. In case this method fails, administrators should then remove the existing wireless LAN card drivers, and they should install the latest ones that are mostly available on the wireless LAN card drivers’ vendor’s official website.

You can also check this website:

http://www.tomshardware.com/faq/id-1656392/fix-dpc-watchdog-violation-error-windows.html


1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes

Join me on my BBM Network as well as BlackBerry Support Forums Channel
PIN: 2A5706AD
Twitter: @sesa_jeckieboo | @i_am_jecka
WeChat: Sesa_Domina_Jecka | i_am_jecka
New Contributor
Posts: 2
Registered: ‎09-10-2013
My Device: Z10
My Carrier: Rogers

Re: Blackberry link and windows 8

i ran the console and stuff. I have no had drive errors. and i also tried updating my wifi adaptor's driver, but it seems to be the newest. after all this, the crashes are still coming back, but not immediatly when i plug the phone to the computer. This time it seemed to work for 1 couple of minutes, but when you tried to sync anything, it says connection error, then i t crashes

SYP
New Contributor
Posts: 7
Registered: ‎08-27-2014
My Device: Current: Z10 and loving it! Previous: Torch, Storm 1 & 2, Curve 1 & 2, Pearl
My Carrier: Verizon

Re: Blackberry link and windows 8

I suspect there are several different glitches at work, not just one, so you have to go through the various solutions until you figure out what works for your system. I have a Z10 and I'm running Windows 8.1. What finally worked for me through trial and error was this:

 

  • Installed Microsoft .NET framework 3.5 SP1. You're suppose to be able to go into your settings for Windows 8 and enable this but for some reason it didn't seem to work for me, so I downloaded & installed the full package from here: http://www.microsoft.com/en-us/download/details.aspx?id=25150
  • After installing this I ran Windows Update to ensure all the service packs and patches for the 3.5 .NET framework were also installed
  • Then I deleted/uninstalled everything Blackberry off my computer (including network adapter drivers, Blackberry device manager, etc)
  • Disabled Windows Defender and my antivirus program temporarily
  • Downloaded a fresh copy of the Link software, right clicked and selected "run as administrator"
  • During setup I made sure the "start when device is connected" option was selected (that may not be the exact wording, but it's something like that) and I chose not to have it run in the background all the time
  • Once Link was installed I set my phone to airplane mode (no network or wireless connections)
  • Then on my phone I went to Settings --> Storage and Access and switched "Access using Wi-Fi" to off. On the same screen I set "USB Connection" to Windows.
  • Then I plugged my phone into a 3.0 (superspeed) port and... success!! (before doing this be sure to see my note below about connecting a Blackberry to a 3.0 port, which has been known to cause issues for some Windows 8 users)

Link recognized my phone, connected to it after a second and I was able to do a backup. Windows even mounted the flash drive (internal storage) of my phone and I was able to transfer files to my laptop with ease!! I've disconnected and reconnected the phone, closed Link and reopened it just to see it was a one time thing -- as long as I used the 3.0 port and had my phone set to airplace mode it has connected great

 

HOWEVER....

 

I'm running Windows 8 and there is a known issue with connecting a Blackberry to a 3.0 USB port with Windows 8 (it causes the "blue screen of death" (BSOD) within about 10 minutes). The work around is to use a 2.0 port, but Link won't communicate with my device on a 2.0 port for me for some reason -- some of you might also have this issue. So what to do?

 

I came across the following suggestion on a forum thread about the 3.0 USB / Windows 8 / Blackberry issue causing the blue screen of death (it gives a DCP Watchdog Violation and you have to reboot your computer). The person posting only had 3.0 ports, no way to use the work around of sticking to 2.0 ports when connecting their phone, so they fiddled around until they found a fix that worked for them -- I decided to give it a try in hopes that I might be able to use the 3.0 port to connected to Link.

 

DCP Watchdog Violation -- possible fix for Windows 8 users connecting on a 3.0 port

 

Control Panel --> System and Security --> Power Options --> Change plan settings (beside your currently seclected plan) --> Change advanced power settings- -> USB settings --> USB selective suspend settings --> then choose to disable both Battery and Plugged in

 

It worked! I had my Z10 plugged into my superspeed 3.0 port several times this evening, once for well over an hour, and I did not get the BSOD once! Before doing this I would've had the BSOD at least five times during that same period. So, I hope this works for others, too.