Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Link

Reply
New Contributor
Secret-Lan
Posts: 3
Registered: ‎01-27-2014
My Device: Q10

New Q10 cannot connect to Link via USB

Hi everyone, I've run into a problem with my new Blackberry Q10 (text messages getting stuck in the notification window) and, seeing as I've had it less than a month, my retailer has ordered me another Q10 and is going to send the old one back.

Now, my understanding is that if I backup my phone to my computer it will save all of the changes I've made regarding ring tones, notifications and other settings so when I get the new one I can just plug it in, say go and have the new phone essentially set up exactly the same as the old one.

Problem is that Blackberry Link has been unable to connect to my phone via usb. I am using Windows 7, have tried a few different usb ports (one of which I use to configure/update my ipad and ipod) but nothing has helped. There is no error message, the status indicator on the phone just stays on "not connected". The computer makes the "device connected" sound whenever I plug the phone in and the phone is able to charge and recognize that it is connected to a computer but for some reason Link still does not recognize it. It is, however, able to connect through wifi...

Any ideas?

Thanks,
Forums Advisor III
fyip
Posts: 2,010
Registered: ‎10-26-2013
My Device: Z10

Re: New Q10 cannot connect to Link via USB

Connect your phone to computer.

 

Go to Control Panel, Device Manager, click View on the Menu, click show hidden devices.

 

Look for a yellow exclamation mark for any BB or RIM driver, if found expand + to show driver then right click and click Update.

 

If it will not update or it is greyed out right click and click Uninstall, unplug your phone, restart computer.

 

After restart wait 5 minutes, open Link then plug in your phone.

New Contributor
Secret-Lan
Posts: 3
Registered: ‎01-27-2014
My Device: Q10

Re: New Q10 cannot connect to Link via USB

Yup, that fixed it - thanks!
Forums Advisor III
fyip
Posts: 2,010
Registered: ‎10-26-2013
My Device: Z10

Re: New Q10 cannot connect to Link via USB

Your welcome, happy linking !

New Contributor
VSeattle
Posts: 3
Registered: ‎02-02-2014
My Device: Q10

Re: New Q10 cannot connect to Link via USB

Hi, fyip - I have the exact same issue, followed  your steps with respect to the Device Manager, but with no success (there were no yellow triangles). Link still is not recognizing my new Q10 at all. I tried updating the Link software, rebooting my PC - nothing works.

 

Like Secret-Lan, I was using a Q10 that had a problem - just got my warranty replacement yesterday & I'm trying to restore the last backup from my old Q10. I'm desperate - I have data in my calendar that I need in order to bill my clients.

 

I'm using Link on a PC running Win7. Can you help?

 

Thanks!

Forums Advisor III
fyip
Posts: 2,010
Registered: ‎10-26-2013
My Device: Z10

Re: New Q10 cannot connect to Link via USB

[ Edited ]

VSeattle:     Try a different USB Port, no success try the below. Your phone should not be attached.

 

Device Manager, Show hidden devices, Uninstall the 2 Drivers listed under (BlackBerry)  (BlackBerry Smartphone)

 

If you do not see them listed do this: Control Panel, System, Advanced system settings, Environment Variables,

Under System variables click New.

 

Variable name: type:     devmgr_show_nonpresent_devices

Variable value: type:     1        click OK,  close all open pages.

 

Go back to Device Manager and uninstall the 2 Drivers.

 

Once uninstalled restart computer, wait 5 minutes then connect your phone.

 

 

New Contributor
VSeattle
Posts: 3
Registered: ‎02-02-2014
My Device: Q10

Re: New Q10 cannot connect to Link via USB

Thanks for your suggestions, fyip. I tried all my USB ports (with reboots in-between), with no success. Then I went through the process you suggested (the devices did not appear in my "hidden" list, so I had to show nonpresent items & uninstall them that way), rebooted & connected after 5 minutes - unfortunately, no luck with that either.

 

I've confirmed that both my laptop and my phone are logged in to my blackberry ID. When the phone is connected, Link still shows no devices on the left-hand side, under the "Computer" tabs. When I click on Remote File Access & try to refresh the device list there, here is the text of the error/failure message: "BlackBerry ID _____@______.com isn't associated with a device running BlackBerry 10OS or an error occurrred when trying to retrieve your ifnormation from the BlackBerry ID servers.  >Confirm that you are signed in with the same BlackBerry ID in BlackBerry Link and on your device. (I am)  >Sign out of your BlackBerry ID in BlackBerry Link and try signing in again."

 

I did try signing out in Link & when I signed back in, I see my old device, which I removed yesterday. It shows as Disconnected, even though my new device is connected with a USB cable. What do you suggest next?

 

Thanks for your help!

Forums Advisor III
fyip
Posts: 2,010
Registered: ‎10-26-2013
My Device: Z10

Re: New Q10 cannot connect to Link via USB

Try calling these #'s for help.

 

BlackBerry 1-877-255-2377

 

AT+T   1-800-417-3654

New Contributor
VSeattle
Posts: 3
Registered: ‎02-02-2014
My Device: Q10

Re: New Q10 cannot connect to Link via USB

Got it resolved - thank you! It just needed a phone reboot, after everything else had been done.

 

Thanks so much for your help!

Forums Advisor III
fyip
Posts: 2,010
Registered: ‎10-26-2013
My Device: Z10

Re: New Q10 cannot connect to Link via USB

Your welcome, now you can bill those clients and when you get paid send me a virtual beer !

 

Thanks for the reply and the info about the phone reboot.