Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Link

Reply
Contributor
ddch
Posts: 47
Registered: ‎06-16-2009
My Device: Blackberry Z10

New Version Of LINK Software & Still Install Issues & Backup Issues & Now A Sync Issue

Well after waiting for the updated LINK software I downloaded it and installed it after removing the previous version.  I disabled the A/V / Firewall software and still it says that it failed to install, and gave the exact same error message advising an issue with a DLL.-

Error 1723

There is a problem with this Windows installer package. A DLL required for this install to complete could not be run

 

So I uninstalled the Desktop Manger V7.1 for my BB9800, removed the LINK software and all other traces of BB software, removed these from the registry as well, rebooted and tried again but still the same.

 

The software like the previous does seem to install and work sort of, still doesn't backup but does sync, but now I have a new issue, it now says that iTunes is not correctly setup/configured, very strange cos it was under the last version of LINK andf it worked.

 

This is all now becoming a joke,  for the backup issue am told that I need to reload the software as it appears there is an issue with the BB ID on the phone, which there is as I also can't get any apps.  So it looks that for BB10 there is a requirement to have a working/active BB ID on the phone for it to backup yet it will sync with the phone.

 

Am concerned that if I reload the software that although I was lucky to do a device switch with the 9800 and managed to get my contacts this time round I wont, plus I will have lost anything I updated or added since the original device switch.

 

Blackberry's response have been very poor if not non existent, when I pointed out that the link they sent to reload the software referred to DM7.1 no response.

 

I did try the carrier support and whilst they said to follow Blackberry advice, all they could add was that if the phone ends up bricked that they will replace it.

 

I did had the option of returning the Z10 earlier but thought that I would stick it out and have some faith in BB, but am regretting the decision

Please use plain text.
Contributor
ticfever
Posts: 36
Registered: ‎06-21-2011
My Device: Playbook and Z10
My Carrier: EE

Re: New Version Of LINK Software & Still Install Issues & Backup Issues & Now A Sync Issue

Uninstall the LINK

You need to use RegEdit (type this in the search box in the START Bar).

Do a search of the registry for everything that says BLACKBERRY.

Then DELETE these.

Restart and install LINK.

If you are concerned about interfering with the registry - just save a copy of it.

 

Please use plain text.
Contributor
ddch
Posts: 47
Registered: ‎06-16-2009
My Device: Blackberry Z10

Re: New Version Of LINK Software & Still Install Issues & Backup Issues & Now A Sync Issue

Thanks for the advice, but unfortunately tried that, after 2 reloads and a security wipe managed to have LINK fully see the Z10 and my BB ID work on Z10.

 

Managed to get it to perform a restore which gave me back my contacts, but something I never saw on the 9800 was that the Z10 asked me the passwords for my email accounts again,  had thought that this would have been included in the restore.  After I managed to get it to backup once, it then decided no more backups.

Please use plain text.
New Contributor
Fordyce10
Posts: 2
Registered: ‎02-25-2013
My Device: Z10

Re: New Version Of LINK Software & Still Install Issues & Backup Issues & Now A Sync Issue

I have the same problem and can get no help from either Blackberry or my provider.

 

I have tried multiple re-loads and even a system restore.

 

They need to get a fix for this out very soon.

Please use plain text.