Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Pearl™

Reply
New Contributor
mm1334
Posts: 3
Registered: ‎08-19-2008
My Device: Not Specified

A true technical challenge - Problem with Call Forwarding and ID

I hope there are some real experts on this site, because everybody else has failed to help me fix this.

I have been dealing with this strange issue for over a year - since I got my phone. This issue has gone well over the head of level 1 and level 2 blackberry tech support at T-Mobile, and even a RIM technical representative who happened to be at their facility one time when I called. I've also posted on two other sites like this, and have received no solution.

I forward calls from my work-issued Nextel to my personal phone when I'm at home - my personal phone is my Blackberry Pearl 8100.

When someone calls the Nextel, it will forward to my personal phone but the caller ID shows up "Private Number".

There have been random instances during the last year when the caller ID started working for a day or two - these instances have been completely random and without any consistency.

I have tried having my nextel forward calls to my friend's Pearl 8100, which is identical to mine and has the same software versions. His phone shows the caller ID of the forwarded call just fine.

I went through literally every setting on my phone and my firend's phone - ensuring that they match. Yes, this was a very long and tedious process.

I tried putting the SIM card from my phone in his phone, and vice versa. The Caller ID showed up fine on his phone still (with my SIM), but still failed to show up on mine (with his SIM). This obviously seems to indicate the phone is the problem.

I tried changing my SIM card (just to be safe), wiping the handheld completely, and resetting all settings - with no success.

I tried forwarding calls from my wife's t-mobile RAZR to my phone to ensure it wasn't something about Nextel, and the same issue continued.
I also tried confirming all the options in my smart dialing menu were correct - even changing them around some to experiment.
I have tried going to the Options>Security Options>General Settings screen, and ensured that content compression is disabled - content protection is disabled - and "include address book" is set to No. 

I finally got T-mobile to replace my phone. So I now I have a new SIM card, a new phone, and newly updated software. Here's the kicker - the call forwarding still shows Private Number when it comes up on my BRAND NEW PEARL 8100. It still shows up fine on other Blackberry Pearls.

I am completely lost on this one - if replacing the phone completely didn't fix it, what could be the issue (unless I got another defective phone, which would be a really weird coincidence - and even then I'm not sure what would be wrong with the phone to cause this).

Somebody please help!
New Contributor
mm1334
Posts: 3
Registered: ‎08-19-2008
My Device: Not Specified

Re: A true technical challenge - Problem with Call Forwarding and ID

I'm very disappointed, I thought this is where the best experts gathered since it's the official blackberry site.  Is there not anybody on here that can help me with this? If not, can somebody refer me to someplace where I can get help.

 

New Contributor
jmcluett
Posts: 9
Registered: ‎08-16-2008
My Device: Not Specified

Re: A true technical challenge - Problem with Call Forwarding and ID

I can understand that you would think it was your phone... but its sounds like a different issue to me.  First, "Private Name" information is forwarded from the originating number to your handset through a "switch" or telephone switch where your number is stored by your wireless provider as far as I know.

 

I know the number does show on other phones, so I would be getting your provider to verify your settings in thier "switch" rather than anything with your handset.  Also, they should make sure that your routing information for your features in the backend is correct.  It could be that its not receiving the proper information or its mis interpreting the info being sent and that is being sent to your handset as "Private Name".

 

Without knowing anything else, that may be a good place to start

New Contributor
mm1334
Posts: 3
Registered: ‎08-19-2008
My Device: Not Specified

Re: A true technical challenge - Problem with Call Forwarding and ID

Well I've eliminated the "originating phone" by any definition - being it the one forwarding the call or the one making the call that is forwarded.  This has been displayed as irrelevant by numerous switches of each. Any forwarded call from any number through any forwarding phone shows up as Private Number. I've talked to tier 2 tech support at T-mobile, and they said it was not them. Also, another t-mobile blackberry pearl that belongs to my neighbor receives it just fine.

 

I can call them again, but I'm not sure their tech support people are going to be able to look at whatever is routing the call.  Any tips on improving those odds?

 

Thanks for the input.

New Contributor
jmcluett
Posts: 9
Registered: ‎08-16-2008
My Device: Not Specified

Re: A true technical challenge - Problem with Call Forwarding and ID

If you have a different phone, and it happens on any forwarded phone, and it works on your friends pearl... then by process of elimination its most likely in your own switch build... or number build.  When you talk to them again ask them to make sure that the number is being routed properly from one provider to another, and to re verify your switch build is correct, or even re build it.. doesn't take that long.
New Member
glgarcia1
Posts: 1
Registered: ‎09-11-2008
My Device: Not Specified

Re: A true technical challenge - Problem with Call Forwarding and ID

i am having a similar problem.  I have a Pearl 8100 with T-Mobile.  I've had it for almost two years (since Jan. '07).  About four weeks ago, this problem started.  I have a landline office phone through AT&T, and when I leave the office, I forward this land line to my Pearl.  When someone calls my office after hours, on nights and weekends, the problem is that instead of the person's name and phone number showing up on my caller ID, my Pearl shows that I am calling myself from my own cell phone!  I don't get "Private Number" like you get, the caller ID shows that I am calling myself!

 

I've spent six or seven hours with T-Mobile tech support, with five different tech people over a period of several days and several phone calls, and they can't figure it out; their final and "best" answer is that it's a blackberry problem, that the issue has been addressed and identified as a "known issue" and a "trouble ticket" has been created.  I contacted RIM and they directed me to their archived troubleshooting and to this forum, so I still don't have an answer.  And T-M had no answer when I told them that this feature worked just fine from Jan. '07 through Aug. '08.  T-Mobile offered to put me into a different device, the T-Mobile wing, which by fair assessment, looks like a piece of junk, and it's window's mobile, which is even worse.  I rejected this option.

 

I'm hoping someone can solve this.  One friend of mine thought that it's a network issue, any issue with caller ID would be with the network, not the phone or its software...this makes some sense to me...and one of the techs at TM thought that this could be the issue as well.  As T-M upgrades its networks to 3G, these bugs are popping out. who knows, I'm sticking with this Pearl and 8100 for a little while longer, b/c I am waiting to see if an answer shows up somewhere on one of the forums, but I hate not knowing who's calling before I answer the phone!

New Member
asiancreation21
Posts: 1
Registered: ‎10-21-2008
My Device: Not Specified

Re: A true technical challenge - Problem with Call Forwarding and ID

Has this Problem been resolved yet? 

I am having the same problem with the Blackberry 8700 on tmobile right now.

Guru I
Bifocals
Posts: 16,194
Registered: ‎07-23-2008
My Device: Torch 9850/ Playbook
My Carrier: VerizonWireless

Re: A true technical challenge - Problem with Call Forwarding and ID

Hi and welcome to the forums!

 

Two different phones same problem.

Two different SIMs same problem

Different model phones, same problem.

 

Not different, your telephone number.

The one common denominator.

Have it re-optioned by the carrier.

 I agree with JMcluett.

 

Just simple logic, and just my simple opinion.

 

If you need more info please ask!  If not please resolve the thread using the options by the Kudos’ star, Just place the check in the Post that answered your question, Thanks  

 

Click Accept as Solution for posts that have solved your issue(s)!
Be sure to click Like! for those who have helped you.

Install BlackBerry Protect it's a free application designed to help find your lost BlackBerry smartphone, and keep the information on it secure.

Follow Bifocals on Twitter

New Member
rgcarterva
Posts: 1
Registered: ‎09-19-2009
My Device: Not Specified

Re: A true technical challenge - Problem with Call Forwarding and ID

Anyone discover a fix here?  This problem just showed up for me a day ago.  Interestingly, I've tried having calls forwarded to my wife's T-Mobile # and the problem doesn't hit her, she also has a blackberry pearl.  I've also put my SIM card in her phone and forwarded calls to my number and the correct forwarding number displays.  Similarly, when I put her SIM in my phone and forward calls to her number, the forwarding number is correct.  It's only when it's my SIM and my phone.  I've wiped the phone and reinstalled and problem persists.  Tech support has no idea and wants me to buy a new phone... but clearly the phone isn't the issue since it works with my wife's SIM card.  I've also had them replace the SIM card.  Given someone else's post above, it sounds like even replacing the phone may not solve the problem.  Ideas?

 

 

New Contributor
Nelimungous
Posts: 2
Registered: ‎02-10-2009
My Device: Bold 9700

Re: A true technical challenge - Problem with Call Forwarding and ID

I know this post is old and I have done some searching. Does anyone have any idea how to fix this or whom to call to get this fixed? I am wondering if it's device related.