Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Pearl™

Reply
Visitor
Justin200000
Posts: 1
Registered: ‎01-19-2012
My Device: BlackBerry® Pearl™ 8120

I need help updating my Pearl 8120 App World Software

Hi, I need help updating my Pearl 8120 Blackberry App World software.  I have a T-Mobile data plan.  I have an old version of Blackberry App world on my 8120 ( 1.1.0.33 ) and cannot upgrade.  When I try yo upgrade App World I recieve the following message "Sorry, your device does not meet the system requirements that are needed to support Blackberry App World"  Is the 8120 outdated?

New Contributor
ebernard
Posts: 2
Registered: ‎11-03-2011
My Device: Blackberry pearl 8120

Re: I need help updating my Pearl 8120 App World Software

Hi, I need help updating my Pearl 8120 Blackberry App World software.  I have a T-Mobile data plan.  I have an old version of Blackberry App world on my 8120 ( 1.1.0.33 ) and cannot upgrade.  When I try yo upgrade App World I recieve the following message "Sorry, your device does not meet the system requirements that are needed to support Blackberry App World"  Is the 8120 outdated

New Contributor
ebernard
Posts: 2
Registered: ‎11-03-2011
My Device: Blackberry pearl 8120

Re: I need help updating my Pearl 8120 App World Software

Hi, I need help updating my Pearl 8120 Blackberry App World software. I have a T-Mobile data plan. I have an old version of Blackberry App world on my 8120 ( 1.1.0.33 ) and cannot upgrade. When I try yo upgrade App World I recieve the following message "Sorry, your device does not meet the system requirements that are needed to support Blackberry App World" Is the 8120 outdated
Retired
SmoothRider
Posts: 2,649
Registered: ‎04-01-2008
My Device: 9500, 8110, 8700, 8220, 9100, 9800, 9810, Z10

Re: I need help updating my Pearl 8120 App World Software

Hello ebernard, 

 

Welcome to the forums. 

 

Here are the system requirements for the BlackBerry App World™ storefront.

To ensure that your BlackBerry smartphone will support BlackBerry App World, it must have the following:

  • BlackBerry App World 2.1 requires BlackBerry® Device Software v4.5 or higher. BlackBerry App World 3.1 requires BlackBerry® Device Software v5.0 or higher (Click "options", then "about" from your smartphone to check your version). Learn how to update your device software
  • A trackpad, trackball or touch screen
  • A service plan that includes access to the BlackBerry® Browser

You can check to see what software versions are available for your device by visiting your service providers download site.

 

BlackBerry Desktop and Device Software Download Sites

 

-SR

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!