Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
New Contributor
Posts: 6
Registered: ‎04-20-2013
My Device: Playbook 16gb
My Carrier: Telus

Camera won't work

I have had my playbook for about 11 months.   I recently discovered the camera is not working.    I get an error message "error.4003 picture when I try to take a picture.    I don't use my camera very often so not sure if this is a new problem with the latest download of if it was there beforehand.   While I don't use it very often, I really like the quality of pictures and do like to use it occasionally.

Super Contributor
Posts: 271
Registered: ‎03-21-2013
My Device: Z10 STL 100-2 & PlayBook 64GB

Re: Camera won't work

Have you tried restarting your playbook?

---------------------------------------------------------------------------------------------------------
Twitter: @ukmight
1. Click on the " Like " button if you find anything helpful posted.

2. If any of the replies in your post has resolved your problem, mark the reply(ies) as " Solution ", so that others can readily view the solution instead of creating another redundant post.
Super Contributor
Posts: 271
Registered: ‎03-21-2013
My Device: Z10 STL 100-2 & PlayBook 64GB

Re: Camera won't work

error.4003 is most likely a hardware issue. So if your device is still covered within the warranty, immediately contact blackberry service center and they should provide you a replacement.

---------------------------------------------------------------------------------------------------------
Twitter: @ukmight
1. Click on the " Like " button if you find anything helpful posted.

2. If any of the replies in your post has resolved your problem, mark the reply(ies) as " Solution ", so that others can readily view the solution instead of creating another redundant post.
Forums Veteran I
Posts: 1,941
Registered: ‎11-28-2011
My Device: PlayBook 32 & 64 GB & Torch 9860
My Carrier: Teksavvy

Re: Camera won't work

Others have reported the same problem usually after an OS update. They got the camera working again after doing a restore of their backup file.
New Contributor
Posts: 6
Registered: ‎04-20-2013
My Device: Playbook 16gb
My Carrier: Telus

Re: Camera won't work

Thanks for the help.   I am not tech savvy at all.   Is it very complicated to do a restore?    This is the second time I have had problems after doing an update, don't think I'll be doing any more after this!!!

Forums Veteran I
Posts: 1,941
Registered: ‎11-28-2011
My Device: PlayBook 32 & 64 GB & Torch 9860
My Carrier: Teksavvy

Re: Camera won't work

Have you done a backup of your PlayBook files to your computer prior to the upgrade of the OS. If the answer is no, then you cannot do a restore.
Visitor
Posts: 1
Registered: ‎04-22-2013
My Device: Playbook
My Carrier: ICE

Re: Camera won't work

Hi, I have the same exact problem;  "error.4003 imagen"

 

I have tried every little thing they post in every Backberry forum, I have reset the Playbook, I upload the OS again, and nothing; still the same error message all the time.

 

If you have found a solution even if I have to upload the OS again or maybe that OS update was damaged and that it why I get this error; please let me know how can I get a new OS.

 

Waiting for your comments 

Forums Veteran I
Posts: 1,625
Registered: ‎02-28-2012
My Device: Two PB's

Re: Camera won't work

[ Edited ]

Whereas I agree with Lost-at that some camera malfunctions have been fixed by software, error 4003 is HARDWARE problem. Needs to be sent to repair shop. There is no user fix for 4003.

 

Message to OS designers - there's no point in having user error codes if you don't provide users with a list of the ocdes and their meanings. - Der!

_________________________