Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
Forums Advisor I
chaosdivine
Posts: 511
Registered: ‎09-16-2012
My Device: BB PlayBook (32 GB Wi-Fi OS 2.1.0.1314) and Torch 9810 (OS 7.1.0.746)

Re: Cameras not working

[ Edited ]

Security wipe


tleparskas wrote:

I'll try that.

 

In th emioddle of SECOND OS re-load.

 

This time with security wipe and de-brick.

 

4003 error back and my camer screen is black!!!!

 

It's the freaking OS!

 

I'll see what the 3 button re-boot does. I'm reloading data - and I have a trip tomorrow.

 

Serves me for doing an upgrade ona  new OS - too mant bugs!!!


For the record, a security wipe is NOT effective to reload the OS. It only removes your data and installed applications. It does NOT refresh the OS itself or remove OS update corruption. You need to accomplish this from the Desktop Management software using a connected computer. See my post marked 8 of 9 in this thread with screenshots: http://supportforums.blackberry.com/t5/BlackBerry-PlayBook/OS-upgrade-issue/td-p/1950961

 

If that method doesn't work, then ya, for sure, it's hardware related and my advice is to seek warranty service or return the device.

New Contributor
shurgen
Posts: 6
Registered: ‎10-15-2012
My Device: Playbook

Re: Cameras not working

Did what chaosdivine suggested above, which was refreshing the OS through the desktop manager. 

The camera worked fro the first time, then stopped working afterwards. 

I would still like a response from someone who can give me the instructions to getting this fixed. There are many people with this same problem. 

Contributor
tleparskas
Posts: 13
Registered: ‎12-23-2011
My Device: Playbook Tablet 32g / Blackberry 9800 smartphone

Re: Cameras not working

I did the above and updated through the desktop manager.

 

Camera has the same error and video chat does not function.

 

After calling support it was determined to ship back for repair/replacement.

 

Lucky I had one month on warranty.

 

Still to be determined if they fix, replace or charge me for non-covered work.

 

We'll see.

 

TL

Contributor
icemanswimmer
Posts: 33
Registered: ‎05-26-2012
My Device: 9700 6.0

Re: Cameras not working

You can try this, it only works if you still can get the camera software working, I mean if u are not getting the message that the camera is in use...

 

Open camera

Press and hold the play/pause button on the top of the PlayBook until u get the sound muted

Release the button

Press and hold again until the sound is on again

Close camera

Restart the PlayBook

Try opening camera again

 

Let me know if it worked for u

 

Developer
Gareth
Posts: 229
Registered: ‎05-14-2008
My Device: 8520, 9700

Re: Cameras not working

I discovered this recently after the 2.1 production release. Dont ever use the camera. I had rim confirm hardware failure by sending them the pb logs initiated via "help" app. Playbook tech analysts are currently tracking this issue to ascertain cause/s. I tried two wipes and updates with no luck.
Trusted Contributor
beavertail
Posts: 101
Registered: ‎09-14-2012
My Device: Playbook 16GB, 32GB, 64GB, Z10

Re: Cameras not working because camera resource is not released by other

It is a software bug and not a hardware problem. I can replicate the problem in my midst of developing a Playbook App.

 

I am in the middle of developing an app and stumble into the same error 4003 problem. I can replicate the problem everytime in my own code and in the Webworks sample code called "Kitchensink" supplied by Adam Stanley of RIM.

 

To replicate the problem, first, run takeVideo() to take a video. Then if you try to run takePicture() afterward, you will get a black screen and if you hit the shutter, you will get the error 4003.

 

However, going the other way, take picture (takePicture() ) first then take video (takeVideo), there is no problem. It works fine.

 

This tells me that there is an API error in the takeVideo(). The camera viewfinder resource is not released for the next action.

 

So what some of you are seeing might be along the same line. Something was used before and lock up the camera resource.

 

Hope support will read this and save people from sending in the Playbook for replacement. Instead should wait for the API fix.

 

Hope this help.

 

 

 

New Contributor
shurgen
Posts: 6
Registered: ‎10-15-2012
My Device: Playbook

Re: Cameras not working because camera resource is not released by other

Thanks beavertail. 

The issue is that this problem has been going on for almost a year now (for me, anyway) with no responses from Blackberry or intentions to fix it. It is very very frustrating that this is happening without any hope of it being resolved any time soon. 

Trusted Contributor
beavertail
Posts: 101
Registered: ‎09-14-2012
My Device: Playbook 16GB, 32GB, 64GB, Z10

Re: Cameras not working because camera resource is not released by other

My family has eight Playbooks. I have not come across this error in normal camera and video use with the "Camera".

 

I ran into the error during my app development in HTML5. I searched the database and saw this link, so I just give it a reply. 

 

At least I think some of the problem is caused by some camera application hogging the resource and not releasing it to the "Camera".

 

Of course, there are other scenario that could generate the error too.

Forums Veteran I
jarviser
Posts: 1,625
Registered: ‎02-28-2012
My Device: Two PB's

Re: Cameras not working because camera resource is not released by other

That's why we, and RIM support, generally take people with all apparent hardware errors to try a debrick process first. If completely replacing the OS and testing the problem before restoring any apps or data still gives an error it it surely unlikely to be a software bug in that instance or we would all have it.  If the error goes away it was software. Using that guideline will prevent unnecessary visits to the store or service centre.

_________________________
Contributor
tleparskas
Posts: 13
Registered: ‎12-23-2011
My Device: Playbook Tablet 32g / Blackberry 9800 smartphone

Re: Cameras not working because camera resource is not released by other

beavertail:

 

what an excellent follow-up and answer!

 

I hope RIM developershave seen this!

 

No more returned products for them to deal with. Geez, a warehouse full of fairly decent playbooks, that could be fixed with an OS upgrade!

 

Nice.

 

Tom Leparskas