Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
Forums Advisor I
chaosdivine
Posts: 511
Registered: ‎09-16-2012
My Device: BB PlayBook (32 GB Wi-Fi OS 2.1.0.1314) and Torch 9810 (OS 7.1.0.746)

Re: Odd behavior with large(ish) wireless file transfers

[ Edited ]

bisleybloke wrote:
Hi there,

I'm sure you're right. Just gonna take some experimentation to track it down.

Kindest

Here is the thread I posted that has some screen shots that may or may not help you. I am using an N router. I too had flaky connections but managed to fix them. See if you can replicate any of the settings I used.

 

http://supportforums.blackberry.com/t5/BlackBerry-PlayBook/WLAN-Problem-since-2-0-1-358/m-p/1914499#...

 

Also, it could be something as simple as interference on the particular channel your router is using. Try switching the router channel.

 

Contributor
bisleybloke
Posts: 10
Registered: ‎10-27-2012
My Device: Playbook

Re: Odd behavior with large(ish) wireless file transfers

Many thanks for that, I'll read it properly and give it a go tomorrow. Eyes going a bit square at the moment.

Kindest
Forums Advisor I
chaosdivine
Posts: 511
Registered: ‎09-16-2012
My Device: BB PlayBook (32 GB Wi-Fi OS 2.1.0.1314) and Torch 9810 (OS 7.1.0.746)

Re: Odd behavior with large(ish) wireless file transfers


bisleybloke wrote:
Many thanks for that, I'll read it properly and give it a go tomorrow. Eyes going a bit square at the moment.

Kindest

OK, good luck. I'll check in tomorrow to see if you have any luck.

 

Contributor
bisleybloke
Posts: 10
Registered: ‎10-27-2012
My Device: Playbook

Re: Odd behavior with large(ish) wireless file transfers

Hello Folks,

 

sorry I didn't get back with an update yesterday. Minor crisis to deal with. Managed to get some testing done last night though - with some interesting results.

 

First off, I looked carefully at my wlan configuration.

 

Like I said, oldish router, G only, nothing on adjacent channels, no ability to do qos etc and no ability to change or bond channel widths. About the only thing that could (conceivably) have any impact is the ability to run in "mixed mode" i.e have both b and g supported. I set that to "G Only"

 

Checked the playbook config. Not a lot to do there really, and started transferring files.

 

Interesting (although a little tedious :smileyhappy:

 

I used a 1.65 GB avi - must get 'round to handbraking that !

 

Sometimes it copied across ok !

Sometimes I got an error saying the connection was interrupted.

Sometimes I got an error saying that the file could not be read or written to. This particular message was written in such a way as to indicate that the mac DIDN'T KNOW if the problem was reading the file or writing the file ! Very telling. 

 

No pattern at all that I could identify.

 

Really suspicious now......

 

I ran the ftp server on my mac and using ESfileexplorer on the pb copied the file several times without failure !

 

Conclusion

 

I think the first thing I'd like to say is that my conclusion is only based on what I've seen in MY setup i.e equipment and environment.

 

I think broadly what is happening is that networking under smb is not awfully robust and that what I'm seeing is basically a timing problem. My evidence is backed up by my own experience of seeing things like this before.

 

The giveaway for me is that the error(s) thrown on the mac is/are sufficient to say that it doesn't really know what the heck happened. It efectively is saying "I don't know what happened, I'll throw an error. Which error shall I throw ? Oh that one will do"

 

For me, the killer evidence is that I never had a failure using ftp.

 

Bootnotes:

 

Thanks to those you who came through with suggestions and made me think :smileyhappy:

 

For mac users out there who would occasionally like to take a deeper look at their wireless environment. Take a look in /System/Library/CoreServices and drag "WiFi Diagnostics" to your desktop. You can just run it where it is if you'd like.

 

One of these days, I'll get an "n" router, I'm confident the problem will go away (or change) Like I said I'm talking about MY environment and setup. In the meantime I'll make a choice between smb and ftp by intuition.

 

Thanks Guys.

 

 

 

Super Contributor
TroyTempest
Posts: 367
Registered: ‎09-22-2012
My Device: Playbook 32

Re: Odd behavior with large(ish) wireless file transfers

If you go for N then you need to go for WPA2 AES encryption, Playbook is very fussy with N in that they actually followed the rules and many routers don't!

 

I find that Mac is more robust than Windoze any day. Not many people have problems just establishing a connection with MAc as opposed to countless problems with Windoze.  However I do find sometimes that Finder will not allow copy and paste were it will allow drag and drop, and may not establish a connection with wifi occasionally until I reboot Mac and playbook. Permissions in Samba are not so robust.  

 

But once you've had Mac you never go back.

________
Contributor
bisleybloke
Posts: 10
Registered: ‎10-27-2012
My Device: Playbook

Re: Odd behavior with large(ish) wireless file transfers

Hi there, thanks I'll take heed of that.

 

With particular regard to smb on the mac - Apple changed the implementation in Mountain Lion (Samba 3) and broke a lot of little things in the process (Sigh)

 

"Once you've had a Mac, you never go back"

 

Oh, you're **bleep** right. :smileyhappy:

 

Thanks and Regards