Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
New Member
akhilashokk
Posts: 1
Registered: ‎10-06-2012
My Device: Blackberry Playbook
My Carrier: BSNL

Playbook dead battery - not switching on

[ Edited ]

The problem is exactly this:

>When I plug in the wall charger, after some 2-5 seconds the red led glows and stays on for some 15 seconds.
>Then the LED turns off and after some 5 seconds the Red battery icon with bolt icon comes in the middle of the screen.
>After some 20 seconds it goes off and the LED again glows for some 2-3 seconds.
>Then the screen goes black again and then no other activity.

>Sometimes after the LED goes off, after some 40 seconds, the playbook logo appears with the boot animation. But after some 4 mins, it goes off.

When I press the power button, the following happens:
The red battery icon with the bolt comes on for  15 seconds
> then the led glows for 10 seconds
>and then after some seconds the Blackberry Playbook Boot Animation screen comes up.
>But after some 4 mins, it switches off. And after that no activiity is shown.
>Only the screen is slightly grayish. No LED glowing or anything.

I tried several stack charging methods found in the forums, but they don't seem to work.

I tried connecting to the desktop software and upgrading, but after the upgrade, an error message comes as "The desktop loader is unable to connect to the device. You may need to enter the password on the device" . But as the playbook is still dead, I can't do that.

At one time, I got the oscillating LED, i.e. the LED started slowing glowing and fading cycle. At that time I thought the charging had started and left it like that for 12 hours. But after 12 hours when i tried to switch on, the same thing happened as when i tried to swtich on earlier - the boot screen comes and the goes of.

I tried calling RIM, they first recommened the stact charging and then the software upgrade. Afterwards as both didn't work, they told to take to the nearest service center.

But I have a problem. The serial number on the playbook doesn't match the serial number on the box and the bill. The packet was unopened when I bought it. So I'm doubtful whether i'll get warranty.

Please use plain text.