Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
Contributor
Posts: 13
Registered: ‎05-23-2012
My Device: playbook tablet
My Carrier: public

Playbook will not boot even after charging

Hi All,

I have this problem for nearly a week and can not resolve.  I think this is a MAJOR ISSUE of playbook since there are a lot of complains here but NO VALID SOLUTION is offered.  I consulted all the related posts here and tried every possible solutions but nothing works.  

My Playbook can be charged until LED indicator showed a soilid GREEN.  According to Playbook manual this indicates that the battery charging process is done.  However, I can not boot up my Playbook.  When I press POWER button , LED indicator shows a red light for 4 seconds then it goes off.  LED indicator then goes dead and nothing start.

THIS IS A MAJOR PROBLEM OF PLAYBOOK.  

My question now for everybody is:

Does anyone have this problem fixed ?

Is it worth it to pay more money to get support from RIM to fix this problem ? (because if this problem can not be fixed then I will stop using my Playbook and look for an Android tablet available on the market. If this problem can be fixed, I will give another shot...)  

 

 

Forums Veteran I
Posts: 2,359
Registered: ‎04-19-2011
My Device: Z10 & Playbook
My Carrier: Verizon Wireless

Re: Playbook will not boot even after charging

Hold the power + and - buttons at the same time for 15 to 20 seconds till it restarts. Report back your results.
Be a Shepard and not an iSheep.
Contributor
Posts: 13
Registered: ‎05-23-2012
My Device: playbook tablet
My Carrier: public

Re: Playbook will not boot even after charging

Hi,

Thanks for your quick reply.

I tried pressing Power and + and - simutaneously but nothing works.  I got several of my friends involved (some help pressing down buttons, etc)

Here is some more observations:

1/Sometimes the LED shows a red light for 10 seconds and everything goes dead (nomre LED)

2/Sometimes while pressing 3 buttons (Power and + and -)  I heard a sound similar to the sound when you press the button capture of a digital camera but not as loud.

 

Anymore idea ?

I think this a a MAJOR PROBLEM OF PLAYBOOK . RIM MUST HAVE REGCONIZED THE PROBLEM BY NOEW

 

Forums Veteran I
Posts: 2,359
Registered: ‎04-19-2011
My Device: Z10 & Playbook
My Carrier: Verizon Wireless

Re: Playbook will not boot even after charging

Try contacting support.
Be a Shepard and not an iSheep.
Contributor
Posts: 38
Registered: ‎05-26-2012
My Device: 9700 6.0

Re: Playbook will not boot even after charging


playbook2012 ha escrito:

Hi,

Thanks for your quick reply.

I tried pressing Power and + and - simutaneously but nothing works.  I got several of my friends involved (some help pressing down buttons, etc)

Here is some more observations:

1/Sometimes the LED shows a red light for 10 seconds and everything goes dead (nomre LED)

2/Sometimes while pressing 3 buttons (Power and + and -)  I heard a sound similar to the sound when you press the button capture of a digital camera but not as loud.

 

Anymore idea ?

I think this a a MAJOR PROBLEM OF PLAYBOOK . RIM MUST HAVE REGCONIZED THE PROBLEM BY NOEW

 



Hi,

 

RIM knows about this.

 

Please, can you tell me what OS version do you have so I can pass it along to them? It's important. 

 

One last thing please, have you tried holding down the power button 10 secs while charging the PB?

 

Thanks

New Member
Posts: 1
Registered: ‎10-28-2012
My Device: PlayBook 16GB wifi
My Carrier: vodafone spain

Re: Playbook will not boot even after charging

tried holding as you say + and - bottons at same time as power for 15secs, and then wait 1 mn, and restart pressing the power button, maintaining it for a loooong time, nothing occurs....

 

what can I do??