Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
New Contributor
Altagd
Posts: 3
Registered: ‎09-08-2012
My Device: Playbook
My Carrier: Telus

Playbook will not turn on...

Can anyone offer some advice? I've had the Playbook (PB) since the spring, and it worked flawlessly until a few weeks ago. I use a desktop charger from BB for the PB, and usually left it on when re-charging. Noticed that it shut itself off, and I was able to turn it on with no problems. This happened a few more times, and then it wouldn’t turn on at all, and did not indicate it was charging. Tried using the USB method, and it still would not turn on. Left it in the charging stand for days on end and the same with the USB method with no results or indication it was charging. When putting it on the charge stand there is no indication of charging. When plugging into the USB, a red light comes on for about 15 seconds, followed by 5 blinks of the white/green light. The PC indicates a connection when the red light comes on, and a disconnection when the red light goes off and the 5 blinking lights start. Tried the 20 second reset using on/odd and +/- keys, and still nothing

 

Any idea as to the problem and a fix, or is this going to have to go back to RIM?

 

Thanks!!

Please use plain text.
Guru I
John_Clark
Posts: 15,010
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Playbook will not turn on...

Do you have the charger that is meant for the Playbook? The BlackBerry chargers do not have enough current to charge the Playbook properly. The instructions even say not to use any other chargers with the Playbook.
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
New Member
yongnwang
Posts: 3
Registered: ‎09-08-2012
My Device: playbook 32g
My Carrier: no

Re: Playbook will not turn on...

push the power button for 30 seconds and see

Please use plain text.
Forums Veteran I
Lost_at_Sea
Posts: 1,920
Registered: ‎11-28-2011
My Device: PlayBook 64 GB & Torch 9860
My Carrier: Cogeco

Re: Playbook will not turn on...

Your battery is dead. http://www.blackberry.com/btsc/KB26708
Here is a suggestion to try. Connect the charger that came with the PlayBook and plug it into the wall. Hold down the Power Button only for 20 seconds. Leave it for 4 minutes, then unplug at the wall, wait a minute, plug it back in again, hold down the Power Button only for 20 seconds. Repeat this process about 10 times and hopefully, your PlayBook should go into a high charging rate. Leave it plugged in overnight and you should have a full charge by morning.
Please use plain text.
New Contributor
Altagd
Posts: 3
Registered: ‎09-08-2012
My Device: Playbook
My Carrier: Telus

Re: Playbook will not turn on...

Yes, it is a "Playbook Charger" - ordered it directly from RIM

Please use plain text.
New Contributor
Altagd
Posts: 3
Registered: ‎09-08-2012
My Device: Playbook
My Carrier: Telus

Re: Playbook will not turn on...

Already tried that method several times. Even tried holding for up to a minute with variations of pressing all three buttons.
Please use plain text.
Guru I
John_Clark
Posts: 15,010
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Playbook will not turn on...

Did you read through this KB?

 

http://www.blackberry.com/btsc/KB27705

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.