Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® PlayBook™

Reply
Contributor
tonyArmitage
Posts: 33
Registered: ‎10-05-2012
My Device: Playbook Tablet (32Gb)

Problems connecting to router since upgrading to the latest os(2.1.0.1032)

[ Edited ]

I recently upgraded to the latest os and since I have I am finding it difficult to get a stable wifi connection for anything more than a few minutes. Previously the tablet would stay connected for days without problem. Now I am lucky if it lasts half an hour. Anyone else noticing the same effect? 

 

I am also having intermittent connection problems in the mail client to yahoo where none existed before.

Forums Advisor I
chaosdivine
Posts: 511
Registered: ‎09-16-2012
My Device: BB PlayBook (32 GB Wi-Fi OS 2.1.0.1314) and Torch 9810 (OS 7.1.0.746)

Re: Problems connecting to router since upgrading to the latest os(2.1.0.1032)

[ Edited ]

I had this in 2.0.1.358 update.

 

I fixed it for myself though and haven't had a problem since. Read the thread here I post to with screenshots and see if your settings are similar. I had to change something on the routher called Channel Width from 20/40 Mhz to 20 Mhz. 40Mhz would not work either but only 20 Mhz. Once this setting was changed, my router worked fine not only for the PlayBook but all other networked devices....computers, cellphone, everthing. It was only the PlayBook that had problems. I don't believe the wireless chip very good in the PlayBook and perhaps only has a Draft specification which doesn't jibe well with standard router configurations. I don't know for sure if this is the case but what I do know that it's not a very good wireless radio in the PlayBook.

 

http://supportforums.blackberry.com/t5/BlackBerry-PlayBook/WLAN-Problem-since-2-0-1-358/m-p/1914499#...

 

Though all routers are different, try to match my specs as best you can. I got my PlayBook to go from G speeds to N speeds reliably without affecting my other networked devices.

Contributor
tonyArmitage
Posts: 33
Registered: ‎10-05-2012
My Device: Playbook Tablet (32Gb)

Re: Problems connecting to router since upgrading to the latest os(2.1.0.1032)

[ Edited ]

Sadly I am using a BT HomeHub3 and there doesnt appear to be an option to make the changes you suggest. I spoke to Blackberry Support when it first started happening and they suggested trying different channel and protocol definitions (b/g/n) combinations. I have now changed it to use Channel 9 with b/g and the jury is out.

 

I find it really frustrating that the one place I want to use the tablet(home) gives me the most grief.   The Playbook is the ONLY device that I have to fiddle with the router for. I have PS3's, Android and iPhones, iPad,. Netbook/Laptop.. all work fine .... what DID Blackberry do with this tablet? Its a real shame as its a great product in all other ways.

Forums Advisor I
chaosdivine
Posts: 511
Registered: ‎09-16-2012
My Device: BB PlayBook (32 GB Wi-Fi OS 2.1.0.1314) and Torch 9810 (OS 7.1.0.746)

Re: Problems connecting to router since upgrading to the latest os(2.1.0.1032)

[ Edited ]

I agree 100% The Playbook was the only device I had to mess with also. It drove me crazy, but at least I was able to find a solution that worked satisfactorily for me. It's unfortunate that you weren't able to find a similar solution. Can you borrow a friends router or go to a friend's and try to connect there?


tonyArmitage wrote:

Sadly I am using a BT HomeHub3 and there doesnt appear to be an option to make the changes you suggest. I spoke to Blackberry Support when it first started happening and they suggested trying different channel and protocol definitions (b/g/n) combinations. I have now changed it to use Channel 9 with b/g and the jury is out.

 

I find it really frustrating that the one place I want to use the tablet(home) gives me the most grief.   The Playbook is the ONLY device that I have to fiddle with the router for. I have PS3's, Android and iPhones, iPad,. Netbook/Laptop.. all work fine .... what DID Blackberry do with this tablet? Its a real shame as its a great product in all other ways.


 

I know this may not be the answer you want to hear, but is is possible you could buy a new router with more user control? I mean, that's an option - not necessarily one that works for you, but according to Wikipedia, the BT Home Hub 3 has some security issues http://en.wikipedia.org/wiki/BT_Home_Hub

 

"It is of note that the BT Home Hub has been criticised for its security and possible privacy flaws."

 

At least you could take it back to the store if it didn't work for you.

Contributor
tonyArmitage
Posts: 33
Registered: ‎10-05-2012
My Device: Playbook Tablet (32Gb)

Re: Problems connecting to router since upgrading to the latest os(2.1.0.1032)

[ Edited ]

Thats definitely  a future option.. (I think I still have my old Linksys router somewhere!). The current combination of Channel 9 and b/g seems to be holding up well (so far).. we'll see!

Thanks for your help.

 

Oh yes - re security - BT have disabled the WPS option for logging in.

Forums Veteran I
jarviser
Posts: 1,625
Registered: ‎02-28-2012
My Device: Two PB's

Re: Problems connecting to router since upgrading to the latest os(2.1.0.1032)

[ Edited ]

From what I remember of the Hub V2 (never having owned a V3) it was by default on WPA+WPA2 and I used to advise everyone with connection problems to downgrade to WPA or WPA2 but not mixed encryption.  The Playbook is certified in its 802.11n licence for WPA2 (AES).  BT were one of the first to sell routers with encryption already set in factory settings, but in my opinion for the V2 and V3 they chose a very strong mixed encryption that tended to give problems with the old Xboxes etc. 

The channel you use should not make much difference but the higer channels tend in BT hubs to be stronger signals. If you can download INSSIDER you can see who is using which channels around you and pick one which is not being used.

 

 

_________________________
Contributor
tonyArmitage
Posts: 33
Registered: ‎10-05-2012
My Device: Playbook Tablet (32Gb)

Re: Problems connecting to router since upgrading to the latest os(2.1.0.1032)

Channel 9 and no N support seems to have made the connection more stable. I dont understand why the tablet has so many issues connecting, none of my other devices have a problem at all .. ahh well. Where can I download INSSIDER please?

Forums Veteran I
jarviser
Posts: 1,625
Registered: ‎02-28-2012
My Device: Two PB's

Re: Problems connecting to router since upgrading to the latest os(2.1.0.1032)

It's why Google was invented.

 

http://www.metageek.net/products/inssider/

_________________________
Contributor
tonyArmitage
Posts: 33
Registered: ‎10-05-2012
My Device: Playbook Tablet (32Gb)

Re: Problems connecting to router since upgrading to the latest os(2.1.0.1032)

Thanks for that (yeh I know.. but sometimes quicker to go direct!)

New Member
dacswells
Posts: 1
Registered: ‎10-10-2012
My Device: Playbook

Re: Problems connecting to router since upgrading to the latest os(2.1.0.1032)

Interested to see this thread as my wife is having the same problem with her playbook (16gb). She does not seem to be able to send attachments on her email as when she presses the send button the server connection seems to drop. The problem has only been occuring since the update.

 

To complicate things I also have a playbook and have had no problems and we do use a BT v3 Hub.