Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
Administrator
MSohm
Posts: 14,444
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Browser Channel Push

I tried multiple versions of BlackBerry Enterprise Server and wasn't able to reproduce this issue.

 

Can you try the browserpushdemo and let me know if it exhibits the same behaviour in your environment?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Developer
kwichman
Posts: 11
Registered: ‎12-30-2009
My Device: Storm 2
My Carrier: T-Mobile

Re: Browser Channel Push

Did you really test with turning off your wireless connection before rebooting the device ?

We have now tested the same scenario in another BlackBerry customers environment and noticed the same behavior.

 

We noticed that there is also a different behavior when content protection is turned on on the device (which in our case is turned on).

 

We tried to download the JDE from the link you mentioned. Unfortunately it is no longer available there. Only the eclipse plugin can be downloaded.

Please use plain text.
Administrator
MSohm
Posts: 14,444
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Browser Channel Push

Content protection seems to be the key here.  Once I enabled that I was able to reproduce this using BlackBerry device software version 4.6.0.

 

However, I did find that it worked correctly when I used version 5.0.  What is the full, 4 digit 5.0 version of BlackBerry device software that you were able to reproduce this on?

 

There are a couple of work arounds you can use.  The obvious one is to disable content protection.

 

Alternatively you could create a Java application that launches the browser to your channel page.  You could then push this application out to users from the BlackBerry Enterprise Server.  The following link explains how to do this.

 

How To - Create a web icon

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800332/800440/How_To_...

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Developer
kwichman
Posts: 11
Registered: ‎12-30-2009
My Device: Storm 2
My Carrier: T-Mobile

Re: Browser Channel Push

We opened a ticket with RIM now, but the replys are very frustrating.

 

So we try here again:

Actually we can reproduce the issue with all devices regardless of the OS.

The OS 5 version you are asking for is version v5.0.0.497 (plattform 4.2.0.220) on a BlackBerry Storm 2.

 

- Turning off content protection is not an option for us !

- Using a Java app is an option. But we should we do this ? Actually we expect the browser channel push to be working

- Upgrading devices to OS5 is alos no option. And actually we find the same bug there.

 

If you reproduce the issue, do not forget to turn of the radio before you restart the device. After reboot you will see that all Channel Push icons are missing on the device or are replaced by default icons. Only when turning on the radio again, they are reloaded from the backend, if they are still available there. This should be very easy to reproduce !

 

 

Please use plain text.