Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
Developer
Posts: 19
Registered: ‎07-02-2013
My Device: BlackBerry Q10
My Carrier: Telus

Keep getting a "Host not found" error with production push url

Hi,

 

While testing with the BlackBerry eval URL "http://cp4145.pushapi.eval.blackberry.com", using the SimplePushServer [https://github.com/blackberry/Cascades-Community-Samples/tree/master/SimplePushServer] I was able successfully send and receive push messages.

 

However after BlackBerry sent me the production URL: https://cp1171.pushapi.na.blackberry.com

 

I am now continually getting a Host not found error:

 

<bpds version="1.0">
<subscriptionquery-message pushservice-id="1171-9014r27221trt37r2o430150l5a1es42l44">
<status status-value="active"/>
</subscriptionquery-message>
</bpds>"

"Failed to receive PINs:
Host not found"

 

This is on a BIS service. Any help would be appreciated.

Developer
Posts: 108
Registered: ‎04-14-2013
My Device: BlackBerry Z30
My Carrier: Chunghwa Telecom

Re: Keep getting a "Host not found" error with production push url

Hello, did you fix the problem?

 

I have the same problem here..

"https://cp1221.pushapi.na.blackberry.com"

always get Host Not Found..

 

 

Anyone can help here?

 

Thanks

 

 

BlackBerry Certified Cascades Developer
Retired
Posts: 856
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Keep getting a "Host not found" error with production push url

Were you able to access it previously, or has it never worked for you?

 

Have you been able to push to the EVAL servers?

Tim Windsor
Open Source Technical Lead
Developer
Posts: 108
Registered: ‎04-14-2013
My Device: BlackBerry Z30
My Carrier: Chunghwa Telecom

Re: Keep getting a "Host not found" error with production push url

Hello Tim

 

Yes, I use the evaluation push service before, and it worked great.

 

After the service expried on last September, I applying the production BlackBerry Push Essential few days ago.

 

I use the sample called "SimplePushServer" and "SimplePushClient" on the BlackBerry Community Github
 
And even thought I can register the push channel in SimplePushClient, I still can't get the pin list from SimplePushServer sample. 
Always return Host Not Found error...
 
Please help me, thanks
 
Simon
BlackBerry Certified Cascades Developer
Highlighted
Retired
Posts: 856
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Keep getting a "Host not found" error with production push url

Okay,

 

Can you try a registration again with the client, and then a request on the server, and note your local time when you are doing so. Then send the following information to me in an email (twindsor@blackberry.com):

 

  • Time of the attempts, with timezone offset
  • PIN of the device
  • Application ID used
  • URL of the push service used
  • Do you have a SIM card?

We will have a lot of logs to go through, but the team should be able to find out what is happening from that.

 

Thanks

Tim Windsor
Open Source Technical Lead
Visitor
Posts: 1
Registered: ‎04-03-2015
My Device: Z10
My Carrier: Rogers

Re: Keep getting a "Host not found" error with production push url

Hello, we have similar "Host not found" issue with

cp1303.pushapi.na.blackberry.com

The evel certificate worked well

Retired
Posts: 162
Registered: ‎10-11-2011
My Device: BlackBerry 9810
My Carrier: Rogers

Re: Keep getting a "Host not found" error with production push url

Hi There,

 

Please be aware that when you change the URL, the client application needs to be registered with the PPG again with the production App ID, production URL and Invoke Target ID.  Also, the push initiator needs to be updated as well.

 

When are you seeing this error?  Do you see this error when you try to POST?

 

Thanks

 

Naveen M