Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Push Messages Not Delivered Anymore.. However setup seems okay.. It worked before.

"After reloading, works for first push then starts failing. Problem not solved." <-- this line is confusing the situation as it has noting to do with pushes, pushes not being received is a symptom of the issue.


The original application seems to leave a thread or something on the device which causes the exception when the new app is loaded overtop. I would suggest removing the app manually and possibly rebooting before trying to load the app again. Another suggestion would be to add a manual call in the app to stop the listening thread before loading the new version.
Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.
New Developer
Posts: 35
Registered: ‎07-11-2009
My Device: Not Specified

Re: Push Messages Not Delivered Anymore.. However setup seems okay.. It worked before.

I stated I've already removed, rebooted and reloaded the app. NullPointerException thrown.

 

Doesn't work. With and without debugger. Rebooting. Reloading. RIM supplied demo simply does NOT work.

 

 

Can you please propose a more detailed test procedure in order to avoid any misunderstanding? I will follow your instructions carefully.

 

 

Please use plain text.
New Developer
Posts: 35
Registered: ‎07-11-2009
My Device: Not Specified

Re: Push Messages Not Delivered Anymore.. However setup seems okay.. It worked before.

Repeated test with same result:

 

- Removed app

- Rebooted

- Set a breakpoint at JVM as recommended by forum user crispyoz

- Registered successfully

- Sent a push: NullPointerException

- Breakpoint not reached even configured with JVM option

 

I'm about to test again, after BB Plugin for Eclipse starts working because it crashed after this test (had to kill process) and doesn't load anymore. Can you now understand why the devs *sometimes* are right?

 

If you could explain a bit what are you looking for, or propose a more formal test procedure, I could fine tune my debugging.

 

I've already done everything you proposed. If you think that's not the case, please point out what I'm missing.

 

If you find I'm requesting too much, please accept my apologies and let me know who should I contact in order to fix this. Free or paid, I just need to deliver to my customer.

 

 

L.

 

Please use plain text.
New Developer
Posts: 35
Registered: ‎07-11-2009
My Device: Not Specified

Re: Push Messages Not Delivered Anymore.. However setup seems okay.. It worked before.

Different results this time. Breakpoints appears to be working now.

 

@ PushMessageReader.java: process()

 

String encoding = httpConn.getEncoding();

 

encoding is always null ... is that normal? tested both DebugPortal push initiation and custom script.

 

Wishing to catch the exact line which throws the exception, could not step over this line at PushController.java

Logger.log( "Text message pushed, size " + size + " bytes" );

 

Debugger lost track.  Exception thrown (shown at log)

 

Is this meaningful to you? what's next?

 

I'm willing to help.

 

Please use plain text.
New Developer
Posts: 35
Registered: ‎07-11-2009
My Device: Not Specified

Re: Push Messages Not Delivered Anymore.. However setup seems okay.. It worked before.

Any news on this topic?

 

Additional testing?

 

 

Thanks.

 

Please use plain text.
New Developer
Posts: 35
Registered: ‎07-11-2009
My Device: Not Specified

Re: Push Messages Not Delivered Anymore.. However setup seems okay.. It worked before.

Please use plain text.
Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Push Messages Not Delivered Anymore.. However setup seems okay.. It worked before.

Hi Luciano,

 

This post is not relevant to this issue, the user is trying to send a Browser Message push while you are sending a Data push, the two are handled completely differently.

 

With regards to your testing, you mentioned earlier that reloading worked to fix the issue the first time the app was run:

http://supportforums.blackberry.com/t5/BlackBerry-Push-Development/Push-Messages-Not-Delivered-Anymo...

 

Now the same steps aren't working? Are you doing anything differently?

 

 

Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.
New Developer
Posts: 35
Registered: ‎07-11-2009
My Device: Not Specified

Re: Push Messages Not Delivered Anymore.. However setup seems okay.. It worked before.

Hi.

 

Push API 5.0+ has been working automagically fine from Saturday. Same app code based on demo, with development credentials. No conclusions on my side.

 

Let's wait for some more days before marking this as solved.


Halted 4.3 testing.

 

 

Thanks for support

Luciano

 

Please use plain text.
New Developer
Posts: 35
Registered: ‎07-11-2009
My Device: Not Specified

Re: Push Messages Not Delivered Anymore.. However setup seems okay.. It worked before.

Here are my findings I would like to share them with other devs.

 

So far the Push API has been working reliably starting a week ago.

 

I think the problem I've experienced it's not really a bug, but a mix of poor documentation and RIM design choices.

 

There's at least one scenario which causes problems. It turns out that scenario is a really typical one for developers, likely to exist when you start testing your first push enabled app.

 

1. If you install the app on a device which didn't have the app previously installed it works fine

2. If you manually remove the app and reinstall, it works fine

3. If you overwrite the app for debugging purposes without resetting the device, then problems start

 

It seems some kind of resource keeps open between app reloads (port?) . It would have saved me lots of hours if I simply got and exception like "Push API can't open port...", or a big red warning at the beginning of the Push API PDF  "YOU MUST RESET YOUR DEVICE BETWEEN APP RELOADS WHEN TESTING" .

 

Hope it helps.

 

Please use plain text.