Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
New Member
ricardo_chavez_t
Posts: 1
Registered: ‎04-28-2012
My Device: Developer
My Carrier: Developer

Push notifications not arriving on the device

Hello everyone

 

I've been experiencing issues with push notifications since some days ago. The device seems to register OK for push notifications, but they never arrive.

 

We've recently obtained credentials for using the BB production push service, complete with a brand new app id and password for our push initiator and a push port (the same as in the evaluation version). I use these in my push enabled app, and when I try to register via the sample app that comes with the Push SDK, everything seems OK: I get a "rc=200l" response and a "Registered successfully for BIS push" message in the console (when running in Debug mode), and the device is listed in the Debug Portal. However, when I try to send a push notification with "push_all", I get a message saying "No Active Subscribers for the Push Service". If I use the subscriber id of the device, everything seems OK (I get the message "The request has been accepted for processing"), but notifications still do not arrive on the device.

 

I've even resorted to using the sample push client, with the following settings:

 

  • Port: (Push Port provided by RIM via e-mail, in the section "Configuration properties for the push-enabled application (client application)")
  • App ID: (Application ID provided by RIM via e-mail)
  • BPAS URL: http://pushapi.na.blackberry.com (the PPG Base URL provided in the e-mail from RIM)
  • Content Provider URL: http://<our-server-address>/sample-app
    (we've installed the sample app from the Push SDK on one of our servers, along with the Debug Portal)
  • App Acknowledgement: unchecked (we're using Push Essentials)

But to no avail: the sample push client registers successfully (or at least that's what it says), but notifications never arrive.

 

The strangest thing is that, a few days ago, push notifications were working without problems on our test device (a BlackBerry 8520 with version 5.0.0.1036 of the platform). We requested production credentials a few days ago and noticed that notifications stopped working, so we assumed our evaluation credentials were no longer valid; however, today we received our new production credentials and tried using them without success.

 

Any pointers on how to solve this would be greatly appreciated.

If there's any additional information missing, let me know.

 

Thank you very much in advance.

Please use plain text.
New Contributor
hasanizer
Posts: 6
Registered: ‎05-09-2012
My Device: 9360
My Carrier: XL

Re: Push notifications not arriving on the device

Same as me... please somebody solve this problem :smileysad:
Please use plain text.
New Contributor
hasanizer
Posts: 6
Registered: ‎05-09-2012
My Device: 9360
My Carrier: XL

Re: Push notifications not arriving on the device

i've experienced after reinstall the application. But its ok when i use brand new credential.
Please use plain text.
New Contributor
anoop_gpr
Posts: 3
Registered: ‎06-11-2012
My Device: Blackberry Curve 9380
My Carrier: Airtel India

Re: Push notifications not arriving on the device

I faced same issue and i am able to resolve this by registering device with content provider and Blackberry push server both

Please use plain text.
New Contributor
hasanizer
Posts: 6
Registered: ‎05-09-2012
My Device: 9360
My Carrier: XL

Re: Push notifications not arriving on the device

i solve my issue. the root of the problem is when i reinstall, the persistent storage is still exist and the port push cleared.

Please use plain text.
New Member
emsieja
Posts: 1
Registered: ‎06-12-2012
My Device: 9810
My Carrier: ATT

Re: Push notifications not arriving on the device

I am seeing the exact same thing. Our 3rd party push provider said this:

 

---------------------

I have checked the logs and it looks like BB server replies that everything is ok. When I try invalid password or ID - it replies that they are not valid. When I enter link, ID, port, password as specified - BB server says - it's all ok and the push has been accepted. However I cannot receive the notification on my BB here either. Eval push link used to work properly.

 

I have googled the problem and found that there are quite a few people complaining about the same issue: Dev pushes works fine, but production does not. The solution so far is to contact BB push support. It looks like most of the similar problems were fixed this way.

---------------------

 

So we have a nation-wide police customer that is treatening to drop our product deployment if this is not resolved in one day. I know I can resort back to the eval server (after 1:00 EST today) but that seems counterproductive.

 

Any help appreciated!

 

-- Ed

Please use plain text.
New Developer
rincethomas33
Posts: 39
Registered: ‎12-31-2010
My Device: 9800
My Carrier: Airtel

Re: Push notifications not arriving on the device

anyone have the solution for this ?

R33
Please use plain text.
New Developer
rincethomas33
Posts: 39
Registered: ‎12-31-2010
My Device: 9800
My Carrier: Airtel

Re: Push notifications not arriving on the device

you find any solution ?

R33
Please use plain text.
New Contributor
hasanizer
Posts: 6
Registered: ‎05-09-2012
My Device: 9360
My Carrier: XL

Re: Push notifications not arriving on the device

1) follow every instructions step by step carefully

2) try eval configuration

3) if success request production configuration and then change every param that changed from eval to production. don't forget to uninstall and reboot apps on device.

Please use plain text.
New Developer
rincethomas33
Posts: 39
Registered: ‎12-31-2010
My Device: 9800
My Carrier: Airtel

Re: Push notifications not arriving on the device

i tried that , but no use.
R33
Please use plain text.