Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
Developer
mikbry
Posts: 17
Registered: ‎01-22-2010
My Device: Bold

Receiving Push on BB10 dev alpha

my BB10 app register correctly to push eval server. The server received a ACK for sent pushes. But the device doesn't received any push. On prior OSes i used a BIS mobile data plan to received pushes. But on alphaDev I only have Wifi as the SIM slot is broken. Should i need a mobile network to get pushes as previously? The doc isn't clear regarding requirements:

BlackBerry device

  • BlackBerry 10 OS
  • BlackBerry Internet Service
  • Data plan with your wireless service provider that provides a connection to the Wi-Fi network and mobile network

Thanks

 

Mik

Retired
mdandrea
Posts: 311
Registered: ‎08-08-2012
My Device: BlackBerry Z10

Re: Receiving Push on BB10 dev alpha

Hi Mik,

 

What development platform are you using to develop exactly?  Cascades, WebWorks, or AIR?

Also, are you using your own app to try to receive pushes or one of our samples that we provide?

 

You should be able to receive pushes just over Wi-Fi (without a SIM).

 

Thanks,

 

Matt

Developer
mikbry
Posts: 17
Registered: ‎01-22-2010
My Device: Bold

Re: Receiving Push on BB10 dev alpha

Thanks for your quick reply. Our app uses Cascades and I test with sample app also. But the server is custom. I checked also the logs. All seem ok. The last message i got from registration in slog2:

 

Jan 09 10:37:01.995 com.xxx default 9000 INFO sendMessage: raw payload [ "dat:json:{"dName":"com.xxx","perimeter":1,"providerApplicationId":"xxx","targetKey":"com.xxx.invoke.push"}
id::registerToLaunch_17646
msg::registerToLaunch
" ]
Jan 09 10:37:01.996 com.xxx default 9000 INFO sendMessage: write to pps: success
Jan 09 10:37:02.002 com.xxx default 9000 INFO receive message: @ipc
msg:: onRegisterToLaunchComplete
id::registerToLaunch_17646
Jan 09 10:37:02.002 com.xxx default 9000 INFO err is 0
Jan 09 10:37:02.002 com.xxx default 9000 INFO No dat section

 

Also I tested to remove app/ unregister/reboot phone.

 

Mik

Retired
mdandrea
Posts: 311
Registered: ‎08-08-2012
My Device: BlackBerry Z10

Re: Receiving Push on BB10 dev alpha

Hi Mik,

 

A couple more questions for you.

 

From the slog2, do you see a successful createChannel?

 

Also, you mentioned getting back an acknowledgement after sending the push.  Are you using result notification or are you just referring to the response you get back after sending the push?  The response after sending a push will typically give back a status of 1001 (i.e. the push was accepted for processing), but that doesn't actually mean the push arrived at the device.

 

Thanks,

 

Matt

Developer
mikbry
Posts: 17
Registered: ‎01-22-2010
My Device: Bold

Re: Receiving Push on BB10 dev alpha

For the createChannel slog2 give me:

Jan 09 15:57:14.316 com.xxx default 9000 INFO sendMessage: raw payload [ "dat:json:{"dName":"com.xxx","perimeter":1,"ppgUrl":"http://cpxxx.pushapi.eval.blackberry.com/","providerApplicationId":"xxx","targetKey":"com.xxx.invoke.push"}
id::createChannel_13562
msg::createChannel
" ]
Jan 09 15:57:14.322 com.xxx default 9000 INFO sendMessage: write to pps: success
Jan 09 15:57:14.803 com.xxx default 0 INFO InputOptionsEventHandler::smileyfrustrated:pellCheck enabled changed to true
Jan 09 15:57:14.803 com.xxx default 0 ERROR PPSEventHandler::Failed to read PPS object
Jan 09 15:57:14.804 com.xxx default 0 ERROR PPSEventHandler::Failed to read PPS object
Jan 09 15:57:14.804 com.xxx default 0 ERROR PPSEventHandler::Failed to read PPS object
Jan 09 15:57:14.804 com.xxx default 0 ERROR PPSEventHandler::Failed to read PPS object
Jan 09 15:57:14.805 com.xxx default 0 ERROR PPSEventHandler::Failed to read PPS object
Jan 09 15:57:15.606 com.xxx default 0 INFO NavigatorEventHandler::Received - BPS - NAVIGATOR_WINDOW_ACTIVE
Jan 09 15:57:17.697 com.xxx default 9000 INFO receive message: @ipc
msg::smileysurprised:nCreateChannelComplete
id::createChannel_13562
dat:json:{"token":"xxx"}
Jan 09 15:57:17.697 com.xxx default 9000 INFO err is 0
Jan 09 15:57:17.697 com.xxx default 9000 INFO found dat

 

Retired
mdandrea
Posts: 311
Registered: ‎08-08-2012
My Device: BlackBerry Z10

Re: Receiving Push on BB10 dev alpha

The createChannel call looks good.

 

When did you send the push though?  Was it after Jan 09 15:57 (when the create channel was done)?

 

You don't see anything in the slog2 about an incoming push?

 

Thanks,

 

Matt

Developer
mikbry
Posts: 17
Registered: ‎01-22-2010
My Device: Bold

Re: Receiving Push on BB10 dev alpha

For incoming pushes we tested several after correct registration. Nothing in the slog2 even after a long time.

Retired
mdandrea
Posts: 311
Registered: ‎08-08-2012
My Device: BlackBerry Z10

Re: Receiving Push on BB10 dev alpha

It sounds like the push is not even reaching the device.  What kind of service level do you have for your push account?  Is it Push Plus or Push Essentials?  

Developer
mikbry
Posts: 17
Registered: ‎01-22-2010
My Device: Bold

Re: Receiving Push on BB10 dev alpha

Push essential

Retired
mdandrea
Posts: 311
Registered: ‎08-08-2012
My Device: BlackBerry Z10

Re: Receiving Push on BB10 dev alpha

You're using eval (not production), right?  Send me a private message with details of your push:

- push application ID

- time

- push ID

when you get a chance and I'll try to see what happened to the push.