Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
New Developer
CharlesZA
Posts: 28
Registered: ‎03-04-2009
My Device: Bold 9700

Response 503

Hi there.

 

First time trying to get Push Notification working. It is proving to be alot of work.

 

Im getting response 503 from the server. Does this mean the server is down or just busy? How long should I wait before trying again?

 

Those of you that got the push notification working, how reliable is it?

 

Thanks

 

 

Please use plain text.
New Developer
CharlesZA
Posts: 28
Registered: ‎03-04-2009
My Device: Bold 9700

Re: Response 503

Here is some of my code. The first request gets response 200 but the second one says "Connection closed by Peer" If I use http I get response 503. Any help? The formRegisterRequest is the sample code from this site.

 

String registerUrl = formRegisterRequest( "https://pushapi.eval.blackberry.com",
"xxxxxxxxxxxx-app-id", null ) + ";deviceside=false;xxxxxxxxlic";

HttpConnection httpConnection = (HttpConnection) Connector.open(registerUrl);
Log("httpConnection responseCode: " + httpConnection.getResponseCode());
InputStream is = httpConnection.openInputStream();
String response = new String(IOUtilities.streamToBytes(is));
close(httpConnection, is, null);

String nextUrl = formRegisterRequest( "https://pushapi.eval.blackberry.com",
"xxxxxxxx-app-id", response ) + "xxxxxxxxlic";

HttpConnection nextHttpConnection = (HttpConnection) Connector.open(nextUrl);
Log("nextHttpConnection responseCode: " + nextHttpConnection.getResponseCode());
InputStream nextInputStream = nextHttpConnection.openInputStream();
response = new String(IOUtilities.streamToBytes(nextInputStream));
close(nextHttpConnection, is, null);

Please use plain text.
Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Response 503

From the client side you should only use HTTP to connect to the BlackBerry infrastructure.

 

I am investigating some other Push related issues in Africa and will let you know what I find, seems to be a trend at the moment so I do not suspect an issue with your application.

Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.
New Developer
CharlesZA
Posts: 28
Registered: ‎03-04-2009
My Device: Bold 9700

Re: Response 503

Thanks for the reply. Any idea how long this has been going on for and is this a regular occurance? I need to present to our client soon and they will undoubtably ask these questions.

Please use plain text.
Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Response 503

The first report I received was about a month ago but at the time it was unclear that this may be a geographically related problem:

http://pushapi.eval.blackberry.com/mss/PD_subReg?serviceid=3174-908c33er4631tt8oo07897M58h29l142e92&...

 

Typically this should not occur but it seems there is some issue which needs investigating to determine why this started happening.

Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.
New Developer
CharlesZA
Posts: 28
Registered: ‎03-04-2009
My Device: Bold 9700

Re: Response 503

Any idea how long before we will have an answer?

Please use plain text.
Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Response 503

We can't predict how long it will take to fix the issue without first finding the root cause.

Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.
Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Response 503

This issue should now be resolved, please let me know if you continue to experience any issues with registering with the EVAL server.

Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.