Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Push Development

Reply
Regular Contributor
galeb
Posts: 77
Registered: ‎11-03-2009
My Device: 9810 Torch

Re: Urban Airship and BlackBerry integration - not receving push notifications (both Native and Java)

I'm using the same for the data in the PUSH application that is having this problem.

Could that be a cause of the problem?

Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Urban Airship and BlackBerry integration - not receving push notifications (both Native and Java)


galeb wrote:

I'm using the same for the data in the PUSH application that is having this problem.

Could that be a cause of the problem?


Nope. The server app requires this to be added because it needs to append more to the URL.

Garett
@garettBeuk
--
Goodbye everybody!
Regular Contributor
galeb
Posts: 77
Registered: ‎11-03-2009
My Device: 9810 Torch

Re: Urban Airship and BlackBerry integration - not receving push notifications (both Native and Java)

now is different error:

Host requires authentication

 

I entered the push id and the password.

Regular Contributor
galeb
Posts: 77
Registered: ‎11-03-2009
My Device: 9810 Torch

Re: Urban Airship and BlackBerry integration - not receving push notifications (both Native and Java)

could I be missing the / sign on the UA server side?
Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Urban Airship and BlackBerry integration - not receving push notifications (both Native and Java)

 

galeb wrote:
could I be missing the / sign on the UA server side?


It's possible, but I would expect UA to provide errors in the log that stated authentication problems.

Garett
@garettBeuk
--
Goodbye everybody!
Regular Contributor
galeb
Posts: 77
Registered: ‎11-03-2009
My Device: 9810 Torch

Re: Urban Airship and BlackBerry integration - not receving push notifications (both Native and Java)

I was missing the forward slash on the UA side (added it),

but still not a single message received.

 

Also, the push server client seems not to be working (host requores authentication error).

 

Any ideas what to try to get it to work?

Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Urban Airship and BlackBerry integration - not receving push notifications (both Native and Java)

For the UA side, check the logs.

 

Cascades client, that means the credentials being used are incorrect. If you're using the same credentials in UA then that would explain the problem.

Garett
@garettBeuk
--
Goodbye everybody!
Regular Contributor
galeb
Posts: 77
Registered: ‎11-03-2009
My Device: 9810 Torch

Re: Urban Airship and BlackBerry integration - not receving push notifications (both Native and Java)

Hi!

 

It seems there are some problems with my testing account.

I took different credentials for BlackBerry push service (one for the new project, not my own anymore), and the communication by Simple Push Server seems to be working fine.

 

I received PINS registered, and I was able to send push messages to the one I have at my hand,.

 

However, there are no messages received through the UA infrastructure - but with no errors in the error log.

 

So, to conculde so far, it seems that BlackBerry push channel towards the application is working properly.

There are no errors in the error log.

 

What am I missing?

Regular Contributor
galeb
Posts: 77
Registered: ‎11-03-2009
My Device: 9810 Torch

Re: Urban Airship and BlackBerry integration - not receving push notifications (both Native and Java)

[ Edited ]

I underwent more investigation, and did the following:

 

I unregistered one device with UA, and tried to send push from there.

UA gave me immediate error response that the device is not active, and cannot send a push message to it.

 

I registered the device again.

Tried sending another message, it has not been received.

 

Next, I put in the password field a wrong password.

I tried to send a push message, and error message was NOT reported by the UA infrastructure.

 

I changed the url, dropping cpid, sent the push again, and still no error in the UA console.

Instead, it reported as that 3 pushes have been sent.

 

Could it be that there is a break of communication between UA and BlackBerry servers?