Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Q5

Reply
New Member
suziemaclondon
Posts: 1
Registered: ‎03-09-2014
My Device: Q5
My Carrier: Three

Blackberry Q5 won't power on after being powered off for a flight!

My BB Q5 was purchased brand new in March 2014. Yesterday afternoon, I switched it off before taking a flight from London to Orlando, Florida (just under 9 hours).

 

On reaching my destination, I tried to switch the device back on, but it is completely unresponsive! 

 

I have charged my device for several hours but am still facing the issue. Before it was turned off, the battery power level was approx 70%.

 

I have attempted to press and hold the up and down media volume keys, for up to 30 seconds, but still nothing happens.I have tried depressing the power key for a long period, as well as short sharp presses, withno joy!

 

There are no lights coming on and nothing that indicates that the device is charging.

 

The device wasn't left anywhere especially cool or hot, it wasn't dropped and, to my knowledge, wasn't near any magnets or other electronic equipment. 

 

Totally confused.  Can anyone assist please? 

Please use plain text.
Elite II
BillJ
Posts: 8,910
Registered: ‎01-05-2009
My Device: BlackBerry Z30
My Carrier: Rogers

Re: Blackberry Q5 won't power on after being powered off for a flight!

Plug it into a wall outlet then remove the battery for a few seconds. Replace the battery and see if you get any signs of life. Whether yes or no, leave it to charge for an hour then attempt to power it back on. If nothing has changed, once again remove the battery for a few seconds and repeat and lather. You might have to repeat this process a couple of times.

 

 

Let us know if that helps you.  :smileyhappy:

 

P.S. Your BlackBerry accepts dual voltage so as long as you have an adaptor for the wall outlet, you'll be fine.


- If my response has helped you, please click "Options" beside my post and mark it as solved. Clicking the "thumbs up" icon near the bottom of my response would also be appreciated.



Please use plain text.