Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Storm™

Reply
New Contributor
Andyt23
Posts: 3
Registered: ‎11-16-2008
My Device: Not Specified

9500 Charging Problems

Hello,

 

I'm new to the BlackBerry world after recieving my new Storm on Friday.  Unfortunately I am having some trouble getting it to charge.

 

When the parcel arrived I followed the instructions in the book, inserting the sim and battery and the phone tried starting up but without much success.  So I plugged it in to the charger and left it for a good couple of hours and then thought I'd turn it on to check it was charging.  It did turn on and had about 30% power on the indicator but the indicator was not showing the small lightning bolt indicating the phone was charging so I switched the charger off at the wall, unplugged it from the phone then reconnected it and switched the wall switch back on.  The phone did then show the charging indicator so I left it on charge while I went to work.

 

After coming back from work (9 hours later) I checked the phone again and the charge indicator was gone and it appeared fully charged.  So I went through the setup wizard before going to bed and left playing with it properly until sat morn.  I woke up and checked the phone and already the battery indicator was on 75%, I didn't really think much of it as I know the battery will prob require several full charges before it gives full battery life.  I used it through the day and the battery indicator went down to about 25% (1 bar) but I couldn't get back to my charger for a couple of hours, by the time I did it was showing red and the low battery warning.  I plugged in the charger as soon as I got in but it just would not give me the charging indicator, I tried it on the usb lead to my PC and the phone connected to the desktop software no problem but still did not indicate the charging indicator.

 

I left the phone plugged in to the charger over night last night hoping it would be charging.  I woke up this morning and checked the phone again and it was on but still showing the red indicator and low battery with no charging indicator shown.

 

The phone has now shutdown completely and I have not been able to get it to take any charge.  I am thinking I may have to return it....  Does anyone have any advice on how I might be able to get it to charge please??

New Contributor
Andyt23
Posts: 3
Registered: ‎11-16-2008
My Device: Not Specified

Re: 9500 Charging Problems

Quick Update

 

To anybody with similar problems monitoring this thread.  My Storm is being returned to Vodafone tomo, I've been told by their tech guys that it's definitely broken.

Visitor
umairsario
Posts: 1
Registered: ‎03-02-2011
My Device: 9500

Re: 9500 Charging Problems

is your problem solved because am also facing the same problem

New Member
kurtdouglas
Posts: 1
Registered: ‎08-02-2011
My Device: 9500 Storm

Re: 9500 Charging Problems