Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Storm™

Reply
New Member
Posts: 1
Registered: ‎04-22-2009
My Device: Not Specified

Browser Security Settings

Storm 9530 on the Telus network.

 

Here's my problem.  As of Monday evening, I was able to use the browser to access a secure web page (the web portal to my company's email system).  I had previously accepted the server's (unknown) certificate and added it to my key store, so there was no problem opening the requested page, logging in, and viewing my email.

 

Yesterday saw a fouled up attempt to repair the Media Manager installation on my laptop that resulted in me downloading the installation package for Desktop Manager 4.7.0.32.  During this installation process, my device was somehow reset back to the factory defaults and rebooted. I ended up losing my contact and calendar information, but kept my downloaded applications.  Following that reboot, I could still access the secure web page, but after I logged in, the browser displayed script text, rather than the next window.

 

Thinking that something has been corrupted, this morning I revoked and deleted the server's certificate.  I was hoping that the browser would connect to the secure web page, detect the unknown certificate, and prompt me to accept it once again.  Instead, the browser displays the message "unable to connect using the current security settings".

 

Obviously, something has become unhinged somewhere, but I can't for the life of me figure out what setting I need to toggle/restore.  I have set the browser to mimic Internet Explorer and allow JavaScript to run.  I have also removed the battery to reboot the device. 

 

PS:  A colleague using a 8830 World Edition on Bell can access the page in question without any problem, so the issue must be with my device/network.

 

Anybody have any suggestions?

 

Thanks,

 

Robin