Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Storm™

Reply
Contributor
hgd7
Posts: 37
Registered: ‎11-19-2008
My Device: Not Specified

EMAIL: Your device had a problem connecting to the server?

I have not received an email to my blackberry for 2 days and wondered if something went wrong.

 

When I run Setup > Email settings.

 

Its starts to load up something then comes up with an error of 'Your device had a problem connecting to the server'

 

Does this just mean I'm not in a area with a connection? Any help?

Please use plain text.
AWJ
New Contributor
AWJ
Posts: 3
Registered: ‎12-04-2008
My Device: Not Specified

Re: EMAIL: Your device had a problem connecting to the server?

Mine has done exactly the same thing - emails were working fine, then nothing, and i get the same error message. I have emailed the tech support, but haven't heard back yet. I called them and they suggested a hard reset (taking out the battery, then the SIM, then put the battery back (no SIM) switch on, let it boot up, the remove the battery again, insert the SIM, turn on and the emails should come through) - but no joy for me I'm afraid...so if anyone has any ideas??
Please use plain text.
New Member
dstonks
Posts: 1
Registered: ‎12-31-2008
My Device: Not Specified

Re: EMAIL: Your device had a problem connecting to the server?

This reset worked fine for me, make sure that you shut down the device total shutdown or it will not work..
Please use plain text.
New Contributor
ZosoJade
Posts: 2
Registered: ‎01-11-2009
My Device: Not Specified

Re: EMAIL: Your device had a problem connecting to the server?

Now I've got the same problem.... I've tried the reboot thing but nothing happened.... Did any of you guys get it working again?  Quite frustrating...
Please use plain text.
AWJ
New Contributor
AWJ
Posts: 3
Registered: ‎12-04-2008
My Device: Not Specified

Re: EMAIL: Your device had a problem connecting to the server?

I did finally get it resolved - after a long time spent on the phone with the Vodafone technical support team - it transpired that my set up was not correctly configured. The clue was that the connection appeared on the handset as 'gprs' (all lower case) and not 'GPRS' (upper case).

 

This meant that I was not correctly connected - quite why or how,I don't know, as I had been picking up emails before.

 

All I do know, is that no amount of hard resets would help, and Vodafone had to change my email settings. Since then all has been fine.

 

I have selecetd the 2G option on my connections as well as I don't realyy use the internet facility, and the telephone signal seems much better.

 

Hope you can get it resolved...

 

AWJ

Please use plain text.
New Contributor
ZosoJade
Posts: 2
Registered: ‎01-11-2009
My Device: Not Specified

Re: EMAIL: Your device had a problem connecting to the server?

Thanks - I'm not sure it's my settings simply because it was working before and then suddenly stopped.  I think it's best I contact Vodafone rather than BlackBerry...
Please use plain text.
AWJ
New Contributor
AWJ
Posts: 3
Registered: ‎12-04-2008
My Device: Not Specified

Re: EMAIL: Your device had a problem connecting to the server?

I think that's best - it worked for me - but it took a while...Good Luck!
Please use plain text.
New Member
PuzPuz
Posts: 1
Registered: ‎01-15-2009
My Device: Not Specified

Re: EMAIL: Your device had a problem connecting to the server?

Thank you so much for your help you guys - I thought my new toy was toast and would spend days trying to fix it. What a great forum.

 

:smileyhappy: 

Please use plain text.
New Member
adrgomes
Posts: 1
Registered: ‎11-18-2009
My Device: Not Specified

Re: EMAIL: Your device had a problem connecting to the server?

[ Edited ]

Worked beautifully for  me too. I had the same problem: for two days I couldn't download e-mails from work and Gmail account. After reading this, I turned my Storm2 off completely and when I turned it back on again, all e-mails sent to me on the past couple of days were downloaded at once. Thanks! Why does it happened?

Please use plain text.
New Member
sirapikin
Posts: 1
Registered: ‎12-04-2009
My Device: Storm 9500

Re: EMAIL: Your device had a problem connecting to the server?

This same thing is happening to me. I left the country for a month, and since I got back and put in my sim card, I haven't been able to receive or send emails. The error message that I get when I try to send emails is that my user account is in SUSPENDED mode, and my device is having a problem connecting to the server when I try to go into my email settings. I've tried the hard reset, and spent an hour and a half with my service provider but they don't know what's wrong either. Anyone have any suggestions?

Please use plain text.