Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Storm™

Reply
New Member
Posts: 1
Registered: ‎10-04-2010
My Device: Blackberry Storm 9500
My Carrier: AT&T

Storm Issues - Help Please

Hey All, I just got a Storm and think its an awesome phone, but it is giving me some major headaches. I will list them, let me know if these are common or if there are any known solutions:

 

 

  • When using the wall charger (either directly into the phone, or via the dock) my Storm locks up then crashes. The second its docked/plugged in it just freezes and reboots. It doesn't do this when using the USB cable with my laptop.
  • Randomly throughout the day the device will reboot
  • Randomly throughout the day the device will say something along the lines of Insert Sim Card and will not work until I reboot the device by pulling the battery
  • Randomly throughout the day I will lose my signal, requiring me to manually enable the radio antenna. For example today I woke up and thought it was strange I had no texts or emails only to find out my signal was gone and I needed to turn the radio back on for NO REASON.
  • I can't use the stock browser because the browser service book will never get pushed to my device. Email works, SMS works, MMS works, but no browser. I am using Opera for now which is fine.
I am running 5.0 fully updated. I love the hardware and the software (when it works) but the issues listed above, happening on a daily basis, are total deal breakers. Do I have a lemon? Is this common? Are there fixes?
Thanks BB community!

 

Highlighted
New Contributor
Posts: 2
Registered: ‎04-07-2010
My Device: storm 9530 touch
My Carrier: Sasktel

Re: Storm Issues - Help Please


I suggest doing backup if necessary then a full wipe. Then from the desktop manager reinstall. I also had to do this. Think of it as a new pc. Sometimes a factory install goes bad