Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Themes & Animated Graphics

Reply
New Contributor
ahmedalsurmi
Posts: 6
Registered: ‎02-29-2012
My Carrier: Blackberry

Need Help By Choosing devices

[ Edited ]

Hello There

i need to create Themes for Blackbery but the problem i dont know the blackberry models well
for example
Nokia use  S60 5th Edition
so if i make a theme for 5800xm the theme will work with all Nokia 5th edition models
in blackberry what kind of device i should use to make theme for OS 4 And OS 5 And OS 6
Sorry for my bad english  
-------------
And from where can i get the SKU Number or code 

Please use plain text.
New Contributor
ahmedalsurmi
Posts: 6
Registered: ‎02-29-2012
My Carrier: Blackberry

Re: Need Help By Choosing devices

three days of waiting :smileysad:

where is the support team 

Please use plain text.
Developer
TheFlowFX
Posts: 166
Registered: ‎02-15-2012
My Carrier: Bags are useful

Re: Need Help By Choosing devices

Sorry for the lack of support my friend,

 

What i suggest you do is create an OS5 or OS6 theme for the 9700 and use it as a template to make others. The OS on each device differs so your gonna have to check that up and carry on from there.

 

As for the SKU, that is not a special number or code. It is just a name you give to your application/theme that when users enter it into the app world search bar, the search results lead directly to your application/theme.

 

Regards,

Flow

If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!

Please use plain text.
Developer
deremi
Posts: 62
Registered: ‎11-17-2009

Re: Need Help By Choosing devices

All you really need to worry about when coding for BB is OS version and dimension.

 

for Example, you can code for OS 5.0 and all devices with 480x360 screen will work.

only problems is the abnormal versions like the 8900 with the 4.6.1 etc

but any OS 5 and up is easily done this way. so if someone with an 8900 manages to upgrade their device to OS 5 - the theme for 9700 works on it.

Please use plain text.