Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Themes & Animated Graphics

Reply
New Contributor
joaquinpb
Posts: 4
Registered: ‎07-16-2012
My Carrier: Personal

Personalized icons

I'm having trouble creating buttons with plazmic.

If I make a rectangle and then I convert it to a button and then I add images to it and animate them depending on the focus or non-focus state when I export it to the SVG file and import it with the theme builder, when I select the button in the navigation panel y see that the red square around it is bigger than the figure.

I was able to correct this difference between the figure and the square but when I preview the theme on the simulator, some items (like the calendar) dissapear.

Is like the button area (marked by the red square) covers the other items even though I was able to make the icon size and it's limits match.

I hope I was able to explain myself. English isn't my natural language so it was difficult for me.

Thanks in advance

Please use plain text.
Developer
webmann
Posts: 45
Registered: ‎10-17-2011
My Carrier: 8ta

Re: Personalized icons

For which phone model is it and what size are your icons?

BlackBerry Junction
http://appworld.blackberry.com/webstore/vendor/18485
Please use plain text.
Contributor
tutibreaker
Posts: 41
Registered: ‎06-11-2012
My Carrier: Claro

Re: Personalized icons

you need to make the right size icons for the device
Th tecnology is upon us !!
Please use plain text.
Developer
waelgasar
Posts: 76
Registered: ‎07-23-2012
My Carrier: vodafone

Re: Personalized icons

which bb ??
Please use plain text.
New Contributor
joaquinpb
Posts: 4
Registered: ‎07-16-2012
My Carrier: Personal

Re: Personalized icons

It's for Torch 9800.
The icon is 36x36 and 25x25 for landscape.
I've modified my icons with GIMP so the have the propper size according to my personalized icons.
Thanks for answering, I hope you can help me
Please use plain text.
Contributor
tutibreaker
Posts: 41
Registered: ‎06-11-2012
My Carrier: Claro

Re: Personalized icons

the icons set for torch are 68x68 if u use icos with lower resolution will be pixelated
Th tecnology is upon us !!
Please use plain text.
New Contributor
joaquinpb
Posts: 4
Registered: ‎07-16-2012
My Carrier: Personal

Re: Personalized icons

Whats the point of using composer then?
Anyway, thats not my problem so...
Please use plain text.
Developer
dwaynedm
Posts: 65
Registered: ‎04-24-2012
My Carrier: --

Re: Personalized icons

Hey,

 

I agree that Composer does screw up things at times.


Though, there actually is a workaround to this.

 

You can change the icon, icon focus, tab and tab focus size directly.

 

This can be done by opening your SVG with notepad and editing the various icon sizes. In this case I edited the icon size from 68 to 80 IN ALL the fields under the specific icon (button) that I wanted to resize. (See the "80" in BOLD throughout the extract of the SVG that I have posted.)


g id="Theme_Button_D_2"
transform="translate(-160 96)">
<!-- pz:tag type="button" -->
<useApplicationIcons app-id="slot3"
normal-group="normalImage"
focus-group="focusImage"/>
<g id="Theme_Button_D_2-Contents">
<!-- pz:tag type="layer" -->
<g id="tabImage_19">
<image id="img_1_1_170"
x="0" y="0" width="80" height="80"
xlink:href="Images/tabImage_img_1_1.png"/>
<image id="img_11_1_171"
x="0" y="0" width="80" height="80"
xlink:href="Images/tabImage_img_1_1.png" visibility="hidden"/>
<image id="img_21_1_172"
x="0" y="0" width="80" height="80"
xlink:href="Images/tabImage_img_1_1.png" visibility="hidden"/>
<image id="img_31_1_173"
x="0" y="0" width="80" height="80"
xlink:href="Images/tabImage_img_1_1.png" visibility="hidden"/>
</g>
<g id="tabFocusImage_21">
<image id="img_1_1_174"
x="0" y="0" width="80" height="80"
xlink:href="Images/tabFocusImage_img_1_1.png" visibility="hidden"/>
<image id="img_11_1_175"
x="0" y="0" width="80" height="80"
xlink:href="Images/tabFocusImage_img_1_1.png" visibility="hidden"/>
<image id="img_21_1_176"
x="0" y="0" width="80" height=80"

xlink:href="Images/tabFocusImage_img_1_1.png" visibility="hidden"/>
<image id="img_31_1_177"
x="0" y="0" width="80" height="80"
xlink:href="Images/tabFocusImage_img_1_1.png" visibility="hidden"/>
</g>
<g id="normalImage_23">
<image id="img_1_1_178"
x="0" y="0" width="80" height="80"
xlink:href="Images/normalImage_img_1_1.png"/>
<image id="img_11_1_179"
x="0" y="0" width="80" height="80"
xlink:href="Images/normalImage_img_1_1.png" visibility="hidden"/>
<image id="img_21_1_180"
x="0" y="0" width="80" height="80"
xlink:href="Images/normalImage_img_1_1.png" visibility="hidden"/>
<image id="img_31_1_181"
x="0" y="0" width="80" height="80"
xlink:href="Images/normalImage_img_1_1.png" visibility="hidden"/>
</g>
<g id="focusImage_25">
<image id="img_1_1_182"
x="0" y="0" width="80" height="80"
xlink:href="Images/focusImage_img_1_1.png" visibility="hidden"/>
<image id="img_11_1_183"
x="0" y="0" width="80" height="80"
xlink:href="Images/focusImage_img_1_1.png" visibility="hidden"/>
<image id="img_21_1_184"
x="0" y="0" width="80" height="80"
xlink:href="Images/focusImage_img_1_1.png" visibility="hidden"/>
<image id="img_31_1_185"
x="0" y="0" width="80" height="80"
xlink:href="Images/focusImage_img_1_1.png" visibility="hidden"/>
</g>
</g>
</g>

 

It is a tiresome process, but needs to be done because of this fault in Composer.

 

Let me know what happens!

 

Happy to Help! :smileyhappy:


1. If any post helps you please click  Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!

:smileyhappy:



Please use plain text.