Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry Themes & Animated Graphics

Reply
New Developer
rorschack23
Posts: 8
Registered: ‎11-18-2009
My Device: Not Specified

Theme file takes more than 30 min to load

[ Edited ]

I am using Theme Studios 5

 

I have a Storm theme (.thm file) that is about 7mb.  For some unknown reasons, TS5 takes more than 30 minutes to load it.  I have an older(beta)  version of the same theme that is about 5mb and it loads right away. 

 

So after the troubled theme loads (after 30 minutes), I tried to narrow down a few things like reset all the backgrounds to default, not loading any SVG file, etc, and then save it as another file, but it would still take a very long time to load.  I am stumped.

 

I would also like to note that the troubled .thm file has 4 .svg (2 for home screens and 2 for lock screens).

 

I uninstalled antivirus.  I thought it might have something to do with Java Runtime Environment, but from my researh, Theme Studios 5 does not require Java.  Am I correct? Dispatcher.exe seems to load java.exe and javaw.exe but it's not important? BTW, I have the latest java (java -version from DOS prompt).

 

I also tried to load the problematic theme on 3 different PC's (2 WinXP, 1 Win7) and no luck!

 

Corruption somehwere?  I don't really want to start from an older theme file as all my work would be lost.  Bummer. :smileysad:

 

Please help.

BlackBerry Development Advisor
cartman
Posts: 39
Registered: ‎11-16-2009
My Device: Not Specified

Re: Theme file takes more than 30 min to load

Try creating a new theme and importing your current one into it.  Except this time don't resolve the SVG files initially.   I think it should come up pretty quickly.  Then add in your SVG files one at a time.

New Developer
rorschack23
Posts: 8
Registered: ‎11-18-2009
My Device: Not Specified

Re: Theme file takes more than 30 min to load

[ Edited ]

Thank you for the suggestion.  I don't know why I didn't think of that before.  However, it is still taking a very long time to import as my CPU is running at 100% for at least 5 minutes so far.  Still going as i'm typing this...almost 10 minutes.  :smileysad:

 

Also, is there some sort of debug or safe mode for themebuilder.exe?  When I exported theme, I see that it creates debug files and then remove them automatically.  I wonder what those debugs files are.

 

TIA!

New Developer
trafsta
Posts: 16
Registered: ‎11-25-2009
My Device: Not Specified

Re: Theme file takes more than 30 min to load

Glad to know I'm not the only one experiencing this problem. I posted my problem here

Developer
burksfinancial
Posts: 26
Registered: ‎10-10-2009
My Device: Not Specified

Re: Theme file takes more than 30 min to load

Yeah, i made a very very very basic theme - with a completely black background...just to test it out on my 8830. Took freaking forever to load on my 8830.

 

After that, phone kept resetting constantly......i finally removed the theme, but it still was resetting constantly. Finally fixed the issue. I probably won't mess with custom themes any longer lol i'll be satisfied with the one i have --- at least until I upgrade to my tour.

 

New Developer
rorschack23
Posts: 8
Registered: ‎11-18-2009
My Device: Not Specified

Re: Theme file takes more than 30 min to load

I have noticed that the reason for the thm file taking a long time to load was that I work on the theme on two different PC.  If I continue to work on the same theme file on a different or second PC with different path to the working folders, then on that one, it takes a very long time to load.  It seems to be searching or trying to find the path to all the files and get hung up somewhere.  Very frustratating!  Anyone at RIM reading this forum or what?