Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Torch™

Reply
New Contributor
Posts: 3
Registered: ‎12-12-2012
My Device: BlackBerry Torch 9860
My Carrier: O2

BB key and return key not working

Hi I have a BB Torch 9860, when I have the phone in a case or in my pocket I have trouble with the BB menu key and the return key not responding. I have tried many different things to get it to work again including pressing on the buttons many times one after the other. This sometimes works! I also try removing battery the putting it back in, this also sometimes works. If I leave my phone on the arm of the sofa when not in use it works fine. This is really confusing! is this a software error or phone error? it only seamed to start doing it when I updated the software to BB 7 from BB 6. Any suggestions as to what is going on please?

Thank You

Steve

Elite II
Posts: 9,321
Registered: ‎04-01-2008
My Device: Torch 9800
My Carrier: grameenphone

Re: BB key and return key not working

You can try resetting the device by pulling the battery out from your phone. If that doesn't work then consider updating/reinstalling your device OS. If performing both doesn't resolve the issue then it can be said that it's a hardware issue. NOTHING can be done!

tanzim                                                                                  
If your query is resolved then please click on Accept as Solution

Click on the LIKE on the bottom right if the post deserves credit

New Contributor
Posts: 3
Registered: ‎12-12-2012
My Device: BlackBerry Torch 9860
My Carrier: O2

Re: BB key and return key not working

Hi, thanks for replying. I have tried all of the above but it is still intermittent. I have read a blog with a similar fault on a Torch 9800 and the reply said that the software developers are creating a fix in the software. I have no idea how to get hold of BlackBerry for an answer if it is software or hardware fault, any idea's please?