Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Torch™

Reply
New Contributor
marko_ks037
Posts: 2
Registered: ‎01-12-2013
My Device: torch 9810
Accepted Solution

Problem with data services

I want to use internet on my phone only by wifi, so obviosly I turned off data services in mobile network set up. Problem is when I'm home, or wherever I can conect to a wifi network, i'm getting a message saying that there is problem, and if it persists i should contact my provider. Am i doing something wrong, is the a solution?

Please use plain text.
Elite II
BillJ
Posts: 8,978
Registered: ‎01-05-2009
My Device: BlackBerry Z30

Re: Problem with data services

[ Edited ]

Browsing the internet over Wi-Fi is still using data so if you turn off your Data Services, you're in essence cutting off your phone from ALL data.

The thing to do is to leave your Data Services turned on.  When a Network Connection and a Wi-Fi connection are both present, your phone will default to the Wi-Fi connection for your internet traffic so you won't be using any data from your  cell carrier.  To confirm how your phone is connecting, turn on both Network and Wi-Fi then on your homescreen follow Manage Connections>Service Status.  Look under BlackBerry Internet Service and it should show that you're connected via Wi-Fi.

 

 

I hope that helps you.  :smileyhappy:


- If my response has helped you, please click "Options" beside my post and mark it as solved. Clicking the "thumbs up" icon near the bottom of my response would also be appreciated.



Please use plain text.
New Contributor
marko_ks037
Posts: 2
Registered: ‎01-12-2013
My Device: torch 9810

Re: Problem with data services

Well I solved the problem, but before your reply and now I’m actually, baffled! And before i continue, let me say thank you very much for the quick response! Here's what happened. I updated my phone from 7.0 to 7.1. made same set up about data services and it works. Data services are off, I’m connected to a network and a wifi and everything works fine. What happened during update, I have no clue. Now here's something that may clarify the picture: I don’t have blackberry services activated on my number....and....when I checked under BlackBerry Internet Service as you explained, it says not connected. Anyway everything works now, and your helped me understand how these things work with blackberries.  Thanks once again!!!

Please use plain text.
Elite II
BillJ
Posts: 8,978
Registered: ‎01-05-2009
My Device: BlackBerry Z30

Re: Problem with data services

For some strange reasons, you can now surf with your Data Services turned OFF.  This is a new feature in OS 7 (or 7.1, I can't remember with which OS it was introduced).  There was a time when you needed Data Services turned ON to surf, even just with Wi-Fi.

 

 

However, I'm glad things are working for you now.  :smileyhappy:


- If my response has helped you, please click "Options" beside my post and mark it as solved. Clicking the "thumbs up" icon near the bottom of my response would also be appreciated.



Please use plain text.