Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Torch™

Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎11-04-2011
My Device: 9800
My Carrier: Vodafone

Recurring Problem with Media Card

Hi

 

I've spotted that there seem to be quite a lot of posts here and elsewhere on the internet about media cards failing.  You get a message saying that the media has broken, then a follow up one about repairing lost clusters etc.

 

This happened to me with the 4MB card supplied with my Torch 9800.  I bought a new one instead, a 32MB one, which has worked perfectly for about three weeks.  Today, it did the same thing.

 

Luckily, all the music and pictures I have on the card have already been backed up to my PC.  I learned my lesson from the death of my 4MB card, and now back up to PC every time I buy a new MP3 file, or at the end of the day when I've been taking photos.  I really don't think it's good that I should have to do this, but it seems that my approach was right, given what happened to my 32MB card today.

 

Why does this keep happening?  Is there something we should do (or avoid doing)?  Maybe removing media cards before accepting software upgrades?  It's just very weird that this has now happened to me twice, with different media cards, and that there seem to be a lot of other people affected by the same problem.

 

What is it that is killing so many media cards?  It isn't something that ever affected me when I had an iPod.  I hope there is something you can advise in order to stop this happening again, because it really puts me off the Torch, which I really like apart from this.

 

Thanks

 

New Contributor
Posts: 3
Registered: ‎11-06-2011
My Device: BlackBerry Torch 9810
My Carrier: 3

Re: Recurring Problem with Media Card

Hi

 

I am in the same situation as you and really regret getting Blackberry Torch.

I never had any problems with my old iPhone.

I havea 32Gb card. I re-formatted it a number of times and tried to sync it with my  I-tunes or Media Library. I also tried adding songs by dragging and dropping them ...but all this only works up to about 190 songs.

I also keep losing pictures. Either I can see them on my BB, but my laptop says that the format of the media file is not supported. Or...I take a picture, can view it immediately after...but when I try to view the picture again a little bit later, I get a blank/black screen. Pictures just disappear.

I am genuinely shocked that Blackberry are so behind iPhone with supporting a basic function of using the phone as a media player! Even Samsung Galaxy seems to work for my friends. Blackberry is the worst example I have seen so far.

I have been through many posts on forums, but haven’t seen a solution yet.

If I find out how to fix the SD card to store more music then 190 songs, I will post it here.

 

VM

New Contributor
Posts: 2
Registered: ‎09-07-2011
My Device: Blackberry Torch 9800
My Carrier: Att

Re: Recurring Problem with Media Card

My card has started doing the same thing. And then it asks me to repair and clusters and now ive lost all my pictures several times. I've tried connecting with the computer, restarting removing the card and putting it back in. Please help! The phone also wont back up any media including music and videos.

Help!

New Contributor
Posts: 3
Registered: ‎11-06-2011
My Device: BlackBerry Torch 9810
My Carrier: 3

Re: Recurring Problem with Media Card

I am not sure whether it would help...but my problem seems to be solved by a card replacement. What I was trying to use previously was a faulty card, I was missold a product on Amazon. 

I now replaced the SD card with a genuine SanDisk card, 16GB, and had no problems uploading about 2000 songs in different formats - MP3 and MP4.

Make sure your card is not faultySmiley Happy

 

Vika

New Contributor
Posts: 3
Registered: ‎11-04-2011
My Device: 9800
My Carrier: Vodafone

Re: Recurring Problem with Media Card

Thanks Vika.  Both my original media card, and the replacement one, were the genuine article.  The 32GB one failed again a week ago, I reformatted it, loaded all the music back on to it, and it all seems OK again, but I just wonder how long before the Torch kills the card again.

 

No-one seems to know what is causing this, and it looks like it is a pretty common problem.