Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Torch™

Reply
Developer
Posts: 25
Registered: ‎01-18-2011
My Device: 850>6230>7230>8700>9000>9700>9900>Z10>Z30
My Carrier: Rogers

Seemingly random crashing

Hi All,

 

We ordered 3 9800's when they first came to Rogers and for the most part have been decent phones, i.e.. when I ask the user if they want to revert to the 9700 to clear up an issue the answer is no and always because they like the bigger screen size...anyway to the point; all the users have been experiencing random crashes with their phones.  One user is either more vocal to me about it or is dealing with more issue as we have had Rogers replace the device 3, or is it 4 times now, hoping to either fix the issue or raise awareness there is an issue.  The only pattern we see is pairing the Bluetooth with their vehicles, which each user does,  and the user on which it crashes most is of course the person who is on the phone most.  She now consciously waits until she passes a certain street to give the phone time to pair before use (she said it helps...); however she will be out walking and the phone will just crash on her as well.

 

I know this is not much to go on, and I have taken the phone to her car and randomly tested all scenarios for 30 mins and never a crash, of course.  There is nothing 3rd party installed on the phone, out of the box, connected to BES and back in the field.

 

Any thoughts..?

 

 

Retired
Posts: 3,246
Registered: ‎07-26-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Seemingly random crashing

Hello CarlosHenriques and welcome to the BlackBerry Support Community Forums.

 

It might possible there is a corruption in the Bluetooth database on the device.

 

Since the device is on a BES, try the follow:

 

Do a clean software reload on the device as shown in KB11320

After the reload completes, re-Enterprise activate the device

Once activation is complete, delete the Desktop [SYNC] service book (found in Options>Device>Advanced System Settings>Service Book)

Clear the Bluetooth database as shown in KB10167

Resend the service books from the BES to restore the Desktop [SYNC] service book back to the device

Re-pair the device with the vehicle and test

 

Let me know how you make out.

 

Thanks!

-HMthePirate

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!



Developer
Posts: 25
Registered: ‎01-18-2011
My Device: 850>6230>7230>8700>9000>9700>9900>Z10>Z30
My Carrier: Rogers

Re: Seemingly random crashing

Followed the steps, deleted "Bluetooth Options" from the device succesfully; however when I went back into the Bluetooth options the car is still paired.  Is this correct?

Retired
Posts: 3,246
Registered: ‎07-26-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Seemingly random crashing

 


CarlosHenriques wrote:

Followed the steps, deleted "Bluetooth Options" from the device succesfully; however when I went back into the Bluetooth options the car is still paired.  Is this correct?


 

The pairing will still be listed but the database is reset.

 

You can manually delete the pairing by highlighting it, hit Menu and select Delete.

 

Let me know how you make you.

 

Thanks!

 

 

-HMthePirate

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!



Developer
Posts: 25
Registered: ‎01-18-2011
My Device: 850>6230>7230>8700>9000>9700>9900>Z10>Z30
My Carrier: Rogers

Re: Seemingly random crashing

Ok, yes that is what I did (Menu, Delete).

 

So the phone was paired with the car again on Tuesday, and it is Friday now and so far no problems!!  Also pairing with the car now happens on first attempt whereas in the past "it took me several attempts".

 

So this seems to have solved the issue, but I am curious as to why, any thoughts on that?

 

We upgrade blackberry's quite often and only since OS6 has this been a problem, seems like the saved bluetooth settings in the BES for OS5 and previous don't meesh..??

 

I will try this reset on the other users, one in particular has an issue paring to his one car, whereas his other car is totally fine.  This is also a new issue since the Torch, all was well with the Bold.  Will report back if this issue resolves as well, have a feeling it will.

 

Really appreciate the help!

Developer
Posts: 25
Registered: ‎01-18-2011
My Device: 850>6230>7230>8700>9000>9700>9900>Z10>Z30
My Carrier: Rogers

Re: Seemingly random crashing

I guess I spoke too soon, so her phone crashed again today.  This is the description of the situation

 

"Just turned on the car, started driving, attempted a call, showed "phone" on the cars display, showed connected on the bb, but there was no sound and then the phone shutdown and rebooted"

 

Thought it was solved...

Retired
Posts: 3,246
Registered: ‎07-26-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Seemingly random crashing

If you activate the user on a different BlackBerry, does the same behavior happen?

 

If you activate that device with another user and pair to their vehicle, does the device crash and reboot?

 

Has she contact her car's manufacturer to see if the vehicle needs an upgrade to the Bluetooth kit?

 

Have you tried pairing the BlackBerry to a Bluetooth headset and see if the issue reoccurs?

-HMthePirate

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!



Developer
Posts: 25
Registered: ‎01-18-2011
My Device: 850>6230>7230>8700>9000>9700>9900>Z10>Z30
My Carrier: Rogers

Re: Seemingly random crashing

If you activate the user on a different BlackBerry, does the same behavior happen?

This is the third Torch she has tried, the Bold 9000 and 9700 worked 100%

 

If you activate that device with another user and pair to their vehicle, does the device crash and reboot?

Have not tried this step.

 

Has she contact her car's manufacturer to see if the vehicle needs an upgrade to the Bluetooth kit?

I can try make this call and see what BMW has to say.

 

Have you tried pairing the BlackBerry to a Bluetooth headset and see if the issue reoccurs?

Have not tried this.

I will try see if I can get to those last 3 items and report back.

New Member
Posts: 1
Registered: ‎02-03-2011
My Device: 9800 Torch
My Carrier: UK Vodafone Sim / Rogers Handset

Re: Seemingly random crashing

Interestingly I have a Rogers handset unlocked, running a UK Vodafone sim.  I drive an Audi RS4 and have exactly the same problem as you describe.  My Bold 9700 worked perfectly with the Audi but my Torch randomly disconnects if I do not use my phone within a few minutes of getting in the car and then seems to randomly reconnect.  The crashing then occurs if I get out of the car and the phone seemingly still indicates the Bluetooth B as highlighted suggesting its still connected.  If I then go into connections and turn the Bluetooth off its fine; if I leave it and try to make a call it crashes!  Have you managed to resolve this, it is possible along with the poor battery life the only down fall of the model which is a shame as it is a fantastic tool otherwise!

Developer
Posts: 25
Registered: ‎01-18-2011
My Device: 850>6230>7230>8700>9000>9700>9900>Z10>Z30
My Carrier: Rogers

Re: Seemingly random crashing

drydenec, are you on a BES server?

Still no resolution to this problem, we called BMW and they don't have any updates for the Bluetooth kit.